Author Topic: rpm packages for C::B?  (Read 7346 times)

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
rpm packages for C::B?
« on: August 03, 2005, 08:00:39 pm »
I was wondering - how hard it is to make RPM packages for Code::Blocks? What are the difficulties and complications?

Offline darklordsatan

  • Almost regular
  • **
  • Posts: 132
    • http://eviltrend.sf.net
Re: rpm packages for C::B?
« Reply #1 on: August 03, 2005, 09:11:06 pm »
Making rpms is a piece of cake. But the difficulties here is that most people havent been able to compile it successfully (Am I right?), so until we have some piece of sourcecode that actually compiles well, with no probs under a Linux box with wx6.1 and else, there should be no prob providing them.

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: rpm packages for C::B?
« Reply #2 on: August 03, 2005, 11:12:47 pm »
Maybe this is going to the extreme, but wouldn't it be easier to add the whole wxWidgets library (i know, it sounds crazy, but it might just work!) so that we compile C::B and our own tested wxWidgets without any problems whatsoever?

Offline Funto

  • Multiple posting newcomer
  • *
  • Posts: 81
Re: rpm packages for C::B?
« Reply #3 on: August 04, 2005, 12:59:04 am »
Isn't there a dependency system with RPM packages?
I know the wxWidgets team proposes RPMs for wx2.4 (not for 2.6); it would be possible to precise a dependency towards these RPMs.

darklordsatan >> compiling doesn't seem to be the real big problem now the Makefiles are up-to-date, the problems are the crashes; this is because the developpers mainly work on Windows :(

Offline darklordsatan

  • Almost regular
  • **
  • Posts: 132
    • http://eviltrend.sf.net
Re: rpm packages for C::B?
« Reply #4 on: August 04, 2005, 01:16:05 am »
compiling doesn't seem to be the real big problem now the Makefiles are up-to-date, the problems are the crashes
I wasnt aware, since my Slack box is broken ATM so I havent had the chance to test it myself.
Well, I guess we need to first make sure it doesnt crash (that much at least :oops:) in order to provide an rpm. Dont know, just MHO.
Probably we need someone to take care of the Linux port? (Im not aware if someone other than yiannis or rick is doing this ATM).

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: rpm packages for C::B?
« Reply #5 on: August 04, 2005, 09:07:07 pm »
Yes, we need a Linux dev in here!

Offline fiammy

  • Multiple posting newcomer
  • *
  • Posts: 46
    • Nebulagame
Re: rpm packages for C::B?
« Reply #6 on: August 04, 2005, 09:55:14 pm »
The problem is that most Linux distros at the moment have some flavour of wxWidgets 2.5.x standard included. I don't know what happens if you install an older version on the system, but you could get away with it if you just include the static version of the libs.

what is needed for an RPM build is a .spec file. I've never done that before, so I don't know if it is complicated or not.