Author Topic: Cannot debug - PSAPI.DLL is missing  (Read 7788 times)

davar

  • Guest
Cannot debug - PSAPI.DLL is missing
« on: July 26, 2005, 08:37:40 am »
Hi all,

C::B RC1 is great IDE. Only one problem on W98SE Czech version: When I try to run debugger, I get message "cannot find PSAPI.DLL". I had no such problem with previous build(s) of C::B. My project is compiled by mingw32 (included in C::B) and debugging info are set ON.

Thanks for any help.

Josef


Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: Cannot debug - PSAPI.DLL is missing
« Reply #1 on: July 26, 2005, 09:11:04 am »
Sorry about that. It seems we haven't put the note on the website yet:

Note for Win98/ME users:
Debugging with Code::Blocks-MinGW bundle under Windows 98/ME will not work out of the box for you. This is because we 've updated the included GDB to version 6.3 which works on NT-class machines only (NT/2000/XP/2003).
All is not lost however. You can go to the MinGW site and download an older GDB version which works for Windows 98/ME. Code::Blocks will happily use it, as long as you install it in the Code::Blocks installation folder ;)

Yiannis.
Be patient!
This bug will be fixed soon...

davar

  • Guest
Re: Cannot debug - PSAPI.DLL is missing
« Reply #2 on: July 26, 2005, 11:14:50 am »
Thanks Yiannis.

I got version     gdb-5.2.1-1.exe installed  package and all works OK.

In download sectio: maybe some note for W98/Me users + link to file which should be used will be helpfull.

Thanks for quick response, keep good work. Your IDE is really one of the best and it's joy to work with that. Especially thanks for OpenWatcom support, in me experiences, that is one of best optimizing compilers.



Josef


Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: Cannot debug - PSAPI.DLL is missing
« Reply #3 on: July 26, 2005, 03:51:33 pm »
I modified the downloads page. Thanks for your suggestion :)

darklordsatan

  • Guest
Re: Cannot debug - PSAPI.DLL is missing
« Reply #4 on: July 26, 2005, 05:08:05 pm »
This is because we 've updated the included GDB to version 6.3 which works on NT-class machines only (NT/2000/XP/2003).
Im curious. I know the 6.x branch is the stable on *nix, but where did you get the binaries for that, Am I missing something since the MinGW website only shows the old 5.x, or did you port it yourself?

Offline Profic

  • Multiple posting newcomer
  • *
  • Posts: 56
Re: Cannot debug - PSAPI.DLL is missing
« Reply #5 on: July 26, 2005, 05:45:25 pm »
Im curious. I know the 6.x branch is the stable on *nix, but where did you get the binaries for that, Am I missing something since the MinGW website only shows the old 5.x, or did you port it yourself?
It's in candidate or snapshot not in release.
Not fear, nor tears can reach me now, the light seems so clear as the night fades away (c) Tristania - Beyond The Veil