Author Topic: [SOLVED] Linking error  (Read 4093 times)

Offline David Perfors

  • Developer
  • Lives here!
  • *****
  • Posts: 560
[SOLVED] Linking error
« on: July 01, 2005, 12:15:57 pm »
I am trying to compile CodeBlocks on Linux and everything is going fine, until the process wants to link devel/codeblocks.exe (Note the exe, shouldn't that be changed?)
I get the following error:
Code
Linking executable devel/codeblocks.exe...
/usr/local/lib/libwx_gtk2-2.4.so: undefined reference to `_gtk_accel_group_detach'
/usr/local/lib/libwx_gtk2-2.4.so: undefined reference to `_gtk_accel_group_attach'
/usr/local/lib/libwx_gtk2-2.4.so: undefined reference to `_gtk_rc_context_get_default_font_name'
collect2: ld returned 1 exit status
make: *** [devel/codeblocks.exe] Error 1

I am using wxWindows 2.4.2 with gtk+2 support (because I wanted to add unicode support), the latest cvs version of C::B (updated 1 july 2005 just half an hour before posting)

Any ideas?
OS: winXP
Compiler: mingw
IDE: Code::Blocks SVN WX: 2.8.4 Wish list: faster code completion, easier debugging, refactoring

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
[SOLVED] Linking error
« Reply #1 on: July 01, 2005, 01:07:27 pm »
It seems to me that someone has not read the wiki    ;)
Yiannis.
Be patient!
This bug will be fixed soon...

Offline David Perfors

  • Developer
  • Lives here!
  • *****
  • Posts: 560
[SOLVED] Linking error
« Reply #2 on: July 01, 2005, 01:50:38 pm »
hehe, I thought I did that, but that was when I compiled a unicode version :oops:

--edit--

It worked, Compiling plugins now... :lol:
OS: winXP
Compiler: mingw
IDE: Code::Blocks SVN WX: 2.8.4 Wish list: faster code completion, easier debugging, refactoring