Author Topic: unicode file and CB (suse 10.1)  (Read 4050 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5297
unicode file and CB (suse 10.1)
« on: June 27, 2006, 09:37:52 pm »
On SUSE 10.1 (64 bit) :

This zip file (http://forums.codeblocks.org/index.php?action=dlattach;topic=3226.0;attach=1027) contains a main.cpp.
When I open this main.cpp I can't see anything.
Similar thing happens with the Cb source : tinystr.cpp ?

I remember something like this happening on windows, but can't remember how to solve it.

Any ideas ??

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9615
Re: unicode file and CB (suse 10.1)
« Reply #1 on: June 27, 2006, 09:45:47 pm »
Any ideas ??
Play around Settings -> Editor -> "Default ewncosing when opening files". Maybe "default" or "ISO8859-1" (or any other ISO page that is appropriate for you) resolves this issue.
With regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5297
Re: unicode file and CB (suse 10.1)
« Reply #2 on: June 27, 2006, 09:54:47 pm »
it's UTF-8. So that should be ok. Unicode is there to solve the problem ... ;-) ... sometimes ...

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9615
Re: unicode file and CB (suse 10.1)
« Reply #3 on: June 27, 2006, 10:11:29 pm »
it's UTF-8.
Good point. If I set this to UTF-8 suddenly I don't see anything, too. Even on Windows. That's quite strange, isn't it?!
With regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ