Author Topic: wxSmith Question  (Read 3117 times)

Offline Frank_CB

  • Almost regular
  • **
  • Posts: 148
wxSmith Question
« on: January 04, 2023, 08:17:18 pm »
Am attempting to follow the 'Hello World' tutorial from C::B's wiki page, but getting to the point where I need to select the standard palette of items it comes up blank (no buttons). All the other palettes display buttons. Am using Windows 10 (64-bit) on a 64-bit platform.

Any suggestions of what is causing this behavior?

Regards.

Offline Miguel Gimenez

  • Developer
  • Lives here!
  • *****
  • Posts: 1591
Re: wxSmith Question
« Reply #1 on: January 04, 2023, 10:47:13 pm »
Which version of C::B are you using?
Are there errors in the log tab?
Can you try the last nightly build?

Offline Frank_CB

  • Almost regular
  • **
  • Posts: 148
Re: wxSmith Question
« Reply #2 on: January 05, 2023, 12:32:09 am »
Used version 13139 of C::B using GCC 12.3

The Build Log:
Code
-------------- Build: Debug in Tut0r1 (compiler: GCC Compiler)---------------

g++.exe -pipe -mthreads -D__GNUWIN32__ -D__WXMSW__ -DWXUSINGDLL -Winvalid-pch -include wx_pch.h -DWX_PRECOMP -Wall -g -D__WXDEBUG__ -IC:\wxWidgets-3.2.1\include -IC:\wxWidgets-3.2.1\lib\gcc_dll\mswd -c C:\Sandbox1\Tut0r1\wx_pch.h -o wx_pch.h.gch\Debug_wx_pch_h_gch
windres.exe -IC:\wxWidgets-3.2.1\include -IC:\wxWidgets-3.2.1\lib\gcc_dll\mswd  -J rc -O coff -i C:\Sandbox1\Tut0r1\resource.rc -o obj\Debug\resource.res
In file included from C:\wxWidgets-3.2.1\include/wx/defs.h:45,
                 from C:\wxWidgets-3.2.1\include/wx/wxprec.h:12,
                 from ./wx_pch.h:14,
                 from <command-line>:
C:\wxWidgets-3.2.1\include/wx/platform.h:159:10: fatal error: wx/setup.h: No such file or directory
  159 | #include "wx/setup.h"
      |          ^~~~~~~~~~~~
compilation terminated.
Process terminated with status 1 (0 minute(s), 0 second(s))
1 error(s), 0 warning(s) (0 minute(s), 0 second(s))
 

Will try the Last Nightly.

Offline Frank_CB

  • Almost regular
  • **
  • Posts: 148
Re: wxSmith Question
« Reply #3 on: January 05, 2023, 01:10:36 am »
Using the Last Nightly version (13107), I get the same response and build log.

Offline Miguel Gimenez

  • Developer
  • Lives here!
  • *****
  • Posts: 1591
Re: wxSmith Question
« Reply #4 on: January 05, 2023, 10:31:45 am »
The log tab is the one titled "Code::Blocks" in the "Logs & Others" pane. You can activate a more exhaustive log tab running "codeblocks /d" from a console.

Offline gd_on

  • Lives here!
  • ****
  • Posts: 799
Re: wxSmith Question
« Reply #5 on: January 05, 2023, 10:50:23 am »
this :
Code
C:\wxWidgets-3.2.1\include/wx/platform.h:159:10: fatal error: wx/setup.h: No such file or directory
  159 | #include "wx/setup.h"
      |          ^~~~~~~~~~~~
suggest that the path to this setup.h is not set correctly.
This file is normaly built when you build your wxWidgets dll and is located in C:\wxWidgets-3.2.1\lib\gcc_dll\mswu\wx (for a non debuging, unicode wxWidgets build).
So, include C:\wxWidgets-3.2.1\lib\gcc_dll\mswu in your compiler search path.
For a debuging, unicode wxWidgets, maybe it's mswud and not mswd...
Note that thiis setup.h is moreless a copy of the generic setup.h found in C:\wxWidgets-3.2.1\include\wx\msw, but adapted to your specific generated library.
« Last Edit: January 06, 2023, 05:54:44 pm by gd_on »
Windows 11 64 bits (23H2), svn C::B (last version or almost!), wxWidgets 3.2.5 (tests with 3.3), Msys2 Compilers 14.1.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\msys64\mingw64) or 32 bits (dwarf2, posix  in C:\msys64\mingw32).

Offline Frank_CB

  • Almost regular
  • **
  • Posts: 148
Re: wxSmith Question
« Reply #6 on: January 06, 2023, 02:59:49 am »
Nothing in Codeblocks window indicating errors.

Made entries, or edited, entries in Build Options Search directories and Linker. Was able to build both debug and release versions, both showing an empty dialog. But still no selections under standard tab. Changed to advanced tab and selected the calendar button and placed it in the .wxs panel. Built both debug and release versions again,  with a calendar showing up in the output. Still nothing in the Codeblocks window indicating errors. Still nothing under the Standard tab.

@gd_on, @Miguel Gimenez:
Thank you. Your comments were enlightening.

Regards.

Offline gd_on

  • Lives here!
  • ****
  • Posts: 799
Re: wxSmith Question
« Reply #7 on: January 06, 2023, 06:04:01 pm »
Frequently, when I work with wxsmith and modify something in the interface, I see that when I build the program that the wxs file is not saved automatically before the build: the name of this wxs file has still an * appended. No such problems with .c, .cpp or .h files. So, before generating, I systematicaly save explicitly the wxs file (right click on the tab and save).
« Last Edit: January 06, 2023, 06:31:21 pm by gd_on »
Windows 11 64 bits (23H2), svn C::B (last version or almost!), wxWidgets 3.2.5 (tests with 3.3), Msys2 Compilers 14.1.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\msys64\mingw64) or 32 bits (dwarf2, posix  in C:\msys64\mingw32).

Offline rts2003

  • Multiple posting newcomer
  • *
  • Posts: 10
Re: wxSmith Question
« Reply #8 on: January 07, 2023, 03:30:50 am »
Have you try following this video?

Offline Frank_CB

  • Almost regular
  • **
  • Posts: 148
Re: wxSmith Question
« Reply #9 on: January 17, 2023, 09:55:03 pm »
Still experiencing problems with wxSmith's tutorial 'Hello World'. Can substitute a Calendar item from the advanced tab and that allows me to complete the tutorial. C::B now has 10 tabs in the .wxs window where as the tutorial only shows three. The standard tab has no buttons now where the tutorial showed 12+ buttons. Where have the standard buttons gone? I just downloaded the last nightly ( r13107) and that is also missing it's standard buttons. SVN r13149 still hasn't found the missing buttons. Is this a bug or have the missing buttons been redistributed to the seven new tabs?

@rts2003:
Yes,  i  did watch it and saw the Hello World window displayed. Both the tutorial and version of C:B were probably older than the ones I am trying to use.

Regards.
« Last Edit: January 18, 2023, 08:59:34 pm by Frank_CB »

Offline Frank_CB

  • Almost regular
  • **
  • Posts: 148
Re: wxSmith Question
« Reply #10 on: January 25, 2023, 10:22:14 pm »
Does anybody know where I would find the missing buttons? The attachment to this reply is a cropped screenshot of the tutorial page showing the Standard tab with the buttons. Nightly r13159 displays a blank Standard tab. The other tabs all display buttons.

Offline Miguel Gimenez

  • Developer
  • Lives here!
  • *****
  • Posts: 1591
Re: wxSmith Question
« Reply #11 on: January 26, 2023, 10:21:39 am »
Looks like you are the only person with this problem. AFAIK there is no way to hide the icons in the tab, and the code filling the tabs is the same for all.

You can try renaming the default.conf file (in %appdata%\CodeBlocks), C::B will create a clean one for you to test.