Author Topic: "Cannot open file" error when stepping through program  (Read 1434 times)

Offline spflanze

  • Almost regular
  • **
  • Posts: 133
"Cannot open file" error when stepping through program
« on: April 20, 2019, 05:32:44 am »
When I attempt to step through my wxWidgets project, which is a wizard created starter file using wxSmith, I get this error:
[debug]> step
[debug]18 in C:/crossdev/src/mingw-w64-v4-git/mingw-w64-crt/crt/crt0_c.c
[debug]> info frame
[debug]Stack level 0, frame at 0x22fe60:
[debug] rip = 0x833f3d in main (C:/crossdev/src/mingw-w64-v4-git/mingw-w64-crt/crt/crt0_c.c:18); saved rip = 0x4013e8
[debug] source language c.
[debug] Arglist at 0x22fe50, args: flags=<optimized out>, cmdline=<optimized out>, inst=<optimized out>
[debug] Locals at 0x22fe50, Previous frame's sp is 0x22fe60
[debug] Saved registers:
[debug]  rip at 0x22fe58, xmm15 at 0x22fe58

Cannot open file: C:/crossdev/src/mingw-w64-v4-git/mingw-w64-crt/crt/crt0_c.c
At C:/crossdev/src/mingw-w64-v4-git/mingw-w64-crt/crt/crt0_c.c:18

There is no directory named  C:/crossdev/ . Mingw was installed at one point, but has been removed. I am using TDM-GCC-64 instead. Where in Code::Blocks is this directory, that it does not find, specified? What should be in its place?

I am using the g++ compiler. In release mode the application runs. Code::Blocks version is 17.12 in a Windows 7 OS.
« Last Edit: April 23, 2019, 02:37:23 am by spflanze »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 13439
    • Travis build status
Re: "Cannot open file" error when stepping through program
« Reply #1 on: April 20, 2019, 10:34:52 am »
You c runtime has been compiled with debug info, but the debug info points to the file on the build machine.
You don't have it on your machine. Just ignore this.
Probably in the future I'll add a debugger option to prevent stopping in similar files.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]