Author Topic: self build revision 10561 is not working on ubuntu 15.10  (Read 2343 times)

Offline eckard_klotz

  • Almost regular
  • **
  • Posts: 176
self build revision 10561 is not working on ubuntu 15.10
« on: November 10, 2015, 04:32:54 am »
Hello Everybody.

Last Sunday I have installed the new Ubuntu 15.10 and had to recognize that my Code::Blocks build was not working anymore. After some investigation I found out that the wxWidgets library was exchanged against a newer one (still 2.8.12). Thus I decided to rebuild Code::Blocks by my self.

In the first step I have checked out the last revision 10561 and this in a new trunk than I run configer, make and make install (as discussed in the last comment of the  topic http://forums.codeblocks.org/index.php/topic,19807.0.html) and all this seemed to run without problems. However Code::Blocks is still not able to run.

C::B starts first normally and stops than with an error-message that the file autosave.zip could not be found. After kicking OK a debug message will be mentions that the attached xml-file was created.

If I run the script-file called "run.sh" located in the folder output where the C::B binaries are in the terminal I get the following output:
Quote
Starting Code::Blocks svn build  rev 10561 Nov  9 2015, 05:21:22 - wx2.8.12 (Linux, unicode) - 32 bit
Initialize EditColourSet .....
Initialize EditColourSet: done.
Loading menubar...
Autosave: loaded
ProjectsImporter: loaded
OccurrencesHighlighting: loaded
Plugin resource not found: .zip
Invalid manifest file for: SpellChecker
Plugin resource not found: libdefaultmimehandler.zip
Plugin resource not found: libopenfileslist.zip
Plugin resource not found: libscriptedwizard.zip
Plugin resource not found: libcompiler.zip
Plugin resource not found: libtodo.zip
Plugin resource not found: libastyle.zip
Plugin resource not found: libdebugger.zip
Plugin resource not found: libabbreviations.zip
Plugin resource not found: libcodecompletion.zip
Plugin resource not found: libclasswizard.zip
Loaded 4 plugins
Loading:
Autosave
Manager failed to access XRC resource ''.
 
     

I hope you are able to help me again.

Best Regards,
                    Eckard Klotz.

Offline eckard_klotz

  • Almost regular
  • **
  • Posts: 176
Re: self build revision 10561 is not working on ubuntu 15.10
« Reply #1 on: November 10, 2015, 07:29:34 am »
Hello again.

I think I have it now.

What I have not seen was that the boost-libraries where not installed. This was mentioned by the output of the command configure. I had to run first. Even configure was not able to do its job I was able to run make and make install since the trunk-folder was not as clean as I thought.
However when I tried it out with a new fresh trunk-folder and there it was not possible to run make and make install after configure without installing boost. So I started the Ubuntu software centre and installed boost and what should I say I was able to runn the build-process completely and with success.

I still wonder why I was able to run the build process before with the older Ubuntu (as discussed in the last comment of the  topic http://forums.codeblocks.org/index.php/topic,19807.0.html). May be the upgrade-process of Ubuntu has deleted the boost-library installed before.

As a result for other users allow me to provide my build-steps:
  • I created in my home-directory a folder path
    Tools/CodeBlocks/CB_xyz
    where CB_xyz is separate build-destination folder for the revision to build (in this case it was actualy CB_10561)
  • I renamed the existing trunk-folder and run in its parent folder the command 
    svn checkout svn://svn.code.sf.net/p/codeblocks/code/trunk
    to get a new fresh revision
  • I used in the svn-root the command
     sudo ./configure --with-contrib-plugins=all --prefix=/home/eckard/Tools/CodeBlocks/CB_xyz
     (please reffer to: http://forums.codeblocks.org/index.php/topic,18421.msg125990.html#msg125990
     and note that I already run ./bootstrap in my trials before.)
  • Then I  run sudo make
  • And finaly I run sudo make install
Very important is to check step for step that no error-message occurs and except the svn checkout I had to run all commands with admin-rights (sudo ...)

Dear developers I made in the last view days a lot of experiments and it may be that the list above may not contain a special action I took but I have forgotten. Thus please check my list and add some comments if you have some doubts or extensions.

Best regards,
                    Eckard.


Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9615
Re: self build revision 10561 is not working on ubuntu 15.10
« Reply #2 on: November 10, 2015, 08:36:59 pm »
This is Linux-Build-Foo, unfortunately. If you don't trust / like autotools remember that there is also the option on Linux to install a nightly and use the nightly to build C::B using C::B and not auto-foo.

Besides I hope some Linux / autotools guru can pick this up.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7254
Re: self build revision 10561 is not working on ubuntu 15.10
« Reply #3 on: November 10, 2015, 09:33:39 pm »
You should not need to run any command with "sudo", execpt if you install in a global folder like "/usr/local" etc.
Inside your home-folder this is not needed.
If you did it once, you always have to use "sudo" or change the owner of your build and install folders (recursively), because some folders/files are now owned by "root".


Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7254
Re: self build revision 10561 is not working on ubuntu 15.10
« Reply #4 on: November 10, 2015, 09:35:46 pm »
To avoid such issues (with configure), you should do an out-of-tree-build.
If you do this, you can always remove the whole build-folder, or it's content to get a clean build-environment.