Recent Posts

Pages: 1 ... 3 4 5 6 7 [8] 9 10
71
Using Code::Blocks / Re: 20.3 Slow to launch on SSD Laptop
« Last post by oBFusCATed on July 14, 2021, 03:13:04 pm »
You continue to guess what the problem is. This rarely ends with solved problem. You need to use a profiler to see where time is spent. Unfortunately I cannot help much with windows guidance... Both ETW and VTune might be usable for find the root cause.
72
Help / Re: CB resolution compatible?
« Last post by oBFusCATed on July 14, 2021, 03:10:52 pm »
Settings -> Environment -> View -> Feature size...

What OS are you using? What is the scaling setting? Is this new install of C::B?
73
Using Code::Blocks / No project options showing
« Last post by vt on July 14, 2021, 11:48:47 am »
I tried both codeblock 17.12 and latest release also.
When I tried making project nothing appears on screen?
GNU GCC compiler is selected?

I want to make console application to printf some text toi get started.
74
The highlighting of the block indicates that the block should not be edited.

You can change highlighting using Settings -> Editor -> Syntax highlighting -> wxSmith generated code
75
Using Code::Blocks / Re: Continuous start and shutdown icon
« Last post by Miguel Gimenez on July 14, 2021, 09:48:28 am »
That is just a visual problem, don't worry about it. It is corrected in the nightlies.
76
Using Code::Blocks / Code incorrectly showing as comment block instead of code
« Last post by AndrewCot on July 14, 2021, 08:41:13 am »
I loaded debuggersettingsdlg.cpp and scrolled down a small amount where line 35 (DebuggerSettingsDlg::DebuggerSettingsDlg(wxWindow* parent) function is showing and it looks like lines 37 through  74 are comments due to the "//(*" on line 37, BUT only lines 37 and 74 should be shown as comments. There are a number of other files using the

The code for the "//(*" and "//*)" was add in the following change when I used github's blame functionality:
    git-svn-id: https://svn.code.sf.net/p/codeblocks/code/[email protected]
    https://github.com/obfuscated/codeblocks_sf/commit/8c7af98cea43f2368d5f3a4c793f3471e7745084

I searched the wiki and Code::Blocks manual 2.0.1 and only found a reference to "//(*" on the following page and after reading it it looks like the code should not be shown as a comment block as it was generated by wxSmith, which uses the "//(*" and "//*)" for the start and end of the generated code.
  https://wiki.codeblocks.org/index.php/WxSmith_tutorial:_Working_with_multiple_resources

I cannot see where I can set the options.highlightWxSmith in the LexCPP.cxx to false. I do not have time to chase this issue at the moment to see if it is a bug or if I have miss configured something.

A such is this a bug or if you open the debuggersettingsdlg.cpp does it displays lines 37 through 74 correctly? If it's a bug I will raise a ticket.
77
Help / CB resolution compatible?
« Last post by butopori on July 14, 2021, 08:33:54 am »
Hello.
My laptop's screen is UHD 4k, and when I try to use codeblocks, the icons are way too small for usage, making the whole program very inconvenient.
any tips?
78
General (but related to Code::Blocks) / video series for getting started
« Last post by vt on July 14, 2021, 08:31:55 am »
I am new to code blocks IDE.
Is there any code video series for learning code blocks from scratch?
79
Using Code::Blocks / Re: 20.3 Slow to launch on SSD Laptop
« Last post by cpcfreak on July 14, 2021, 07:58:43 am »
Thanks, and I suspect that for whatever reason when I launch C::B something in MS MKC conflicts and hogs the CPU via the iType application, maybe something related to custom keyboard mapping. Although the Details tab suggest CPU Idle time is high, and C::B makes little use of either CPU or Disk during the Plugin scanning phase when the compiler plugin is enabled.

Even when the compiler plugin is disabled and launch happens almost instantly (Maybe 5 ~ 10s) the C::B CPU and Disk use really doesn't change much from the slow to load state, so it looks to be quite a complex problem, not something trivial as I had hoped.

As an aside, I don't recall having these problems prior to 20.3, if I recall correctly 17.12 might have actually launched faster on the SSD laptop than it did on the HDD Desktop.
80
Using Code::Blocks / Continuous start and shutdown icon
« Last post by emerrryjones on July 14, 2021, 06:44:13 am »
Hi everyone,

Whenever I open up C::B it's icon down in the taskbar looks like the program starts up and shuts down repeatedly, in the end it does start up, still it bothers me a bit.
I have already tried deleting and reinstalling C::B, nothing changed. Did anybody ever encounter this problem before?
Do you have any idea why this might be happening?

Thank you in advance!!!
Pages: 1 ... 3 4 5 6 7 [8] 9 10