Author Topic: Codeblocks CVS compilation problem  (Read 5685 times)

Commander_TH0r

  • Guest
Codeblocks CVS compilation problem
« on: September 19, 2005, 09:16:23 pm »
I fallowed the instructions from the wiki page: How to compile Codeblocks  with wxWidgets 2.6.1

An i got this linker error

Quote
Linking executable: devel\codeblocks.exe
.objs\2.6\src\app.o(.text+0x2732):app.cpp: undefined reference to `_imp___ZN13wxDebugReportC1Ev'
.objs\2.6\src\app.o(.text+0x275c):app.cpp: undefined reference to `_imp___ZN13wxDebugReport6AddAllENS_7ContextE'
.objs\2.6\src\app.o(.text+0x277a):app.cpp: undefined reference to `wxDebugReportPreviewStd::Show(wxDebugReport&) const'
.objs\2.6\src\app.o(.text+0x2789):app.cpp: undefined reference to `_imp___ZN13wxDebugReport7ProcessEv'
.objs\2.6\src\app.o(.text+0x27ef):app.cpp: undefined reference to `wxDebugReport::~wxDebugReport()'
.objs\2.6\src\app.o(.text+0x2828):app.cpp: undefined reference to `wxDebugReport::~wxDebugReport()'
.objs\2.6\src\app.o(.text$_ZN23wxDebugReportPreviewStdD1Ev[wxDebugReportPreviewStd::~wxDebugReportPreviewStd()]+0xa):app.cpp: undefined reference to `_imp___ZTV23wxDebugReportPreviewStd'
.objs\2.6\src\app.o(.text$_ZN23wxDebugReportPreviewStdC1Ev[wxDebugReportPreviewStd::wxDebugReportPreviewStd()]+0x15):app.cpp: undefined reference to `_imp___ZTV23wxDebugReportPreviewStd'
collect2: ld returned 1 exit status

I really don't know why?

Any ideas

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: Codeblocks CVS compilation problem
« Reply #1 on: September 19, 2005, 10:24:25 pm »
Run a cvs update. It was fixed earlier today.
The CVS version might break occasionally, it's expected with all the development going on...
Be patient!
This bug will be fixed soon...

Commander_TH0r

  • Guest
Re: Codeblocks CVS compilation problem
« Reply #2 on: September 19, 2005, 10:27:00 pm »
i just wanted to see what was added.

and to try the new plugins that are in development.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: Codeblocks CVS compilation problem
« Reply #3 on: September 19, 2005, 10:57:46 pm »
Hey, no need to apologize :)
The more people using the CVS version, the better for us. I 'm just saying that occasionally it might break...
Be patient!
This bug will be fixed soon...