Author Topic: Code::blocks nightly builds on ubuntu 7.10 - i386  (Read 3003 times)

Thor

  • Guest
Code::blocks nightly builds on ubuntu 7.10 - i386
« on: February 20, 2008, 02:46:22 am »
Hi,

install does not work.
error : libwxgtk2.8-0 (>=2.8.7) but 2.8.4.0-0ubuntu3 is to be installed.


Please , please , please How can I get the libwxgtk2.8-0 on ubuntu 7.10 ? 

I can only install CB v4439  without problem.


Offline pasgui

  • Almost regular
  • **
  • Posts: 165
    • LGP
Re: Code::blocks nightly builds on ubuntu 7.10 - i386
« Reply #1 on: February 20, 2008, 06:39:54 pm »
Do you update wxWidgets with 2.8.7 ?

You can find howto http://lgp203.free.fr/spip/spip.php?article1&lang=en

Regards, pasgui

Offline LeRoi

  • Single posting newcomer
  • *
  • Posts: 4
Re: Code::blocks nightly builds on ubuntu 7.10 - i386
« Reply #2 on: February 21, 2008, 08:47:51 am »
Hy

I have had the same problem with ubuntu geisty

I tried to manually update libwxgtk2.8-0, but I found that libpango1.0-0 was causing the problem (latest version in repository is 1.18.2 while 1.18.3 is needed)

But after some few "googling", I found that I have to enable updates  :lol:

So the solution is very simple:
System-->Administration-->Software Sources-->Updates-->check (Recommended updates) then OK

finally try again this command:

sudo apt-get install libcodeblocks0 codeblocks libwxsmithlib0 codeblocks-contrib

I hope this will help you, please let me now if you get any errors

Thor

  • Guest
Re: Code::blocks nightly builds on ubuntu 7.10 - i386
« Reply #3 on: February 21, 2008, 05:08:35 pm »