Author Topic: Can't compile any Codeblocks version on Kubuntu  (Read 6768 times)

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Can't compile any Codeblocks version on Kubuntu
« on: August 22, 2005, 04:18:10 pm »
Hello

I compiled Codeblocks successfull and without any problems on Suse Linux with wxgtk 2.5.3 (Suse-RPM).
Now I tried it to compile on Kubuntu (gcc 3.3.5). But I get the same errors with wxgtk 2.4.3 (sarge-package) , 2.4.4 (sid-package) and with the selfcompiled 2.6.1 (from the original sources without unicode). I also tried two Codeblocksversions, 1.0-RC1 and the CVS.

Code
Compiling sdk/Managers/Managers.cpp...
In file included from sdk/cbeditor.h:14,
                 from sdk/sdk_events.h:7,
                 from sdk/manager.h:6,
                 from sdk/Managers/StdAfx.h:16,
                 from sdk/Managers/Managers.cpp:4:
/usr/include/wx/stc/stc.h:2453: error: parse error before `,' token
/usr/include/wx/stc/stc.h: In function `int
   DECLARE_EXPORTED_LOCAL_EVENT_TYPE(...)':
/usr/include/wx/stc/stc.h:2455: error: redefinition of `int
   DECLARE_EXPORTED_LOCAL_EVENT_TYPE(...)'
/usr/include/wx/stc/stc.h:2454: error: `int
   DECLARE_EXPORTED_LOCAL_EVENT_TYPE(...)' previously defined here
/usr/include/wx/stc/stc.h:2455: error: redefinition of `int
   DECLARE_EXPORTED_LOCAL_EVENT_TYPE(...)'
...
sdk/editorbase.h:12: confused by earlier errors, bailing out
make: *** [.objs/sdk/Managers/Managers.o] Error 1

I've attached the whole output of make.

I don't know what to do.

Thank you

Daniel
Nightly builds for openSUSE

Offline David Perfors

  • Developer
  • Lives here!
  • *****
  • Posts: 560
Re: Can't compile any Codeblocks version on Kubuntu
« Reply #1 on: August 22, 2005, 04:55:05 pm »
looks like stc is broken in some way...

btw. there is no attachment..
OS: winXP
Compiler: mingw
IDE: Code::Blocks SVN WX: 2.8.4 Wish list: faster code completion, easier debugging, refactoring

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Re: Can't compile any Codeblocks version on Kubuntu
« Reply #2 on: August 22, 2005, 05:17:05 pm »
wasn't it reported a few times, that Codelocks doesn't compile with wxGTK > version 242 ?
i've built it with selfcompiled wxGTK-242 under Ubuntu 5.04 and it compiles fine.
« Last Edit: August 22, 2005, 05:19:07 pm by tiwag »

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: Can't compile any Codeblocks version on Kubuntu
« Reply #3 on: August 22, 2005, 05:56:00 pm »
wasn't it reported a few times, that Codelocks doesn't compile with wxGTK > version 242 ?
i've built it with selfcompiled wxGTK-242 under Ubuntu 5.04 and it compiles fine.

It compiles fine, except that it doesn't work afterwards  :?

Yiannis.
Be patient!
This bug will be fixed soon...

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: Can't compile any Codeblocks version on Kubuntu
« Reply #4 on: August 22, 2005, 06:40:38 pm »
It compiles fine, except that it doesn't work afterwards  :?

So much for portability :lol:
But why doesn't it work? Any ideas?

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: Can't compile any Codeblocks version on Kubuntu
« Reply #5 on: August 22, 2005, 06:42:45 pm »
I 'm talking about the linux version using wx2.6.1. That's what is not working. Don't have a clue why yet...

Yiannis.
Be patient!
This bug will be fixed soon...

Offline TheTuxKeeper

  • Regular
  • ***
  • Posts: 293
  • daniel2000
Re: Can't compile any Codeblocks version on Kubuntu
« Reply #6 on: August 22, 2005, 08:11:22 pm »
wasn't it reported a few times, that Codelocks doesn't compile with wxGTK > version 242 ?
i've built it with selfcompiled wxGTK-242 under Ubuntu 5.04 and it compiles fine.
But why does it work with wxgtk 2.5.3 ?

Now I've installed wxgtk 2.5.3. It looks to compile without any error. When it won't work I'll try version 2.4.2 .

Sorry for having asked one more time the same question, but I've read a few threads and there it wasn't said so clear that > version 2.4.2 doesn't work, only that it's crashing a little more often. But it's also possible that I've misunderstood something.

Thank you for helping

Daniel
Nightly builds for openSUSE