Author Topic: [SOLVED] Can't compile Code::Blocks  (Read 3371 times)

Rampage

  • Guest
[SOLVED] Can't compile Code::Blocks
« on: June 23, 2007, 03:20:15 pm »
Dear community!

Every time I try to bootstrap the build-process of Code::Blocks it gives me the following errors:

Code
$ ./bootstrap
configure.in:80: warning: macro `AM_OPTIONS_WXCONFIG' not found in library
configure.in:81: warning: macro `AM_PATH_WXCONFIG' not found in library
configure.in:80: error: possibly undefined macro: AM_OPTIONS_WXCONFIG
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.in:81: error: possibly undefined macro: AM_PATH_WXCONFIG

Here is what I did:

1. I checked out the repository.
2. I added the official WX-repositories to my /etc/apt/sources.list
3. I installied wxGTK2.8-0 and wxGTK2.8-dev with aptitude
4. I exported the environment variable ACLOCAL_FLAGS=-I /usr/share/aclocal
5. I typed ./bootstrap inside the trunk-directory.

After a few seconds it gives me those warnings.
I am running Debian Etch, Autoconf and Automake are installed and work quite good.

Does anyone here have an idea what I could do in order to compile Code::Blocks? Please let me know if you need to know more about my system.

Thanks for your time,
Rampage
« Last Edit: June 23, 2007, 03:29:28 pm by Rampage »

Offline raph

  • Almost regular
  • **
  • Posts: 242
Re: Can't compile Code::Blocks
« Reply #1 on: June 23, 2007, 03:24:25 pm »
Have a look at the wiki.
You'll find some hints there.

Regards
raph

Rampage

  • Guest
Re: Can't compile Code::Blocks
« Reply #2 on: June 23, 2007, 03:29:07 pm »
Damn... I overread the part in the "Prerequisites"-section where it says that wx-common has to be installed.

Thanks for making me read the article again raph. :D
Rampage