Author Topic: Compile Problems SVN revision 2713 Ubuntu_amd64  (Read 3130 times)

Offline HybridBlue

  • Single posting newcomer
  • *
  • Posts: 3
Compile Problems SVN revision 2713 Ubuntu_amd64
« on: July 08, 2006, 05:34:38 am »
Ive been trying to compile Code Blocks on Ubuntu Dapper 6.06 and i cant seem to get it to compile fully. It bootstraps just fine and will also configure without any errors but when i try to run a make on it i get to the plugins dir where it hits the project wizard and then it dies trying to compile. So far anything ive tried hasnt fixed it and i tried installing off a package that someone on the UbuntuForums had but their package dosnt work very well for me as it crashes a LOT!

Code
wiz.cpp: In member function 'void Wiz::FillComboboxWithCompilers(const wxString&)':
wiz.cpp:545: error: invalid use of undefined type 'struct Compiler'
../../../src/sdk/compilerfactory.h:11: error: forward declaration of 'struct Compiler'
wiz.cpp:547: error: invalid use of undefined type 'struct Compiler'
../../../src/sdk/compilerfactory.h:11: error: forward declaration of 'struct Compiler'
wiz.cpp: In member function 'wxString Wiz::GetCompilerFromCombobox(const wxString&)':
wiz.cpp:568: error: invalid use of undefined type 'struct Compiler'
../../../src/sdk/compilerfactory.h:11: error: forward declaration of 'struct Compiler'
make[4]: *** [wiz.lo] Error 1
make[4]: Leaving directory `/home/xen/Desktop/Devlopment/SVN_SourceBlocks/trunk/src/plugins/projectwizard'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/xen/Desktop/Devlopment/SVN_SourceBlocks/trunk/src/plugins/projectwizard'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/xen/Desktop/Devlopment/SVN_SourceBlocks/trunk/src/plugins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/xen/Desktop/Devlopment/SVN_SourceBlocks/trunk/src'
make: *** [all-recursive] Error 1

**Just a note it seems more like its dieing on wiz.cpp atm?

These are the errors im getting so far and havnt been able to fix. If anyone has any ideas i could try i would be very happy =)
For reference im running all this:
Ubuntu Dapper 6.06 Fully Patched (AMD64)
CB source is: Checked out revision 2713.
wxGTK2 : Compiled and installed from source with no problems --- 2.6.3

I did have to make some links to the libs installed by wxGTK2 after it installed to get the make this far, but so far all attempts ive made to get any further have been no good.. Any help would be greatly appreciated.

Thanks!
HB
« Last Edit: July 08, 2006, 08:12:07 am by HybridBlue »

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: Compile Problems SVN revision 2713.
« Reply #1 on: July 08, 2006, 08:12:04 am »
Fixed, revision 2714.
Be patient!
This bug will be fixed soon...

Offline HybridBlue

  • Single posting newcomer
  • *
  • Posts: 3
Re: Compile Problems SVN revision 2713 Ubuntu_amd64
« Reply #2 on: July 08, 2006, 08:37:48 am »
Testing it out right now, so far it looks like everything seems to be working and if it all compiles properly ill build a package of it =)

Thanks a lot by the way, you guys really keep on top of it. Great work =)

HB

Offline HybridBlue

  • Single posting newcomer
  • *
  • Posts: 3
Re: Compile Problems SVN revision 2713 Ubuntu_amd64
« Reply #3 on: July 08, 2006, 09:09:30 am »
Looks to be working perfect seems that im having a problem with it loading one of the plugins (libexporter.so). but at the moment thats not really a big problem at the moment. Ill see what that issue is and make a package to post up for the amd64 build..so far the only builds ive seen people with have been 32bit so i might for once help somene haha..

Anyway, thanks a lot for putting in that fix and all that =) it all seems to be working great.

-HB

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: Compile Problems SVN revision 2713 Ubuntu_amd64
« Reply #4 on: July 08, 2006, 09:24:40 am »
Ill see what that issue is and make a package to post up for the amd64 build..so far the only builds ive seen people with have been 32bit so i might for once help somene haha..

http://prdownload.berlios.de/codeblocks/codeblocks_1.0r2678_amd64.deb

I provide dapper amd64 builds every now and then so probably you didn't look around ;)
Anyway, I 'd suggest you don't make a package yet because current HEAD has some serious problems with resources loading. Wait till those are resolved first...
Be patient!
This bug will be fixed soon...