Author Topic: Strange Startup Error  (Read 4483 times)

Guest

  • Guest
Strange Startup Error
« on: May 16, 2005, 02:17:39 am »
I currently get an error message:

"file 'C:\WINDOWS/MinGW.ini', line 2: '=' expected."

in a small popup message every single time I start up CodeBlocks.
This appears together with the compilers auto-detection window.

I haven't a clue what exactly triggered this, but I was trying to compile a DLL using a custom Makefile. In the process, I was closing and starting up CodeBlocks a number of times.

I've tried reinstalling CodeBlocks and MinGW, deleted CodeBlocks related registry keys (not sure if I spotted all of them) but the message appears if ClodeBlocks and MinGW are both installed.

Any ideas?

Anonymous

  • Guest
Strange Startup Error
« Reply #1 on: May 16, 2005, 05:12:55 am »
question - why did you close and started up codeblocks a number of times? Was the DLL a codeblocks plugin or something? Well, try deleting the mingw.ini and see what happens. OH wait, you might want to show here the contents of such mingw.ini.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Strange Startup Error
« Reply #2 on: May 16, 2005, 08:20:32 am »
If you want, post the contents of c:\mingw.ini here so we can fix this error message.
After you do that, it's safe to delete it, and the error will go away.

Yiannis.
Be patient!
This bug will be fixed soon...

Offline chikigai

  • Multiple posting newcomer
  • *
  • Posts: 33
Strange Startup Error
« Reply #3 on: May 18, 2005, 06:40:07 am »
OK, replying as a registered user.

The reason I was opening/closing CodeBlocks a number of times was because I was trying to figure out a problem I was having with output paths and make targets CodeBlocks was setting when compiling.
(I will post details in a different post).

I have tried uninstalling Codeblocks, deleting registry keys, and restarting the computer.
Reinstalled Codeblocks and the startup error no longer appears.

The contents of "MinGW.ini" is and always has been:

[InstallSettings]
InstallPath MinGW=c:\MinGW
[Development Environment]
OS: WinXP SP3
IDE: Code::Blocks Nightly Build SVN Rev.6080 wxWidgets: 2.8.10 Windows Unicode Build SVN: 1.6.x

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Strange Startup Error
« Reply #4 on: May 18, 2005, 07:19:37 am »
no longer appears? :-/ Darn! It's non-reproduceable now. Grrrr. OH well.