Author Topic: About background colour of symbols window  (Read 15965 times)

lfm

  • Guest
About background colour of symbols window
« on: May 24, 2006, 07:26:43 am »
The background colour of symbols window is not good-look. can i change ?


[attachment deleted by admin]

sethjackson

  • Guest
Re: About background colour of symbols window
« Reply #1 on: May 24, 2006, 01:57:35 pm »
The background colour of symbols window is not good-look. can i change ?


It is not in any C::B setting. However you can modify the code to "fix" it (it looks ugly on windows)....
The reason is eranif in one of his wxFNB release changed the background color on Windows.

Fourth post from the bottom......

http://wxforum.shadonet.com/viewtopic.php?t=5761&postdays=0&postorder=asc&start=90
« Last Edit: May 24, 2006, 03:05:36 pm by sethjackson »

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: About background colour of symbols window
« Reply #2 on: May 24, 2006, 02:12:40 pm »
This has been fixed *long* ago...
Be patient!
This bug will be fixed soon...

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Re: About background colour of symbols window
« Reply #3 on: May 24, 2006, 02:49:48 pm »
This has been fixed *long* ago...

sorry, that screeny is from svn rev 2498



it really doesn't look fixed  :P

WinXP, wxWidgets 2.6.3 unicode

takeshimiya

  • Guest
Re: About background colour of symbols window
« Reply #4 on: May 24, 2006, 02:55:10 pm »
it really doesn't look fixed  :P
I can confirm that. :P

A wxPanel there shouldn't solve it?

@tiwag: that cyan background doesn't hurt your eyes? :o

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: About background colour of symbols window
« Reply #5 on: May 24, 2006, 02:55:42 pm »
You might want to run update.bat (windows) or "sh update" (linux, build using C::B).
If you 're using linux/autotools, run the following:
Code
make clean-zipfiles
make
make install


[attachment deleted by admin]
Be patient!
This bug will be fixed soon...

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: About background colour of symbols window
« Reply #6 on: May 24, 2006, 02:57:19 pm »
A wxPanel there shouldn't solve it?

Look in src/plugins/codecompletion/resources/classbrowser.xrc.
Surprise! It uses a wxPanel :)
Be patient!
This bug will be fixed soon...

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Re: About background colour of symbols window
« Reply #7 on: May 24, 2006, 03:02:22 pm »
You might want to run update.bat (windows) ...
done, but without success

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Re: About background colour of symbols window
« Reply #8 on: May 24, 2006, 03:04:21 pm »
@tiwag: that cyan background doesn't hurt your eyes? :o
it doesn't as hurt as certain questions in this forum here ...

sethjackson

  • Guest
Re: About background colour of symbols window
« Reply #9 on: May 24, 2006, 03:05:18 pm »
Hey everyone this happens on Windows only. See my post above. :D

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: About background colour of symbols window
« Reply #10 on: May 24, 2006, 03:06:18 pm »
@tiwag: that cyan background doesn't hurt your eyes? :o
it doesn't as hurt as certain questions in this forum here ...
I believe the background in SciTE is not cyan... :)

EDIT: And looking closely, the above isn't either :)
« Last Edit: May 24, 2006, 03:10:39 pm by thomas »
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline Defender

  • Multiple posting newcomer
  • *
  • Posts: 49
Re: About background colour of symbols window
« Reply #11 on: May 24, 2006, 03:07:32 pm »
Yes, I can confirm this too.
Windows XP SP2
wxWidgets 2.6.3 patch2
Code::Blocks 2490 Full rebuild
But it doesn't hurt me...

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4315
    • Code::Blocks IDE
Re: About background colour of symbols window
« Reply #12 on: May 24, 2006, 03:12:59 pm »
Well, did anyone have a look at src/plugins/codecompletion/resources/classbrowser.xrc???
Be patient!
This bug will be fixed soon...

sethjackson

  • Guest
Re: About background colour of symbols window
« Reply #13 on: May 24, 2006, 03:22:44 pm »
Well, did anyone have a look at src/plugins/codecompletion/resources/classbrowser.xrc???

Yes, but the real problem is wxFNB. I have rev 2498. I ran update.bat same "problem" described above.....

Offline tiwag

  • Developer
  • Lives here!
  • *****
  • Posts: 1196
  • sailing away ...
    • tiwag.cb
Re: About background colour of symbols window
« Reply #14 on: May 24, 2006, 03:23:54 pm »
Well, did anyone have a look at src/plugins/codecompletion/resources/classbrowser.xrc???

when i test this with XRCed it looks ok, all bg and fg colours are set to default, also the
CodeBlocks\share\CodeBlocks\code_completion.zip
contains the right classbrowser.xrc file,
i don't know why this happens, but it is not related to an outdated classbrowser.xrc file.