Author Topic: Debian package for Code::Blocks 1.0 beta7  (Read 4317 times)

Offline Neumann

  • Multiple posting newcomer
  • *
  • Posts: 14
    • http://
Debian package for Code::Blocks 1.0 beta7
« on: April 28, 2005, 09:34:56 pm »
If you can't bother reading my rants, here is the package:

http://www.lostwebsite.net/debian/codeblocks_1.0-beta7-1_i386.deb

At last, I finished "school things" earlier this week and put up a fight against Debian to package Code::Blocks.

Lintian doesn't report any error so I feel safe to put this package up for testing.   Please report any error to me here.  The package was compiled for Debian unstable distribution.  Sarge user might need packages not found in their archive (I don't know for sure).

I'm not gonna request a sponsor for the package because I feel it's not yet stable enough for Debian and because (that's a personal opinion), GTK1 is butt-ugly.  wx2.5 packages, which use GTK 2, are unicode-only and won't see anymore work before the release of wx2.6 packages that will probably happen soon.

So yeah now that I know I can do it, releasing Debian packages for future versions should be easier.  I'll try to keep up with the mainstream releases.

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Debian package for Code::Blocks 1.0 beta7
« Reply #1 on: April 28, 2005, 10:35:18 pm »
Well yes, unicode is a BIG lag. I wonder when we'll have this stuff fixed etc. I think it'll improve when we implement search-in-files :)

Anonymous

  • Guest
Debian package for Code::Blocks 1.0 beta7
« Reply #2 on: April 28, 2005, 10:55:43 pm »
If the future wx2.6 package is still unicode only I'll hack the main source package to get a non-unicode version and put it online along my Code::Blocks package.

I'm not a DD so there isn't much I can do to pressure the maintainers.  At least I can make it more convenient and nicer-looking for Debian Code::Blocks users.