Author Topic: Running debugger runs the output file, not the debugger (AGC)  (Read 958 times)

Offline NeilFraser

  • Single posting newcomer
  • *
  • Posts: 2
Hello, I'm trying to use Code::Blocks to debug code for the Apollo Guidance Computer.  Compiling works great, it generates a valid binary output file.  But when I try to run the debugger, Code::Blocks forgets to include the specified debugger executable.

The build log states:

Code
-------- Run: Debug in Comanche051 (compiler: AGC YaYUL assembler)----------
Checking for existence: /home/pi/virtualagc/Comanche051/Comanche051.bin
Executing: /home/pi/virtualagc/Comanche051/Comanche051.bin (in /home/pi/virtualagc/Comanche051/.)
Process terminated with status -1 (0 minute(s), 0 second(s))

I believe the problem is that it's forgetting about the debugger; it should be executing:
Code
/home/pi/VirtualAGC/bin/yaAGC /home/pi/virtualagc/Comanche051/Comanche051.bin

Under "Settings", "Debugger...", "AGC" (my GDB/CDB debugger profile), the executable path is set to /home/pi/VirtualAGC/bin/yaAGC, but this info doesn't seem to be making it to the command being executed.

Under "Settings", "Compiler...", "Global compiler settings", "Toolchain executables", the debugger is set to "GDB/CDB debugger: AGC".

Any idea what I should be doing differently?  Thanks!

Offline Grit Clef

  • Multiple posting newcomer
  • *
  • Posts: 62
  • Where there is a will, there is a way.
Re: Running debugger runs the output file, not the debugger (AGC)
« Reply #1 on: April 22, 2024, 01:03:43 pm »
Have you run debugger from Debug->Start? You seem to directly run the executable!
-Windows 7, 32-bit
-CodeBlocks r13518, gcc 13.2.0, debug version

Offline NeilFraser

  • Single posting newcomer
  • *
  • Posts: 2
Re: Running debugger runs the output file, not the debugger (AGC)
« Reply #2 on: April 23, 2024, 01:03:19 am »
Quote
Have you run debugger from Debug->Start? You seem to directly run the executable!

Well.  I guess that's what I get for trying to solve this problem at 3 am...   :o

Thanks!