Author Topic: problem with silent install in version codeblocks-20.03mingw-setup  (Read 1235 times)

Offline olivier sc

  • Single posting newcomer
  • *
  • Posts: 2
Hello dear,

I try to install silently codeblocks-20.03mingw-setup.exe with /S
I get alwais a exit status 2
When i lunch it, no compiler is present.
You can see attached image:
in 1 it is a machine that has never had codeblock installed.
in 2 it is a machine installed by hand or having already had codeblock installed

I see this on chocolatey package to!

Offline ur_naz

  • Single posting newcomer
  • *
  • Posts: 4
Re: problem with silent install in version codeblocks-20.03mingw-setup
« Reply #1 on: April 20, 2024, 07:44:16 pm »
check if mingw directory exist inside your CB install dir. if so, then
1) go to menu Settings->Compiler
2) In settings window move to toolchain executables tab
3)  Remove 'mingw32-' prefix for upper 4 apps
4) Check mingw path
5) enjoy

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7606
    • My Best Post
Re: problem with silent install in version codeblocks-20.03mingw-setup
« Reply #2 on: April 21, 2024, 02:46:44 am »
check if mingw directory exist inside your CB install dir. if so, then
1) go to menu Settings->Compiler
2) In settings window move to toolchain executables tab
3)  Remove 'mingw32-' prefix for upper 4 apps
4) Check mingw path
5) enjoy

Are you working to get banned?
Because your reply makes you look like a bot!

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 64 bit.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org