Author Topic: wxWidgets location doesn't work when portable  (Read 1838 times)

MichaelAgarkov

  • Guest
wxWidgets location doesn't work when portable
« on: February 15, 2024, 05:59:15 pm »
Hello everyone.

I have a flash drive on which I run Code::Blocks through CbLauncher.exe. I also have wxWidgets-3.0.5 on the same drive.
I tried to create a global variable for it as $(APPPATH)\wxWidgets-3.0.5, but when I create a new project, it throws me this error:
Quote
Script error
The path you entered seems valid, but this wizard can't locate wxWidgets' files in it...
However it works when I directly specify it including the drive letter.

What can be done about this?
Sincerely thank you.

Offline Miguel Gimenez

  • Developer
  • Lives here!
  • *****
  • Posts: 1583
Re: wxWidgets location doesn't work when portable
« Reply #1 on: February 15, 2024, 06:06:08 pm »
The wizard appends "/include/wx/wx.h" to the address you gave, if the file does not exist it emits that message.

Have you tried $(APPPATH)/wxWidgets-3.0.5?

MichaelAgarkov

  • Guest
Re: wxWidgets location doesn't work when portable
« Reply #2 on: February 15, 2024, 06:14:14 pm »
$(APPPATH)/wxWidgets-3.0.5 also doesn't work. "wxWidgets-3.0.5\include\wx\wx.h" does exist.

Offline Miguel Gimenez

  • Developer
  • Lives here!
  • *****
  • Posts: 1583
Re: wxWidgets location doesn't work when portable
« Reply #3 on: February 15, 2024, 06:17:19 pm »
Then the value of $(APPPATH) may be different from expected. Try modifying the script so it shows the value.

MichaelAgarkov

  • Guest
Re: wxWidgets location doesn't work when portable
« Reply #4 on: February 15, 2024, 06:23:27 pm »
Simply trying $(APPPATH)wxWidgets-3.0.5 worked. Thanks for help though.