Author Topic: clangd_client_wx32_64.cbp compiler usage in r13056  (Read 745 times)

Offline everSome

  • Multiple posting newcomer
  • *
  • Posts: 29
clangd_client_wx32_64.cbp compiler usage in r13056
« on: November 22, 2022, 11:22:20 pm »
Any particular reason src/plugins/contrib/clangd_client/clangd_client_wx32_64.cbp has been changed to not use the GNU c++ extensions? I get the change from v17 back v11. Everything else uses gnu++1. The same can be asked of 'clangd_client_wx31_64.cbp'.

findstr /s /n std= *wx32_64.cbp
CodeBlocks_wx32_64.cbp:636:                     <Add option="-std=gnu++11" />
plugins\codecompletion\cctest_wx32_64.cbp:36:                   <Add option="-std=gnu++11" />
plugins\contrib\AutoVersioning\AutoVersioning_wx32_64.cbp:63:                   <Add option="-std=gnu++11" />
plugins\contrib\BrowseTracker\BrowseTracker_wx32_64.cbp:64:                     <Add option="-std=gnu++11" />
plugins\contrib\byogames\byogames_wx32_64.cbp:42:                       <Add option="-std=gnu++11" />
plugins\contrib\cb_koders\cb_koders_wx32_64.cbp:47:                     <Add option="-std=gnu++11" />
plugins\contrib\Cccc\Cccc_wx32_64.cbp:42:                       <Add option="-std=gnu++11" />
plugins\contrib\clangd_client\clangd_client_wx32_64.cbp:41:                     <Add option="-std=c++11" />
plugins\contrib\codesnippets\codesnippets_wx32_64.cbp:50:                       <Add option="-std=gnu++11" />
plugins\contrib\codestat\codestat_wx32_64.cbp:42:                       <Add option="-std=gnu++11" />
plugins\contrib\copystrings\copystrings_wx32_64.cbp:42:                 <Add option="-std=gnu++11" />
plugins\contrib\CppCheck\CppCheck_wx32_64.cbp:42:                       <Add option="-std=gnu++11" />
plugins\contrib\Cscope\Cscope_wx32_64.cbp:42:                   <Add option="-std=gnu++11" />
plugins\contrib\devpak_plugin\DevPakPlugin_wx32_64.cbp:72:                      <Add option="-std=gnu++11" />
plugins\contrib\DoxyBlocks\DoxyBlocks_wx32_64.cbp:74:                   <Add option="-std=gnu++11" />
plugins\contrib\dragscroll\DragScroll_wx32_64.cbp:44:                   <Add option="-std=gnu++11" />
plugins\contrib\EditorConfig\EditorConfig_wx32_64.cbp:60:                       <Add option="-std=gnu++11" />
plugins\contrib\EditorTweaks\EditorTweaks_wx32_64.cbp:59:                       <Add option="-std=gnu++11" />
plugins\contrib\envvars\envvars_wx32_64.cbp:56:                 <Add option="-std=gnu++11" />
plugins\contrib\FileManager\FileManager_wx32_64.cbp:51:                 <Add option="-std=gnu++11" />
plugins\contrib\headerfixup\headerfixup_wx32_64.cbp:57:                 <Add option="-std=gnu++11" />
plugins\contrib\help_plugin\help-plugin_wx32_64.cbp:93:                 <Add option="-std=gnu++11" />
plugins\contrib\HexEditor\HexEditor_wx32_64.cbp:62:                     <Add option="-std=gnu++11" />
plugins\contrib\IncrementalSearch\IncrementalSearch_wx32_64.cbp:66:                     <Add option="-std=gnu++11" />
plugins\contrib\keybinder\keybinder_wx32_64.cbp:49:                     <Add option="-std=gnu++11" />
plugins\contrib\lib_finder\lib_finder_wx32_64.cbp:45:                   <Add option="-std=gnu++11" />
plugins\contrib\MouseSap\MouseSap_wx32_64.cbp:62:                       <Add option="-std=gnu++11" />
plugins\contrib\NassiShneiderman\NassiShneiderman_wx32_64.cbp:68:                       <Add option="-std=gnu++11" />
plugins\contrib\profiler\cbprofiler_wx32_64.cbp:42:                     <Add option="-std=gnu++11" />
plugins\contrib\ProjectOptionsManipulator\ProjectOptionsManipulator_wx32_64.cbp:45:                     <Add option="-std=gnu++11" />
plugins\contrib\regex_testbed\RegExTestbed_wx32_64.cbp:52:                      <Add option="-std=gnu++11" />
plugins\contrib\ReopenEditor\ReopenEditor_wx32_64.cbp:61:                       <Add option="-std=gnu++11" />
plugins\contrib\rndgen\rndgen_wx32_64.cbp:58:                   <Add option="-std=gnu++11" />
plugins\contrib\SmartIndent\SmartIndent_wx32_64.cbp:178:                        <Add option="-std=gnu++11" />
plugins\contrib\source_exporter\Exporter_wx32_64.cbp:103:                       <Add option="-std=gnu++11" />
plugins\contrib\SpellChecker\SpellChecker_wx32_64.cbp:110:                      <Add option="-std=gnu++11" />
plugins\contrib\symtab\symtab_wx32_64.cbp:46:                   <Add option="-std=gnu++11" />
plugins\contrib\ThreadSearch\ThreadSearch_wx32_64.cbp:52:                       <Add option="-std=gnu++11" />
plugins\contrib\ToolsPlus\ToolsPlus_wx32_64.cbp:51:                     <Add option="-std=gnu++11" />
plugins\contrib\wxContribItems\wxContribItems_wx32_64.cbp:121:                  <Add option="-std=gnu++11" />
plugins\contrib\wxSmith\wxSmith_wx32_64.cbp:48:                 <Add option="-std=gnu++11" />
plugins\contrib\wxSmithAui\wxSmithAui_wx32_64.cbp:25:                                   <Add option="-std=gnu++11" />
plugins\contrib\wxSmithContribItems\wxSmithContribItems_wx32_64.cbp:85:                 <Add option="-std=gnu++11" />
plugins\displayevents\cbDisplayEvents_wx32_64.cbp:51:                   <Add option="-std=gnu++11" />
tools\Addr2LineUI\Addr2LineUI_wx32_64.cbp:41:                   <Add option="-std=gnu++11" />
tools\cbp2make\cbp2make_wx32_64.cbp:36:                 <Add option="-std=gnu++11" />
tools\cb_share_config\cb_share_config_wx32_64.cbp:37:                   <Add option="-std=gnu++11" />

Offline Miguel Gimenez

  • Developer
  • Lives here!
  • *****
  • Posts: 1252
Re: clangd_client_wx32_64.cbp compiler usage in r13056
« Reply #1 on: November 23, 2022, 09:02:10 am »
On Linux CBP everything links with GTK2, clangd-client uses GTK3.

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2526
Re: clangd_client_wx32_64.cbp compiler usage in r13056
« Reply #2 on: November 23, 2022, 07:07:05 pm »
Any particular reason src/plugins/contrib/clangd_client/clangd_client_wx32_64.cbp has been changed to not use the GNU c++ extensions? I get the change from v17 back v11. Everything else uses gnu++1. The same can be asked of 'clangd_client_wx31_64.cbp'.
....

I was informed by an AutoTools builder that debian and Mac builds failed because Clangd_client was using c++17 and that CB AutoTools builds did not support that option.

Being ignorant of AutoTools, I took the easiest option and re-coded anything that required newer than std=c++11 to reduce the code to std=c++11.
std=c++11 is what the messager suggested.
 

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2526
Re: clangd_client_wx32_64.cbp compiler usage in r13056
« Reply #3 on: November 23, 2022, 07:10:28 pm »
On Linux CBP everything links with GTK2, clangd-client uses GTK3.

Would you suggest the changes needed to fix this.
On my current Mint20, I can't seem to link successfully with GTK2.

Thanks

Offline Miguel Gimenez

  • Developer
  • Lives here!
  • *****
  • Posts: 1252
Re: clangd_client_wx32_64.cbp compiler usage in r13056
« Reply #4 on: November 23, 2022, 07:28:13 pm »
I link successfully on Mint 18 with GTK2, see ticket 1331 for a patch. This patch solves also a template issue I get on MInt 18 due to last parameter type mismatch.

The CBP patch is big because of whitespace, the real changes are:
Code
-				<Variable name="PKG_CONFIG_GTK_VERSION" value="3.0" />
+ <Variable name="PKG_CONFIG_GTK_VERSION" value="2.0" />
- <Variable name="WX_CONFIG" value="wx-config --toolkit=gtk3" />
+ <Variable name="WX_CONFIG" value="wx-config --toolkit=gtk2" />

Offline everSome

  • Multiple posting newcomer
  • *
  • Posts: 29
Re: clangd_client_wx32_64.cbp compiler usage in r13056
« Reply #5 on: November 23, 2022, 09:50:45 pm »
Note that the following commands show that usage in general is
<Add option="-std=gnu++11" />:

findstr /s /n std= *_wx31.cbp
findstr /s /n std= *_wx32.cbp
findstr /s /n std= *wx31_64.cbp
findstr /s /n std= *wx32_64.cbp

The findstr /s /n std= *_wx30-unix.cbp variants instead use
<Add option="-std=c++11" />
in general with
CodeBlocks_wx30-unix.cbp:415:         <Add option="-std=c90" />
being the sole exception.


Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2526
Re: clangd_client_wx32_64.cbp compiler usage in r13056
« Reply #6 on: November 24, 2022, 12:52:11 am »
I link successfully on Mint 18 with GTK2, see ticket 1331 for a patch. This patch solves also a template issue I get on MInt 18 due to last parameter type mismatch.

The CBP patch is big because of whitespace, the real changes are:
Code
-				<Variable name="PKG_CONFIG_GTK_VERSION" value="3.0" />
+ <Variable name="PKG_CONFIG_GTK_VERSION" value="2.0" />
- <Variable name="WX_CONFIG" value="wx-config --toolkit=gtk3" />
+ <Variable name="WX_CONFIG" value="wx-config --toolkit=gtk2" />

Fixed head rev 13061
Thanks

Offline Pecan

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 2526
Re: clangd_client_wx32_64.cbp compiler usage in r13056
« Reply #7 on: November 24, 2022, 12:53:25 am »
Note that the following commands show that usage in general is
<Add option="-std=gnu++11" />:

findstr /s /n std= *_wx31.cbp
findstr /s /n std= *_wx32.cbp
findstr /s /n std= *wx31_64.cbp
findstr /s /n std= *wx32_64.cbp

The findstr /s /n std= *_wx30-unix.cbp variants instead use
<Add option="-std=c++11" />
in general with
CodeBlocks_wx30-unix.cbp:415:         <Add option="-std=c90" />
being the sole exception.

Fixed head rev 13061
Thanks