Author Topic: [Resolved] Cannot Build wxWidgets Libraries Anymore With GCC  (Read 306 times)

Offline Frank_CB

  • Multiple posting newcomer
  • *
  • Posts: 115
[Resolved] Cannot Build wxWidgets Libraries Anymore With GCC
« on: September 14, 2022, 10:00:17 pm »
A couple weeks ago, I realized that all my wxWidgets libraries for GNU/GCC up to that point were 64-bit I believe that was causing any attempts to build 32-bit C::Bs to be failures.

Now, I am unable to build any GNU/GCC libraries on a 64-bit Windows 10 platform. I get RSP files rather than DLL files. This happens for wxWidgets-3.2.1 also. Any ideas why?

Regards  :)
« Last Edit: September 17, 2022, 02:04:50 am by Frank_CB »

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5625
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: Cannot Build wxWidgets Libraries Anymore With GCC
« Reply #1 on: September 15, 2022, 12:23:48 am »
Quote
Now, I am unable to build any GNU/GCC libraries on a 64-bit Windows 10 platform.

I don't know what are the steps you tried, and please show more details.
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline Frank_CB

  • Multiple posting newcomer
  • *
  • Posts: 115
Re: Cannot Build wxWidgets Libraries Anymore With GCC
« Reply #2 on: September 15, 2022, 01:46:25 am »
@ollydbg: Thanks for your comment.

It appears that either mingw32-make.exe or makefile.gcc is exiting prematurely without any error message.

I've used the following command:  mingw32-make.exe -f makefile.gcc CFG=64 BUILD=Release SHARED=1 MONOLITHIC=1 >out10 2>err10 at a command prompt for awhile (years) without any problems.

Now I would end-up with approximately 15 subroutines and wxmsw32u_gcc_custom.dll.rsp in the gcc_dll64 library. This last file is usually a dll of approx.27,000+Kb is size, but now is only 25+Kb. There also is usually a second dll file.

Regards
« Last Edit: September 15, 2022, 01:48:38 am by Frank_CB »

Offline ollydbg

  • Developer
  • Lives here!
  • *****
  • Posts: 5625
  • OpenCV and Robotics
    • Chinese OpenCV forum moderator
Re: Cannot Build wxWidgets Libraries Anymore With GCC
« Reply #3 on: September 15, 2022, 04:33:33 am »
My guess is your PATH is polluted. You may have to clean your PATH first. Maybe, you have to reinstall a new GCC compiler suite.
If some piece of memory should be reused, turn them to variables (or const variables).
If some piece of operations should be reused, turn them to functions.
If they happened together, then turn them to classes.

Offline Frank_CB

  • Multiple posting newcomer
  • *
  • Posts: 115
Re: Cannot Build wxWidgets Libraries Anymore With GCC
« Reply #4 on: September 15, 2022, 05:10:03 am »
@ollydbg:
WHERE says mingw32-make.exe is where it's suppose to be, and that it is the only one.  I'll reinstall  the GCC suite and try again.

Regards

Offline Frank_CB

  • Multiple posting newcomer
  • *
  • Posts: 115
Re: [Resolved] Cannot Build wxWidgets Libraries Anymore With GCC
« Reply #5 on: September 17, 2022, 02:35:59 am »
I had recently installed a ancient version of mingw64 (GCC 8.1.0).  This has contributed to my failures compiling wxWidgets libraries and building versions of C::B. I replaced it with the correct version of mingw64 (GCC 8.1.0) for a Windows 10 (64-bit) platform.

I just compiled wxWidgets-3.2.1 into a 64-bit library. I'll address 32-bit wx3.2.1 libraries and C::B versions later.

My apologies