Author Topic: Code::Blocks projects and wx-3.1.7 with Leap-15.4 (Linux)  (Read 677 times)

Offline LETARTARE

  • Regular
  • ***
  • Posts: 491
  • L'ami de l'homme.The friend of man.
Code::Blocks projects and wx-3.1.7 with Leap-15.4 (Linux)
« on: June 16, 2022, 07:25:15 pm »
I just compiled 'CB-12838' under 'Leap15.4' with 'wx3.1.7'.
So I propose you a patch for the compilation, including the '*-3.1.x-Unix.cbp' and '*-3.1.x-Unix.workspace' and all 'update31' ( I hope I didn't forget anything !).
https://sourceforge.net/p/codeblocks/tickets/1265/
« Last Edit: June 16, 2022, 07:27:57 pm by LETARTARE »
CB-12888, plugins-sdk-2.22.0 : Collector-1.7.4, AddOnForQt-3.4.9
1-Win7 Business Pack1 64bits : wx-3.2.1, gcc-8.1.0,
2-OpenSuse::Leap-15.4-64bits : wx-3.2.0, gcc-9.3.1 ,
=> !! The messages are translated by Deepl

Offline AndrewCot

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 657
Re: Code::Blocks projects and wx-3.1.7 with Leap-15.4 (Linux)
« Reply #1 on: June 17, 2022, 12:11:14 am »
IMHO the number of CBP files is way too much and the maintenance of the files is an issue.
I would suggest as per already seen in other threads that the project files transition to use global variables in order to do the following:1) Support different versions of wxWidgets without requiring a set of files for a specific wxWidget version2) Support for Windows 32 and 64 bit in the one cbp set of files
3) Reduce the number of CBP sets to one per OS, so three Windows, Linux/Unix and one for MacOS
I have the MacOS project files working, but I have not created a ticket as I have too many patches banked up in the ticket system.

Offline AndrewCot

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 657
Re: Code::Blocks projects and wx-3.1.7 with Leap-15.4 (Linux)
« Reply #2 on: June 19, 2022, 03:52:48 am »