Author Topic: C::B LinuxMint 20.3 segmentation fault on start after upgrade LM & C::B  (Read 246 times)

Online AndrewCot

  • Regular
  • ***
  • Posts: 336
This looks like something has gone wrong with my Linux Mint virtual guest, but I cannot figure out what I need to do, so any pointers or help or advice is welcome as I have spend all day updating and trying things.

The problem is that after upgrading LinuxMint from 20.2 to 30.3 and then upgrading to the 12639 Nightly build from Xaviou in the  http://apt.xaviou.fr/debian11/pool/main/c/codeblocks directory I get the following when I run "gdb /usr/bin/codeblocks":
Code
Reading symbols from /usr/bin/codeblocks...
(No debugging symbols found in /usr/bin/codeblocks)
(gdb) r
Starting program: /usr/bin/codeblocks
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff69c3854 in wxBaseArrayPtrVoid::Add(void const*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
(gdb) back
#0  0x00007ffff69c3854 in wxBaseArrayPtrVoid::Add(void const*, unsigned long) () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#1  0x00007ffff69a1907 in wxCmdLineParser::AddSwitch(wxString const&, wxString const&, wxString const&, int) () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#2  0x00007ffff69a4b57 in wxCmdLineParser::SetDesc(wxCmdLineEntryDesc const*) () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#3  0x0000555555602cb0 in  ()
#4  0x00007ffff6a21a72 in wxEntry(int&, wchar_t**) () at /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0
#5  0x00005555555e9292 in  ()
#6  0x00007ffff63b60b3 in __libc_start_main (main=0x5555555e9280, argc=1, argv=0x7fffffffe5a8, init=<optimised out>, fini=<optimised out>, rtld_fini=<optimised out>, stack_end=0x7fffffffe598) at ../csu/libc-start.c:308
#7  0x00005555555fbe5a in  ()
(gdb)

Things I have tried:
   * Remove codeblocks and tried to reinstall 20.03 from the LM Software Manager, but this did not work and I did not want to spend allot of time on this as I want to use a recent nightly
   * Remove codeblocks and re-install from debs a number of times with reboots between them and still did not help
   * Upgrade the kernel from 5.15.2 to 5.15.14 just in case, but this did not help
   * Installed the http://ftp.de.debian.org/debian/pool/main/w/wxwidgets3.0/libwxbase3.0-0v5_3.0.5.1+dfsg-2_amd64.deb as reference on the https://debian.pkgs.org/11/debian-main-amd64/libwxbase3.0-0v5_3.0.5.1+dfsg-2_amd64.deb.html page , but again this did not help
    * Run other apps like Visual Code, Meld etc and they run okay.

Tonight if I get time I will install a new LM 20.3 guest from the LM 20.3 iso and see how I go.

Online AndrewCot

  • Regular
  • ***
  • Posts: 336
@Xaviou
I have installed a new virtualbox guest LM 20.3 from the linuxmint-20.3-xfce-64bit.iso and have found the following after narrowing the C::B install problem that I have been having with this new LM 20.03 install as follows:

1) If I try to install the Xaviou's Debian bullseye nightly 20.03svn12639 release I cannot due to dependency issues. Attahed is the install log showing the dependency issues.
2) If I install the following two deb's before trying to install Xaviou's debian bullseye then the install works and I can start C::B (have not tested it as this has taken a while to get to this stage):
     http://ftp.de.debian.org/debian/pool/main/w/wxwidgets3.0/libwxbase3.0-0v5_3.0.5.1+dfsg-2_amd64.deb
     http://archive.ubuntu.com/ubuntu/pool/universe/w/wxwidgets3.0/libwxgtk3.0-gtk3-0v5_3.0.5.1+dfsg-2_amd64.deb

Sorry, but I have no idea what the real problem is as I am not a hard core Linux developer and do not have the skills to figure out what is going on.

I have attached is the script I used to install codeblocks (appended .txt to be able to add it). It does not install the debs above. For Linux I try to create install scripts so the base install can be re-created and this script is a snippet taken from a larger script that installs a number of utilities (Meld, Git, PeaZip & & &....).

Let me know if you want me to try anything or if you need more info.