Author Topic: Windows CB using wxwidget debug DLL build issue with path query  (Read 2788 times)

Offline AndrewCot

  • Almost regular
  • **
  • Posts: 193
I have locally built wxwidget and CB, but if I set WX_SUFFIX to ud instead of u then when I run CB I get get errors with PNG files due to what looks like wxwidget not changing the path delimiters from unix to windows as per the following pop up error message:

---------------------------
19:41:35: Error: Failed to load image from file "F:\Andrew_Development\AC-WindowsInstaller\src\output31_64\share\codeblocks/images/wxsmith/wxTreeCtrl32.png".
---------------------------

Has anyone successfully run CB that has been built using the wxwidget debug DLL's without any pop up errors appearing that seem to be caused by a path issue?

Offline AndrewCot

  • Almost regular
  • **
  • Posts: 193
Re: Windows CB using wxwidget debug DLL build issue with path query
« Reply #1 on: July 30, 2021, 03:15:08 am »
Got CB working correctly with the debug wxwidget DLL's. I fell into the hole where the CB global variables are not true global variables that override the variables used in all cbp files when using a workspace.

I had the CodeBlocks_wx31_64.cbp configured for <Variable name="WX_SUFFIX" value="ud" /> , BUT the other cbp files still had the value 'u' and as such when I built CB via the batch_build_all_31_64.bat file I had some of the built files using the debug and other using the release wxwidget DLL's.....

There does not look like there is a way of building CB with the debug wxwidget dll's without modifying all of the CB project files. If this is not the case please point me to a URL/post or let me know where/how I can configure the build process to build against the the debug wxwidget DLL's without modifying all of the cbp files.

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 3009
Re: Windows CB using wxwidget debug DLL build issue with path query
« Reply #2 on: August 01, 2021, 05:59:12 pm »
It would be possible, but we have to make some homework first:
https://forums.codeblocks.org/index.php/topic,21696.msg147584.html#msg147584

Offline AndrewCot

  • Almost regular
  • **
  • Posts: 193
Re: Windows CB using wxwidget debug DLL build issue with path query
« Reply #3 on: August 02, 2021, 01:31:04 am »
Thanks very much for this thread link as it is exactly what I fell into. I will have a good read on this over the next few days.