Author Topic: How to install NEW Code::Blocks??  (Read 218 times)

Offline EverlyKingston

  • Single posting newcomer
  • *
  • Posts: 1
How to install NEW Code::Blocks??
« on: March 17, 2021, 11:43:29 am »
One installation way is :
sudo add-apt-repository ppa:damien-moore/codeblocks-stable
sudo apt update
sudo apt install codeblocks

But I think it is very old (2016 year?)
How to install newer, maybe not latest from nightly build but a bit newer.
I have Mint 20.
But this archive has many .deb files. I must use gdebi? For all files? Which order?
I use  sudo dpkg -i *.deb but with many conflicts, I must  remove some deb from folder and again. Next I have runtime error: libwx_gtk2u_aui-3.0.so.0 -> want version 2 but in deb are version 3 gtk and wx

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2948
Re: How to install NEW Code::Blocks??
« Reply #1 on: March 17, 2021, 04:25:05 pm »
Here you can find a up to date ppa:
https://launchpad.net/~fuscated/+archive/ubuntu/codeblocks-nightly
[edit:] at least to some months ago....

It is very easy to build codeblocks: https://github.com/bluehazzard/codeblocks_sf/wiki/build_linux_mint_18
If you find some problems, please report them!