Author Topic: wxWidget with codeblocks problem  (Read 53483 times)

Offline gtafan

  • Almost regular
  • **
  • Posts: 126
Re: wxWidget with codeblocks problem
« Reply #45 on: April 10, 2017, 01:34:15 pm »
Ok, one last time:
In post #6:
Here the path:

but it canĀ“t be the problem, because wrong path would show an error mesage just after this dialog.
My options look like that:

Just for fun have tried all posible combinations, but always got exactlly the same error.

The lib folder looks like that:
and the gcc_lib:

Posibly some .a files are mising?
you posted a image with the files:
Now we told you like 1000 times that your wxWidgets build failed and for this you are missing some libraries:
There are two missing libraries, libwxmsw30u.a and libwxmsw30u_gl.a.

You should call again the compilation command and look for compilation errors (one frequent error with monolithic builds is related to memory starvation in ld).
after this nothing productive happened... You whined about how complicated all this is, we whined how you can not simply post the error messages you get. After this we thought you have successfully build wxWidgets and so we asked if you can post the filenames again, but you told us that you have posted them in #6 and we told you that this is not the case and so on and so on... BlaBlaBlaBla...

Simply follow the steps from the other link and if you hit a error post a screenshot of the error here....
No meter what I did, always got the same result as in post #6, the comandline was wrong, or to be more precise incomplete. Like somebody mentioned here, 2 .a files were mising, but instead of telling that, the CB wizard tolld me something about wrong configuration, which was really iritating.
The really anoing thing about comandline is not the fact I have to use it, but the time it takes to build. Hope I was able to make ewerithing clear.

Offline gtafan

  • Almost regular
  • **
  • Posts: 126
Re: wxWidget with codeblocks problem
« Reply #46 on: December 25, 2022, 05:38:16 pm »
Is it not posible just simply to open the make file from wxWidgets in CB like it can be done wit VS or DevCpp makefiles?