Author Topic: [RESOLVED] Compilation failure using wxwidgets and resource files  (Read 3393 times)

Offline mrSimple

  • Single posting newcomer
  • *
  • Posts: 2
As title says, i am unable to build a "blank" project for Win32 using wxwidgets.

I am new to Code Blocks and new to free IDE/compiler software.

Next follows a list of actions, errors and solutions as i have encountered them.

Downloaded and installed from "codeblocks-10.05mingw-setup.exe" (IDE + compiler).
Required files for compiling with wxwidgets, despite included wxwidgets editing capabiities built into IDE , are not included.

So downloaded and installed "wxPack_v2.8.11.02.exe".

Environment variables
Code
WXADDITIONS=C:\Program Files\wxWidgets2.8\additions
WXWIN=C:\Program Files\wxWidgets2.8

Chose wizard-driven project setup.

-type wxWidgets Project
-version wxWidgets2.8.x
-chose project name and directory
-filled in user name and email
-selected wxFormBuilder and Dialog Based
-chose wxwidgets location  C:\Program Files\wxWidgets2.8
-chose compiler GNU GCC Compiler (did not found MinGW in list, even if C::B setup INCLUDED AND OFFERED IT)
 [NOTE: is THIS a critical point causing failure !?]
-chose release and debug configuration, used defaults
-config options left blank
-additional libraries ALL added (everything that was offered)

Trying to build.
I get
Code
"error: wx/msw/wx.rc: No such file or directory"

Fixed after searching forum
Code
Go to menu Project
   Build Options ...
      Search Directories
         Resource Compiler
            Add
               "C:\Program Files\wxWidgets2.8\includ\wx\msw\"

Trying again to build.
Entire usage help shows in Build Log, here is an excerpt:
Code
No input-file is stdin, default rc.  No output-file is stdout, default rc.

Fix : None found so far.

After searching through forum for with the above line and also using keyword "windres" found no topic with helpful information.

Found only topics where members are complaining about this error but no responses or with solutions unrelated to problem at hand.

Some topics that have relevant posts have either a solution that is already defined in project properties, such as this one
Code
http://forums.codeblocks.org/index.php/topic,541.0.html
or dead links etc ...

Also what surprised is how OLD these posts are. Is it possible that since 2006 (date of newest post found in search results)
this problem still persists !?

Also tried, per suggestion in Help sub-forum sticky
Code
http://forums.codeblocks.org/index.php/topic,246.0.html
to search Berlios on this issue. Used same search phrase as above, tried "windres", tried "resource", tried "resources" with no luck.

How to enable Code::Blocks to work with MinGW and wxWidgets, which are supposedly supported ?
« Last Edit: October 07, 2010, 03:14:42 am by mrSimple »

Offline mrSimple

  • Single posting newcomer
  • *
  • Posts: 2
Re: Compilation failure using wxwidgets and resource files
« Reply #1 on: October 07, 2010, 03:14:25 am »
Found what was basic error : when wxPack setup asked for install location, i chose program files folder, which contains spaces. Re-installed and left default location (an ugly placement directly on root of drive).

So a basic blank project, with no additional libraries was built and run !

It is amazing that 1985 tech still bites back when it comes to spaces in names  :D

Offline Linuxx

  • Multiple posting newcomer
  • *
  • Posts: 17
Re: [RESOLVED] Compilation failure using wxwidgets and resource files
« Reply #2 on: December 16, 2010, 12:40:35 pm »
Thank you so much! This solved my problem too...

 :D :D :D :D :D

Linuxx