Author Topic: error : invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!].  (Read 11492 times)

jack.x.lee

  • Guest
Hi All,

 I just had installed code blocks 8.02 on Fedora 7.  it can't work correctly, because when compile a file,
a error message (see following)  in the "build log" window. I had installed gcc 4.3.0 before code blocks.

"test - Release" uses an invalid compiler [YOUR ANSWER IS ALREADY THERE. SEARCH THE FORUMS!]. Skipping...
Nothing to be done.


 on my  Windows XP OS, it works well, but while i install it on my Fedora7, it can not work.
 who can help me?

 :( :( :( :( :( :(

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
You need to set up our compiler paths and/or executable names correctly (Compiler settings, toolchain executables). Apparently your gcc is either installed in a location where Code::Blocks doesn't find them, or it has a non-standard name.
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

yi_jun_jun

  • Guest
Hi jack:

i am chinese. i also use codeblock on FC7. like you, i be troubled by this problem. but i make it right now.

follow me:

codeblock->setting->compiler and debugger setting->global compiler settings->toolchain executables->compiler's installation directory

fill "/usr" not "/usr/lib" .

notice describe letter!

i want to help you.just try!

ppesci

  • Guest
Thanks, it worked fine :).

A very annoying thing. Maybe packager must check if the thing they are building works well.

Offline SharkCZ

  • Almost regular
  • **
  • Posts: 127
It is not a bug in distro or packaging, but a bug in the compiler detection in C::B, it gets fooled when ccache package (compiler cache) is installed. It was fixed in SVN revision 5159.
Code::Blocks package maintainer for Fedora and EPEL