Author Topic: WxWidget problem  (Read 8604 times)

Offline Adam01

  • Single posting newcomer
  • *
  • Posts: 9
WxWidget problem
« on: August 23, 2008, 04:18:12 pm »
Hi, I've looked at all the tutorials, tried different methods, and still get the same error:

Code: [Select]
||=== wxtest, Release ===|
C:\wxWidgets-2.8.8\include\wx\platform.h|196|wx/setup.h: No such file or directory|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|103|#error "wxUSE_DYNLIB_CLASS must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|111|#error "wxUSE_EXCEPTIONS must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|119|#error "wxUSE_FILESYSTEM must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|127|#error "wxUSE_FS_ARCHIVE must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|140|#error "wxUSE_DYNAMIC_LOADER must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|148|#error "wxUSE_LOG must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|156|#error "wxUSE_LONGLONG must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|164|#error "wxUSE_MIMETYPE must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|180|#error "wxUSE_PRINTF_POS_PARAMS must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|188|#error "wxUSE_PROTOCOL must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|230|#error "wxUSE_REGEX must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|238|#error "wxUSE_STDPATHS must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|246|#error "wxUSE_XML must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|254|#error "wxUSE_SOCKETS must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|262|#error "wxUSE_STREAMS must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|270|#error "wxUSE_STOPWATCH must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|278|#error "wxUSE_TEXTBUFFER must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|286|#error "wxUSE_TEXTFILE must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|302|#error "wxUSE_URL must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|310|#error "wxUSE_VARIANT must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|330|#error "wxUSE_ABOUTDLG must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|338|#error "wxUSE_ACCEL must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|346|#error "wxUSE_ANIMATIONCTRL must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|354|#error "wxUSE_BITMAPCOMBOBOX must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|362|#error "wxUSE_BMPBUTTON must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|370|#error "wxUSE_BUTTON must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|378|#error "wxUSE_CALENDARCTRL must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|386|#error "wxUSE_CARET must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|394|#error "wxUSE_CHECKBOX must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|410|#error "wxUSE_CHOICE must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|418|#error "wxUSE_CHOICEBOOK must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|426|#error "wxUSE_CHOICEDLG must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|434|#error "wxUSE_CLIPBOARD must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|442|#error "wxUSE_COLLPANE must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|450|#error "wxUSE_COLOURDLG must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|458|#error "wxUSE_COLOURPICKERCTRL must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|466|#error "wxUSE_COMBOBOX must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|474|#error "wxUSE_COMBOCTRL must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|482|#error "wxUSE_DATAOBJ must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|490|#error "wxUSE_DATAVIEWCTRL must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|498|#error "wxUSE_DATEPICKCTRL must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|506|#error "wxUSE_DIRPICKERCTRL must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|514|#error "wxUSE_DISPLAY must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|522|#error "wxUSE_DOC_VIEW_ARCHITECTURE must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|530|#error "wxUSE_FILEDLG must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|538|#error "wxUSE_FILEPICKERCTRL must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|546|#error "wxUSE_FONTDLG must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|554|#error "wxUSE_FONTMAP must be defined."|
C:\wxWidgets-2.8.8\include\wx\chkconf.h|562|#error "wxUSE_FONTPICKERCTRL must be defined."|
||More errors follow but not being shown.|
[/size]

If I included setup.h, it would say only for msvc.

Offline TDragon

  • Lives here!
  • ****
  • Posts: 943
    • TDM-GCC
Re: WxWidget problem
« Reply #1 on: August 23, 2008, 06:03:57 pm »
You obviously haven't looked at all the tutorials. Try the wxWindowsQuickRef.
https://jmeubank.github.io/tdm-gcc/ - TDM-GCC compiler suite for Windows (GCC 9.2.0 2020-03-08, 32/64-bit, no extra DLLs)

Offline Adam01

  • Single posting newcomer
  • *
  • Posts: 9
Re: WxWidget problem
« Reply #2 on: August 23, 2008, 07:27:07 pm »
Actually I have, and theres no path called "\gcc_dll\" in the entire WxWidget directory.

Offline dje

  • Lives here!
  • ****
  • Posts: 683
Re: WxWidget problem
« Reply #3 on: August 23, 2008, 07:31:51 pm »
It is automatically created when you build wxWidgets with shared and release options.

Dje

Offline Adam01

  • Single posting newcomer
  • *
  • Posts: 9
Re: WxWidget problem
« Reply #4 on: August 23, 2008, 08:01:24 pm »
Ok, thanks, I did another command prompt attempt.
But now I get the 2nd FAQ error:

| cannot find -lwxmsw28u|

I checked the linker, everything is fine, what directories should be there anyway?

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
Re: WxWidget problem
« Reply #5 on: August 23, 2008, 08:42:50 pm »
Ok, thanks, I did another command prompt attempt.
But now I get the 2nd FAQ error:

| cannot find -lwxmsw28u|

I checked the linker, everything is fine, what directories should be there anyway?

Did you set your "$(#wx)"-variable correctly to your wxWidgets base directory ?

After doing a wxWidgets release-build their should be a directory like "c:\wxWidgets-2.8.8\lib\gcc_dll" containing "libwxmsw28u.a" and "wxmsw28u_gcc_custom.dll" and some other "*.a" and maybe "*.dll"-files (e.g. from a debug-version).

If you have done everything as described in the "wxWindowsQuickRef" it should work.
You might want to copy the dll's from  c:\wxWidgets-2.8.8\lib\gcc_dll" (in my case) to the "system32" directory of your "windows" folder, because they might not be found otherwise.

Offline Adam01

  • Single posting newcomer
  • *
  • Posts: 9
Re: WxWidget problem
« Reply #6 on: August 23, 2008, 08:47:48 pm »
Sorry, there are no files in the gcc_dll directory.
But 'mingw32-make -f "C:\wxWidgets-2.8.8\build\msw\makefile.gcc" MONOLITHIC=1 SHARED=1 UNICODE=1 BUILD=release' fails both ways.
If I 'cd' the mingw32 directory, it wont find config.gcc, if I 'cd' the \build\msw\ directory, it cant find gcc, and returns an error.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7255
Re: WxWidget problem
« Reply #7 on: August 23, 2008, 10:25:00 pm »
Sorry, there are no files in the gcc_dll directory.
But 'mingw32-make -f "C:\wxWidgets-2.8.8\build\msw\makefile.gcc" MONOLITHIC=1 SHARED=1 UNICODE=1 BUILD=release' fails both ways.
If I 'cd' the mingw32 directory, it wont find config.gcc, if I 'cd' the \build\msw\ directory, it cant find gcc, and returns an error.

Add your MinGW\bin directory to your path-variable and it should work from "c:\wxWidgets-2.8.8\build\msw" .

Offline Adam01

  • Single posting newcomer
  • *
  • Posts: 9
Re: WxWidget problem
« Reply #8 on: August 23, 2008, 11:27:16 pm »
It works!
Thank you soo much.

Its doing the wx compiling now...

Offline Siavash

  • Single posting newcomer
  • *
  • Posts: 9
Re: WxWidget problem
« Reply #9 on: August 31, 2008, 05:05:33 pm »
It works!
Thank you soo much.

Its doing the wx compiling now...

I've followed these steps but there isn't any lib_dll folder or lwxmsw28u.a created.
[+When I'm trying to make a new project using wxWidgets , It says "A matching Debug/Release configuration connot be found in the wxWidgets ..."]

Offline Adam01

  • Single posting newcomer
  • *
  • Posts: 9
Re: WxWidget problem
« Reply #10 on: August 31, 2008, 05:08:58 pm »
Ignore those messages, it works fine anyway.
Check this page out http://wiki.codeblocks.org/index.php?title=WxWindowsQuickRef
Did you compile wxwidgets?, you need to follow every step, as I found out.

Offline Siavash

  • Single posting newcomer
  • *
  • Posts: 9
Re: WxWidget problem
« Reply #11 on: August 31, 2008, 08:04:14 pm »
Ignore those messages, it works fine anyway.
Check this page out http://wiki.codeblocks.org/index.php?title=WxWindowsQuickRef
Did you compile wxwidgets?, you need to follow every step, as I found out.
Thanks alot my friend, It's working  :o