Author Topic: {thread search] File mask not saved  (Read 2941 times)

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2842
Re: {thread search] File mask not saved
« Reply #15 on: February 17, 2019, 04:37:49 pm »
Ok, i applied the patches about the file masks: points 2 and 4
There is still point 3, where i still have to figure out how the sizer have to be set and the crash reported in ticket 777

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12821
    • Travis build status
Re: {thread search] File mask not saved
« Reply #16 on: October 17, 2020, 01:06:05 pm »
@bluehazzard: Are there anything else here to be fixed? I've made a lot of changes to the ThreadSearch, so I might have accidentally fixed it.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline BlueHazzard

  • Developer
  • Lives here!
  • *****
  • Posts: 2842
Re: {thread search] File mask not saved
« Reply #17 on: October 18, 2020, 08:22:51 pm »
With the latest trunk i still see some wired behaviour:
1) Open the Thread search tab
2) press show/hide dir items
3) now if you click trough the search options (search in workspace, search in open files ecc.) The file mask is only enabled if you search in directory. I do not know it this is wanted, or if the mask should also apply for workspace search ecc.. Anyway:
4) Search in workspace, execute the search
5) Search successful, but the file mask now seems to be active (not greyed out) but you can not enter anything. It only appears enabled, but is disabled...

A other thing:
If you open the thread search options and modify the "Search in files" again, like search in workspace, search in open files ecc the mask control is never deactivated... So it is inconsistent with the tab behaviour...

[edit] windows, wxWidgets 3.1.4
« Last Edit: October 18, 2020, 08:25:32 pm by BlueHazzard »