Author Topic: How to install Code::Blocks :-(  (Read 2584 times)

Offline coder89

  • Single posting newcomer
  • *
  • Posts: 4
How to install Code::Blocks :-(
« on: May 15, 2008, 08:48:07 pm »
Hello
I have Ubuntu 7.10 Gutsy. I have downloaded codeblocks_8.02-0ubuntu1.deb.tar.gz and unpacked it. I tried to install it but i get error: "Dependency is not satisfiable: libwxgtk2.8-0" so i go to my Synaptic Packet Manager and I have downloaded all wxWidgets and wx* packets and libraries. But i still have this same error that libwxgtk2.8-0. (libwxgtk2.8 is configured as default!)
Then I tried to do all things which i read in: http://wiki.codeblocks.org/index.php?title=Installing_Code::Blocks_nightly_build_on_Ubuntu
Suddenly libcodeblocks was instaled using a terminal but it was some errors becouse it wasn't configured. So it doesn't work... I still get errors that libwxgtk isn't installed (but really it is!) when i double-click on libcodeblocks... :(

Pleas help me... which packages i have to install or what to do to install this IDE (the best i've heard).
Best regards.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7253
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: How to install Code::Blocks :-(
« Reply #1 on: May 15, 2008, 08:58:59 pm »
You need wxWidgets 2.8.7 what (I think) is not (yet) in ubuntu's rep.

Look here how to fetch it from apt.wxwidgets.org .