Author Topic: Codeblocks triggers X Windows System error  (Read 11412 times)

Offline ASJ

  • Multiple posting newcomer
  • *
  • Posts: 46
Codeblocks triggers X Windows System error
« on: January 18, 2008, 01:53:25 pm »
All of a sudden my Codeblocks doesn't start up anymore, giving the following message right after the splash screen flashes for a moment:
Code: [Select]
  The program 'codeblocks' received an X Window System error.
  This probably reflects a bug in the program.
  The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 1304 error_code 11 request_code 145 minor_code 5)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

After re-installing x.org this problem still remains. Also building a new version from svn does not change anything. I am using openSuse 10.3 (also tried the TuXKeeper rpm, it gives the same problems).
Does anyone have the same problem or have a clue to solve this problem?

TIA

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Codeblocks triggers X Windows System error
« Reply #1 on: January 18, 2008, 02:32:13 pm »
This is not (only) a C::B problem:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=461410
You can downgrade "xserver-xorg-core" manually to make it work again.

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Codeblocks triggers X Windows System error
« Reply #2 on: January 18, 2008, 02:58:29 pm »
Ubuntu 7.10, Codeblocks svn4639
Reinstalling to Codeblocks svn4830 (from 'lgp203.free.fr' repository) don't help... :(
Again: it's not C::B related.
It's a bug in xserver-xorg caused by a security update.
For Ubuntu look here: https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/183969 .

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7265
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: Codeblocks triggers X Windows System error
« Reply #3 on: January 18, 2008, 03:14:49 pm »
I just got a mail from debian package-maintainer.

As workaround you can try to put the following into "xorg.conf" and restart XServer:
Code: [Select]
        Section "Extensions"
                Option "MIT-SHM" "no"
        EndSection

Offline HCHRIST

  • Single posting newcomer
  • *
  • Posts: 3
Re: Codeblocks triggers X Windows System error
« Reply #4 on: January 18, 2008, 04:06:24 pm »
xorg.conf addition works for me. Thanks lad.

Offline ASJ

  • Multiple posting newcomer
  • *
  • Posts: 46
Re: Codeblocks triggers X Windows System error
« Reply #5 on: January 18, 2008, 08:57:05 pm »
The xorg.conf addition works fine for me as well!
Thanks a lot! you saved my day! 8)

Offline HCHRIST

  • Single posting newcomer
  • *
  • Posts: 3
Re: Codeblocks triggers X Windows System error
« Reply #6 on: January 19, 2008, 07:37:11 pm »
I noticed on my kubuntu machine that there was an update of the x-server-core, among others. So I removed the patch above from my xorg.conf file, to see if the problem was gone. And yep: everything works again with the old xorg.conf file.

So, probably a temporary problem.

Offline PauloH

  • Single posting newcomer
  • *
  • Posts: 5
Re: Codeblocks triggers X Windows System error
« Reply #7 on: January 19, 2008, 08:54:37 pm »
There is an upgrade right now. The problem was solved. My "gnome" made the update when I started my machine. No need to use the old xorg.conf again.

Bye.
« Last Edit: January 19, 2008, 09:01:05 pm by PauloH »

Hossein

  • Guest
Re: Codeblocks triggers X Windows System error
« Reply #8 on: May 08, 2012, 01:27:49 pm »
As workaround you can try to put the following into "xorg.conf" and restart XServer:
Code: [Select]
       Section "Extensions"
                Option "MIT-SHM" "no"
        EndSection

I seem to have difficulty finding my xorg.conf. In my VMWare Kubunutu, I searched for the file and found a directory containing vm*.* files. I added the above piece of code in a new file in the directory and restarted the machine. I still get the same error! Any idea? (I'm using CB 10.05 under KUbuntu 12.04 64B.)
« Last Edit: May 08, 2012, 04:30:57 pm by Hossein »