Author Topic: Problems while install CB with rpm pack  (Read 2337 times)

Offline skyplus

  • Multiple posting newcomer
  • *
  • Posts: 11
Problems while install CB with rpm pack
« on: November 21, 2007, 04:45:44 am »
I am using  `rpm -i CB_20070105_rev3461_fc4+5.i586.rpm`
to install Code::Blocks IDE on our server. It failed with unresolved denpendencies, as listed below.
/////////////////////////////////
(1)the gcc version:
      gcc (GCC) 3.4.6 20060404 (Red Hat 3.4.6-8)
(2)also, I can find libstdc++.so.6 under dir "/usr/lib/libstdc++.so.6"
or "/usr/lib64/libstdc++.so.6"
(3)i have already built and installed wxGTK2.6
wx-config --version-full
      2.6.4.0
Someone Plaese help me :(
////////////////////////////////
error: Failed dependencies:
        libstdc++.so.6(GLIBCXX_3.4.4) is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libstdc++.so.6(GLIBCXX_3.4.6) is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_baseu-2.6.so.0 is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_baseu-2.6.so.0(WXU_2.6) is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_baseu_net-2.6.so.0 is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_baseu_net-2.6.so.0(WXU_2.6) is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_baseu_xml-2.6.so.0 is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_baseu_xml-2.6.so.0(WXU_2.6) is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_gtk2u_adv-2.6.so.0 is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_gtk2u_adv-2.6.so.0(WXU_2.6) is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_gtk2u_core-2.6.so.0 is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_gtk2u_core-2.6.so.0(WXU_2.6) is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_gtk2u_core-2.6.so.0(WXU_2.6.2) is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_gtk2u_core-2.6.so.0(WXU_2.6.3) is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_gtk2u_html-2.6.so.0 is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_gtk2u_html-2.6.so.0(WXU_2.6) is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_gtk2u_qa-2.6.so.0 is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_gtk2u_qa-2.6.so.0(WXU_2.6) is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_gtk2u_xrc-2.6.so.0 is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        libwx_gtk2u_xrc-2.6.so.0(WXU_2.6) is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586
        wxGTK >= 2.6.0 is needed by codeblocks-1.0_0.svn.3461-0.fc4+5.i586

Offline skyplus

  • Multiple posting newcomer
  • *
  • Posts: 11
Re: Problems while install CB with rpm pack
« Reply #1 on: November 21, 2007, 04:51:33 am »
# uname -a
Linux localhost 2.6.9-55.ELsmp #1 SMP Wed May 2 14:04:42 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux


forgot to tell this, Sorry~

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4291
    • Code::Blocks IDE
Re: Problems while install CB with rpm pack
« Reply #2 on: November 21, 2007, 09:32:53 am »
I don't know much about rpm, but somehow those two don't seem to fit together:

Quote
CB_20070105_rev3461_fc4+5.i586.rpm
Linux localhost 2.6.9-55.ELsmp #1 SMP Wed May 2 14:04:42 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux

Anyway, maybe the packager could tell you more...
Be patient!
This bug will be fixed soon...

Offline skyplus

  • Multiple posting newcomer
  • *
  • Posts: 11
Re: Problems while install CB with rpm pack
« Reply #3 on: November 21, 2007, 11:33:00 am »
This is yum‘s prompt

[[email protected]]# yum install CB_20070520_rev3975_fc4+5.i586.rpm
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Examining CB_20070520_rev3975_fc4+5.i586.rpm: codeblocks - 1.0_0.svn.3975-0.fc4+5.i586
Marking CB_20070520_rev3975_fc4+5.i586.rpm to be installed
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package codeblocks.i586 0:1.0_0.svn.3975-0.fc4+5 set to be updated
--> Running transaction check
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.4) for package: codeblocks
--> Processing Dependency: libwx_baseu_xml-2.6.so.0 for package: codeblocks
--> Processing Dependency: libwx_gtk2u_adv-2.6.so.0(WXU_2.6) for package: codeblocks
--> Processing Dependency: libwx_baseu_xml-2.6.so.0(WXU_2.6) for package: codeblocks
--> Processing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6.2) for package: codeblocks
--> Processing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6.3) for package: codeblocks
--> Processing Dependency: libwx_baseu-2.6.so.0(WXU_2.6) for package: codeblocks
--> Processing Dependency: libwx_gtk2u_xrc-2.6.so.0(WXU_2.6.2) for package: codeblocks
--> Processing Dependency: wxGTK >= 2.6.0 for package: codeblocks
--> Processing Dependency: libwx_gtk2u_adv-2.6.so.0 for package: codeblocks
--> Processing Dependency: libwx_gtk2u_html-2.6.so.0(WXU_2.6) for package: codeblocks
--> Processing Dependency: libwx_gtk2u_qa-2.6.so.0(WXU_2.6) for package: codeblocks
--> Processing Dependency: libwx_baseu_net-2.6.so.0 for package: codeblocks
--> Processing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6) for package: codeblocks
--> Processing Dependency: libwx_gtk2u_xrc-2.6.so.0 for package: codeblocks
--> Processing Dependency: libwx_baseu_net-2.6.so.0(WXU_2.6) for package: codeblocks
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.6) for package: codeblocks
--> Processing Dependency: libwx_gtk2u_core-2.6.so.0 for package: codeblocks
--> Processing Dependency: libwx_baseu-2.6.so.0 for package: codeblocks
--> Processing Dependency: libwx_gtk2u_xrc-2.6.so.0(WXU_2.6) for package: codeblocks
--> Processing Dependency: libwx_gtk2u_html-2.6.so.0 for package: codeblocks
--> Processing Dependency: libwx_gtk2u_qa-2.6.so.0 for package: codeblocks
--> Finished Dependency Resolution
Error: Missing Dependency: libstdc++.so.6(GLIBCXX_3.4.4) is needed by package codeblocks
Error: Missing Dependency: libwx_baseu_xml-2.6.so.0 is needed by package codeblocks
Error: Missing Dependency: libwx_gtk2u_adv-2.6.so.0(WXU_2.6) is needed by package codeblocks
Error: Missing Dependency: libwx_baseu_xml-2.6.so.0(WXU_2.6) is needed by package codeblocks
Error: Missing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6.2) is needed by package codeblocks
Error: Missing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6.3) is needed by package codeblocks
Error: Missing Dependency: libwx_baseu-2.6.so.0(WXU_2.6) is needed by package codeblocks
Error: Missing Dependency: libwx_gtk2u_xrc-2.6.so.0(WXU_2.6.2) is needed by package codeblocks
Error: Missing Dependency: wxGTK >= 2.6.0 is needed by package codeblocks
Error: Missing Dependency: libwx_gtk2u_adv-2.6.so.0 is needed by package codeblocks
Error: Missing Dependency: libwx_gtk2u_html-2.6.so.0(WXU_2.6) is needed by package codeblocks
Error: Missing Dependency: libwx_gtk2u_qa-2.6.so.0(WXU_2.6) is needed by package codeblocks
Error: Missing Dependency: libwx_baseu_net-2.6.so.0 is needed by package codeblocks
Error: Missing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6) is needed by package codeblocks
Error: Missing Dependency: libwx_gtk2u_xrc-2.6.so.0 is needed by package codeblocks
Error: Missing Dependency: libwx_baseu_net-2.6.so.0(WXU_2.6) is needed by package codeblocks
Error: Missing Dependency: libstdc++.so.6(GLIBCXX_3.4.6) is needed by package codeblocks
Error: Missing Dependency: libwx_gtk2u_core-2.6.so.0 is needed by package codeblocks
Error: Missing Dependency: libwx_baseu-2.6.so.0 is needed by package codeblocks
Error: Missing Dependency: libwx_gtk2u_xrc-2.6.so.0(WXU_2.6) is needed by package codeblocks
Error: Missing Dependency: libwx_gtk2u_html-2.6.so.0 is needed by package codeblocks
Error: Missing Dependency: libwx_gtk2u_qa-2.6.so.0 is needed by package codeblocks