Author Topic: DO NOT USE wxWidgets version 2.8.5  (Read 9000 times)

Offline raph

  • Almost regular
  • **
  • Posts: 242
Re: wxWidgets updated to version 2.8.5
« Reply #15 on: September 11, 2007, 02:38:15 pm »
No problem here running cb rev 4458 with wxMSW-2.8.5.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7056
    • My Best Post
Re: wxWidgets updated to version 2.8.5
« Reply #16 on: September 15, 2007, 07:40:39 pm »
The wxWidgets devs are talking about a quick 2.8.6 because a few bugs were found after release in 2.8.5

Tim S

Quote
ce> what is/went wrong with 2.8.5 ?

 There is the status bar problem under wxMSW and the fact that calling
Eof() on a stream used by wxTextInputStream (as is done by wxExecute
overload with IO redirection) never returns true any more. I.e. nothing
wrong with packaging (AFAIK), just bugs.

 Regards,
VZ
« Last Edit: September 15, 2007, 07:43:52 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline vapor

  • Single posting newcomer
  • *
  • Posts: 5
Re: wxWidgets updated to version 2.8.5
« Reply #17 on: September 24, 2007, 09:35:43 pm »
Been using 2.9 CVS for a while now and so far so good.
Haven't yet delved too deeply into the updated or new code yet though; just notebook, listbook, the same ol stuff.

<modified>
Forgot to mention I'm using Debian lenny. Most stable pre-release I've seen.
« Last Edit: September 24, 2007, 09:52:33 pm by vapor »

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7056
    • My Best Post
Re: wxWidgets updated to version 2.8.5
« Reply #18 on: September 25, 2007, 06:26:04 pm »
Hello,
wxWidgets 2.8.6 has appeared at the York site => http://biolpc22.york.ac.uk/pub/2.8.6/


Note, they are starting the 2.8.6 release cycle, they normally wait for package issues for a few hours before posting to sourceForge.net

Tim S
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org