Author Topic: problem installing wxSmith ...  (Read 6273 times)

Offline pivit80

  • Multiple posting newcomer
  • *
  • Posts: 27
problem installing wxSmith ...
« on: July 05, 2007, 08:40:54 pm »
Hi,
I've downloaded latest codeblocks svn (rev 4228).
Installation finished OK.
But when I run the program I receive this popup message:

Quote
One or more plugins were not loaded.
This happens ...
....
List of failed plugins:

libwxsmith.so
libwxsmithcontribitems.so

practically it says I've a version of wxSmith plugin isn't compatible with the codeblocks version I've installed.
How shall I do to install wxSmith?

And generally, What's the link to download a codeblocks plugin?
Is there a page where I can find them?

Thank you in advance.
pv

Offline raph

  • Almost regular
  • **
  • Posts: 242
Re: problem installing wxSmith ...
« Reply #1 on: July 05, 2007, 08:54:10 pm »
practically it says I've a version of wxSmith plugin isn't compatible with the codeblocks version I've installed.
How shall I do to install wxSmith?
You do not need to install wxSmith. Just use a current nightly build and you will be fine.

And generally, What's the link to download a codeblocks plugin?
Is there a page where I can find them?
A lot of plugins come with codeblocks. So either use a current nightly build or build codeblocks by yourself.
If you build it yourself, simply build the ContribPlugins.workspace workspace and run update.bat(on linux do "./configure --enable-contrib").
You do also find some plugins in the plugins development forum  :wink:

Offline pivit80

  • Multiple posting newcomer
  • *
  • Posts: 27
Re: problem installing wxSmith ...
« Reply #2 on: July 05, 2007, 09:27:58 pm »
Thank you for the answer,
but I've already done what you say.

There is no nightly build for linux mandriva distribution, so I've downloaded latest svn.
Anyhow I have always used the svn to install or update codeblocks on linux, and I've never had problems;
this is the first time I have problem with wxSmith plugin.
I've used --enable-contrib;
all plugins have been installed regularly, except wxSmith.

Can it be a conflict with previous version of wxSmith?
When I run "make uninstall" the library libwxsmith.so is deleted?

Please, let me say if anyone have installed codeblocks from svn (rev 4228) and wxsmith works.

Thank you again.
pv

Offline pivit80

  • Multiple posting newcomer
  • *
  • Posts: 27
Re: problem installing wxSmith ...
« Reply #3 on: July 05, 2007, 11:44:39 pm »
In the codeblocks log, I've these errors:

ERROR: /usr/local/share/codeblocks/plugins/libwxsmith.so: not loaded (missing symbols?)
ERROR: /usr/local/share/codeblocks/plugins/libwxsmithcontribitems.so: not loaded (missing symbols?)


No solutions?

I think wxSmith version, isn't updated.

pv

Offline Auria

  • Almost regular
  • **
  • Posts: 152
Re: problem installing wxSmith ...
« Reply #4 on: July 06, 2007, 12:29:59 am »
Are you using wxWidgets 2.6 ? If so that is the problem, wxSmith now only works in 2.8 as of recently IIRC (this is probably not a desired behaviour, but the wxSmith maintainer is on holiday now still IIRC)

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7065
    • My Best Post
Re: problem installing wxSmith ...
« Reply #5 on: July 06, 2007, 12:37:12 am »
Are you using wxWidgets 2.6 ? If so that is the problem, wxSmith now only works in 2.8 as of recently IIRC (this is probably not a desired behaviour, but the wxSmith maintainer is on holiday now still IIRC)

That was supposed to be fixed in 4228, but I have not had it confirmed that it works. Will try it myself now; will be a couple of hours at least.

Note: I can build wxSmith with wx 26, but wxSmith items still does not work. Is that the one with the error for you?

Tim S
« Last Edit: July 06, 2007, 02:51:18 am by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline pivit80

  • Multiple posting newcomer
  • *
  • Posts: 27
Re: problem installing wxSmith ...
« Reply #6 on: July 06, 2007, 08:26:25 am »
No,
I use wxWidgets 2.8 .

Quote
wx-config --libs
-pthread -L/usr/X11R6/lib  -lwx_gtk2u_aui-2.8 -lwx_gtk2u_xrc-2.8 -lwx_gtk2u_qa-2.8 -lwx_gtk2u_html-2.8 -lwx_gtk2u_adv-2.8 -lwx_gtk2u_core-2.8 -lwx_baseu_xml-2.8 -lwx_baseu_net-2.8 -lwx_baseu-2.8

Is there a way to compile plugin manually?
I've tried to open file wxSmith-unix.cbp and wxSmith.cbp, but I don't know what are the settings to compile it.

Is there anyone have installed svn 4228?
If yes, does wxSmith plugin works?

Thank you again.
pv

Offline pivit80

  • Multiple posting newcomer
  • *
  • Posts: 27
Re: problem installing wxSmith ...
« Reply #7 on: July 06, 2007, 03:58:45 pm »
Hi,
I've installed latest nightly build under windows and it works fine!
all plugins, wxSmith included, work fine.

Why this?
What can be the problem with linux?

Please help me.
Thank you in advance.
pv


Offline dmoore

  • Developer
  • Lives here!
  • *****
  • Posts: 1576
Re: problem installing wxSmith ...
« Reply #8 on: July 06, 2007, 04:11:24 pm »
have you tried:

1. (maybe) delete any pch files in trunk/src/include
2. open CodeBlocks-unix.cbp in code::blocks
3. select Build -> Rebuild
4. open ContribPlugins-unix.workspace in code::blocks
5. select Build -> Rebuild Workspace

(If you haven't already you will need to set the cb variable to <path to your checkout>/trunk/src)
« Last Edit: July 06, 2007, 04:13:26 pm by dmoore »

Offline pivit80

  • Multiple posting newcomer
  • *
  • Posts: 27
Re: problem installing wxSmith ...
« Reply #9 on: July 06, 2007, 06:35:11 pm »
Ok, I've executed the five passes;
I've rebuilt project CodeBlocks-unix.cbp;
I've rebuilt workspace ContribPlugins-unix.workspace;

now What shall I do?
I've tried to run again "make install", but nothing changed.

Is there anything specific, shall I do?

Thank you again.
pv

Offline dmoore

  • Developer
  • Lives here!
  • *****
  • Posts: 1576
Re: problem installing wxSmith ...
« Reply #10 on: July 06, 2007, 06:55:37 pm »
I forgot step 6 - run the update script in trunk/src

use the Run button to start your freshly built CB (that will make sure you are running the version in trunk/src/devel and not some other)

PS: you probably shouldn't use the makefiles at all if you are are using the project/workspace files (although you will have to be content with a local install)
« Last Edit: July 06, 2007, 07:02:56 pm by dmoore »

Offline pivit80

  • Multiple posting newcomer
  • *
  • Posts: 27
Re: problem installing wxSmith ...
« Reply #11 on: July 06, 2007, 07:39:39 pm »
Ok,
but then I can use it only locally?
Can I install it in my usr/local/ folder?
That is can I run "make install"?

I don't want codeblocks installed in the trunk/src directory.

Thank you.
pv

Offline dmoore

  • Developer
  • Lives here!
  • *****
  • Posts: 1576
Re: problem installing wxSmith ...
« Reply #12 on: July 06, 2007, 08:01:37 pm »
well, the makefiles should also work (and you will have to get them working if you want a non-local install), but they are completely separate from project files (and if I recall correctly, they build in a completely separate place, dividing up binaries and data for installation in the usual linux dirs). Anyway, your success with the project/workspace files suggests either a missing dependency or incorrect setting in one of the makefiles. You could try looking at the wxsmith makefiles first and compare them with the wxSmith project files (the project files are just xml and easy enough to read -- otherwise load up the project in codeblocks and inspect the properties, build targets). one of the devs might also look into this...

NB: for the local copy you could put the contents of trunk/src/output wherever you want (you just need to set environment vars correctly). obviously this is very un-linux like... ;)

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: problem installing wxSmith ...
« Reply #13 on: July 06, 2007, 08:43:22 pm »
but then I can use it only locally?

Yes, you can. Once the build is finished (using CodeBlocks-unix.cbp), run the update script. Once the update finishes its job, go to devel or output directory. You'll find a run.sh file. Run that and C::B will start locally.

Can I install it in my usr/local/ folder?
That is can I run "make install"?

No. You can't use make install with that.
Be a part of the solution, not a part of the problem.

Offline pivit80

  • Multiple posting newcomer
  • *
  • Posts: 27
Re: problem installing wxSmith ...
« Reply #14 on: July 07, 2007, 11:25:12 am »
HI,
I've copied locally codeblocks installation files, in my usr/local/share;
It isn't the same, but works for now ...

Quote from: dmoore
You could try looking at the wxsmith makefiles first and compare them with the wxSmith project files (the project files are just xml and easy enough to read -- otherwise load up the project in codeblocks and inspect the properties, build targets)

I think I'll wait for the next svn revision.

Just a thing I've not understood:
but is this a my own problem, or is it an overall makefiles problem?

In the last case it has to be fixed.

Thank you for all.
pv