Author Topic: The 21 May 2007 build is out.  (Read 29615 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5192
The 21 May 2007 build is out.
« on: May 21, 2007, 05:41:31 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

A link to the unicode windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw28u_gcc_cb_wx284.7z


For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://prdownload.berlios.de/codeblocks/mingwm10.7z

The 21 May 2007 build is out.
  - Windows :
   http://prdownload.berlios.de/codeblocks/CB_20070521_rev3977_win32.7z
  - Linux :
   http://prdownload.berlios.de/codeblocks/CB_20070521_rev3977_Ubuntu6.10+7.04.deb
   http://prdownload.berlios.de/codeblocks/CB_20070521_rev3977_suse100-102.i586.rpm (not yet)
   http://prdownload.berlios.de/codeblocks/CB_20070521_rev3977_fc4+5.i586.rpm (not yet)


Resolved Fixed:

  • Fixed: [Bug #11134] last chosen file type not remembered on 'new file'
  • Fixed: [Bug #11121] bugs with openwatcom 1.6 linker
  • Improved: Generation of OpenWatcom Linker (wlink.exe) parameters

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem/Win XP problem)

« Last Edit: May 21, 2007, 10:06:46 pm by killerbot »

Offline Xaviou

  • Regular
  • ***
  • Posts: 301
    • X@v's wxStuff
Re: The 21 May 2007 build is out.
« Reply #1 on: May 21, 2007, 08:22:16 pm »
Ubuntu 6.10 & 7.04 Amd64 .deb installer can be found here.

[Edit] : For this rev, I've made both wx263 and wx284 .deb package. Not sure I'll do it every times, but I'll try  :D
« Last Edit: May 21, 2007, 08:56:32 pm by Xaviou »
The french wxWidgets site : http://www.wxdev.fr
My wxWidgets's stuff : https://wxstuff.xaviou.fr/

Offline cstudent

  • Almost regular
  • **
  • Posts: 159
    • Cstudent's Help Desk
Re: The 21 May 2007 build is out.
« Reply #2 on: May 21, 2007, 08:23:14 pm »
Ubuntu .deb package for Edgy (6.10) and/or Feisty (7.04) built using wxWidgets 2.8.4 available here.

You'll need to install the package for wxWidgets 2.8.4 thusly:

Open /etc/apt/sources.list in your favorite text editor.

Add the repository for your distro to your /etc/apt/sources.list
Code: [Select]
deb http://apt.tt-solutions.com/ubuntu/ edgy mainor
Code: [Select]
deb http://apt.tt-solutions.com/ubuntu/ feisty main
Save the file and close your editor.

Add the key:
Code: [Select]
wget http://www.tt-solutions.com/vz/key.asc
Code: [Select]
sudo apt-key add key.asc
Update your sources file and then upgrade:
Code: [Select]
sudo apt-get update
Code: [Select]
sudo apt-get dist-upgrade
Set wxWidgets to 2.8.4
Code: [Select]
sudo update-alternatives --config wx-configSelect the number for the gtk 2.8.4 version and hit Enter.


You should now be set to go.

cstudent



Offline wxLearner

  • Multiple posting newcomer
  • *
  • Posts: 71
Re: The 21 May 2007 build is out.
« Reply #3 on: May 21, 2007, 08:50:09 pm »
Hello, I've uploaded a portable version here.
Thank you MVP for the space! :D
It contains the same libraries as this one, but it has the new boost-1.34.0 and the new wxWidgets-2.8.4.
I'm also uploading the slightly patched source (including compiled binaries), so you can use a SVN client like RapidSVN and add the source folder as an existing repository to make updating and improving your portable version possible. When the upload of the prebuilt source code will be ready (in about 50 minutes), I will post a link here.

The source code (prebuilt), of this Code::Blocks version can be found here.

Thank you, dear Code::Blocks team, for the best IDE ever :D
« Last Edit: May 21, 2007, 09:46:56 pm by wxLearner »

Offline pasgui

  • Almost regular
  • **
  • Posts: 165
    • LGP
Re: The 21 May 2007 build is out.
« Reply #4 on: May 21, 2007, 08:54:49 pm »
Since a while, after a build on Ubuntu feisty wx2.8.4, I got the following error when running C::B:
ERROR: /usr/local/share/codeblocks/plugins/libwxsmithcontribitems.so: not loaded (missing symbols?)
Did you have any idea where this error come from ?

thanks,

pasgui

Offline MVP

  • Multiple posting newcomer
  • *
  • Posts: 20
Re: The 21 May 2007 build is out.
« Reply #5 on: May 21, 2007, 09:34:32 pm »
Hello, I've uploaded a portable version here.
Thank you MVP for the space! :D
It contains the same libraries as this one, but it has the new boost-1.34.0 and the new wxWidgets-2.8.4.
I'm also uploading the slightly patched source (including compiled binaries), so you can use a SVN client like RapidSVN and add the source folder as an existing repository to make updating and improving your portable version possible. When the upload of the prebuilt source code will be ready (in about 50 minutes), I will post a link here.

Thank you, dear Code::Blocks team, for the best IDE ever :D

Awesome thanks for the update! :D

XenThraL

  • Guest
Re: The 21 May 2007 build is out.
« Reply #6 on: May 22, 2007, 12:12:53 am »
Hi there
Just wanted to thank the developers, fantastic IDE, thanks!

on 2 bugs:
also getting the
"ERROR: /usr/local/share/codeblocks/plugins/libwxsmithcontribitems.so: not loaded (missing symbols?)"
running Ubuntu Feisty 7.04
downloaded cstudent's .deb...

and also, on the Management tab
it doesn't seem to remember anymore the position of the tabs, it used to - never use the resources tab so I always kept the symbols one next to the projects, now it resets


Again, thanks for the great IDE, and thanks cstudent for the helpful page/compiles :)

Offline Xaviou

  • Regular
  • ***
  • Posts: 301
    • X@v's wxStuff
Re: The 21 May 2007 build is out.
« Reply #7 on: May 22, 2007, 12:21:59 am »
Hi all!

"ERROR: /usr/local/share/codeblocks/plugins/libwxsmithcontribitems.so: not loaded (missing symbols?)"

I have the same error on Ubuntu 6.10 amd64 with my ".deb", but only with the one linked to wx284. I don't have this error when linked to wx263
The french wxWidgets site : http://www.wxdev.fr
My wxWidgets's stuff : https://wxstuff.xaviou.fr/

Offline codeur

  • Multiple posting newcomer
  • *
  • Posts: 113
    • Code::Blocks EDU-Portable
Re: The 21 May 2007 build is out.
« Reply #8 on: May 22, 2007, 01:07:05 am »
Hello, I've uploaded a portable version [here.

This contribution is very much appreciated, wxLearner, and thanks also for making the code of the portable version available...
   Brilliant!

Offline stahta01

  • Lives here!
  • ****
  • Posts: 6666
    • My Best Post
Re: The 21 May 2007 build is out.
« Reply #9 on: May 22, 2007, 01:33:11 am »
Hi all!

"ERROR: /usr/local/share/codeblocks/plugins/libwxsmithcontribitems.so: not loaded (missing symbols?)"

I have the same error on Ubuntu 6.10 amd64 with my ".deb", but only with the one linked to wx284. I don't have this error when linked to wx263


Are you positive it compiles with wx263, I sometimes get compile error on that project using wxWidgets 2.6.

Tim S
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline cstudent

  • Almost regular
  • **
  • Posts: 159
    • Cstudent's Help Desk
Re: The 21 May 2007 build is out.
« Reply #10 on: May 22, 2007, 02:06:50 am »
Hi all!

"ERROR: /usr/local/share/codeblocks/plugins/libwxsmithcontribitems.so: not loaded (missing symbols?)"

I have the same error on Ubuntu 6.10 amd64 with my ".deb", but only with the one linked to wx284. I don't have this error when linked to wx263


Are you positive it compiles with wx263, I sometimes get compile error on that project using wxWidgets 2.6.

Tim S

I can confirm what Xaviou has said. I get same results in Ubuntu 32bit. No error with wx2.6.3 but the error shows up under wx2.8.4.

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: The 21 May 2007 build is out.
« Reply #11 on: May 22, 2007, 09:22:21 am »
"ERROR: /usr/local/share/codeblocks/plugins/libwxsmithcontribitems.so: not loaded (missing symbols?)"
running Ubuntu Feisty 7.04

Confirmed. I'll look into it today. Strange it looks like wx 2.8.4 causes this to happen. But after I've checked what's the missing symbol, it's some internal data of wxChartCtrl  :?

Thanks for reporting

BYO

Offline PsYhLo

  • Almost regular
  • **
  • Posts: 157
Re: The 21 May 2007 build is out.
« Reply #12 on: May 22, 2007, 11:40:34 am »
@Byo
i have this probleme
Code: [Select]
Scanning for plugins in /usr/share/codeblocks/plugins...
ERROR: Plugin resource not found: libwxsmithlib.zip
svn 3981 Ubuntu Feisty 7.04 wxwidgets2.6.3

Offline rickg22

  • Lives here!
  • ****
  • Posts: 2283
Re: The 21 May 2007 build is out.
« Reply #13 on: May 22, 2007, 05:09:26 pm »
PsYhlo:

I had the same problem with the build. Already filed it as Bug #11144.

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: The 21 May 2007 build is out.
« Reply #14 on: May 22, 2007, 06:05:32 pm »
@Byo
i have this probleme
Code: [Select]
Scanning for plugins in /usr/share/codeblocks/plugins...
ERROR: Plugin resource not found: libwxsmithlib.zip
svn 3981 Ubuntu Feisty 7.04 wxwidgets2.6.3

[sudo] rm /usr/share/codeblocks/plugins/libwxsmithlib.*

PsYhlo:

I had the same problem with the build. Already filed it as Bug #11144.


Currently it's not a bug, it is what's left after some other bug and there's no option to fix this automatically (even make uninstall won't remove bogus plugins/libwxsmithlib.la because it's not in makefiles after removing that previous bug ;)).

It won't happen when you compile on fresh OS without C::B installed before.

Regards
   BYO