Author Topic: [wxSmith] 2 minor issues with wxTimer  (Read 3224 times)

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9595
[wxSmith] 2 minor issues with wxTimer
« on: April 24, 2007, 11:21:50 pm »
Dear Byo,
playing around with wxSmith lead me to discover 2 very minor glitches:
- the property is called "Inerval" instead of "Interval"
- it's not possible to change the Identifier to something else than ID_TIMER1
The second one might be on purpose (why?)...?!
Everything else I played around with was solid (as usual ;-)).
With best regards, Morten.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline raph

  • Almost regular
  • **
  • Posts: 242
Re: [wxSmith] 2 minor issues with wxTimer
« Reply #1 on: April 24, 2007, 11:52:44 pm »
- it's not possible to change the Identifier to something else than ID_TIMER1
The second one might be on purpose (why?)...?!
If you give two timers the same identifier, one timer will fall back to ID_TIMER1 (at least that's what I experienced).
Beside that it works as expected, here.

Regards raph

Offline byo

  • Plugin developer
  • Lives here!
  • ****
  • Posts: 837
Re: [wxSmith] 2 minor issues with wxTimer
« Reply #2 on: April 24, 2007, 11:58:09 pm »
Dear Byo,
playing around with wxSmith lead me to discover 2 very minor glitches:
- the property is called "Inerval" instead of "Interval"
- it's not possible to change the Identifier to something else than ID_TIMER1
The second one might be on purpose (why?)...?!
Everything else I played around with was solid (as usual ;-)).
With best regards, Morten.

First one fixed :)

Second one may be some bigger issue. There's some bug in wxSmith which forces identifiers to be restored to default value (bug already posted on berlios). I haven't found but I also haven't looked for it.

If you give two timers the same identifier, one timer will fall back to ID_TIMER1 (at least that's what I experienced).
Beside that it works as expected, here.

Yup, wxSmith usually don't allow two items in one resource to share same id. Currently if you want have two items with same id, you may use raw number instead of identifier value. But haven't tested that yet.

Regards
  BYO