Author Topic: The 15 March 2007 build is out.  (Read 15723 times)

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5258
The 15 March 2007 build is out.
« on: March 15, 2007, 10:57:35 pm »
Get quick announcements through the RSS feed http://www.codeblocks.org/nightly/CodeBlock_RSS.xml

A link to the unicode windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw26u_gcc_cb_wx2.6.3p2.7z

To fix the menu alignment bug introduced in wx 2.6.3 [windows only bug] we have patched wx ourselves, and that results in the following alternative dll : http://prdownload.berlios.de/codeblocks/wxmsw26u_gcc_cb_wx2.6.3p2AndCbPatch_version3.7z

For those who might need this one (when no MingW installed on your system) : the mingw10m.dll : http://prdownload.berlios.de/codeblocks/mingwm10.7z

For support of ansi builds, a link to the ansi windows wxWidget dll for Code::Blocks : http://prdownload.berlios.de/codeblocks/wxmsw26_gcc_cb_wx2.6.3p2.7z

The 15 March 2007 build is out.
  - Windows : http://prdownload.berlios.de/codeblocks/CB_20070315_rev3711_win32.7z
  - Linux :
         http://prdownload.berlios.de/codeblocks/CB_20070315_rev3711_Ubuntu6.xx.deb (not yet)
         http://prdownload.berlios.de/codeblocks/CB_20070315_rev3711_suse100-102.i586.rpm (not yet)
         http://prdownload.berlios.de/codeblocks/CB_20070315_rev3711_fc4+5.i586.rpm (not yet)


Resolved Fixed:

  • fulfilled FR #3165 by applying patch #1900 (thanks dermeister)

Regressions/Confirmed/Annoying/Common bugs:

  • toolbar-images-not-changing-state (is a wx problem/Win XP problem)
  • menu items with icon not correctly aligned (since wx263) (is fixed with our special wx263/wx28 dll)


Offline nenin

  • Multiple posting newcomer
  • *
  • Posts: 120
Re: The 15 March 2007 build is out.
« Reply #1 on: March 15, 2007, 11:14:44 pm »
Debuger still does not working on Win2k.   :cry:  It can be hacked by replacement of current debugger.dll with one from svn3677.

Offline orefa

  • Multiple posting newcomer
  • *
  • Posts: 102
Re: The 15 March 2007 build is out.
« Reply #2 on: March 15, 2007, 11:36:05 pm »
It can be hacked by replacement of current debugger.dll with one from svn3677.

Good tip, thanks!

Offline Xaviou

  • Regular
  • ***
  • Posts: 325
    • X@v's wxStuff
Re: The 15 March 2007 build is out.
« Reply #3 on: March 15, 2007, 11:47:57 pm »
Ubuntu 6.10 Amd64 .deb installer can be found here.
The french wxWidgets site : http://www.wxdev.fr
My wxWidgets's stuff : https://wxstuff.xaviou.fr/

IC0ffeeCup

  • Guest
Re: The 15 March 2007 build is out.
« Reply #4 on: March 16, 2007, 01:53:06 am »
Hello great work, I wonder if the panels could hide? Like these in vs. I have a old laptop and code on it. The res is 800x600 so I cannot see more code and the space is wasted by the managers and the build messages. I would be thankfull if the dev team of c::b could improve that. Thanks a lot, and Regards.

basurapr

  • Guest
Re: The 15 March 2007 build is out.
« Reply #5 on: March 16, 2007, 02:05:42 am »
Hello great work, I wonder if the panels could hide? Like these in vs. I have a old laptop and code on it. The res is 800x600 so I cannot see more code and the space is wasted by the managers and the build messages. I would be thankfull if the dev team of c::b could improve that. Thanks a lot, and Regards.

with shift-F2 you can hide the "Managment" panel, and just close the "Open files" panel and there is a setting in menu Settings->Environment->View check Auto-hide message pane

IC0ffeeCup

  • Guest
Re: The 15 March 2007 build is out.
« Reply #6 on: March 16, 2007, 02:32:29 am »
Thanks, I didn`t see that.

Offline chikigai

  • Multiple posting newcomer
  • *
  • Posts: 33
Re: The 15 March 2007 build is out.
« Reply #7 on: March 16, 2007, 08:19:38 am »
Hello,

I can no longer run executables using this nightly build on Windows XP using MinGW.

1. Build a Console project.
2. Hit Ctrl+F10 or chose Run from the menu.

This results in:

Execution of 'xterm -T '<Poject Name>' -e 'LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH "<Executable>" ' in '<Executable Directory>' failed.

The portions surrounded by <> have been replaced with the actual text in the build log.
I'm guessing here, but "xterm" is Unix/Linux command isn't it?


Also, the Output Parsing for "compiler errors" disappeared for the GNU GCC Compiler advanced compiler options.
I had to add the regular expression back in manually.

Not sure if anyone else here is experiencing the same problems....
[Development Environment]
OS: WinXP SP3
IDE: Code::Blocks Nightly Build SVN Rev.6080 wxWidgets: 2.8.10 Windows Unicode Build SVN: 1.6.x

Offline Jewe

  • Multiple posting newcomer
  • *
  • Posts: 70
    • Fit Trainer
Re: The 15 March 2007 build is out.
« Reply #8 on: March 16, 2007, 09:06:06 am »
Debuger still does not working on Win2k.   :cry:  It can be hacked by replacement of current debugger.dll with one from svn3677.

maybe this can be put in the top msg?
So everybody knows this, would be nice for people who start with C::B.
Anything curved in the hardware can be straighten with software :D
OS: Vista64 + Debian(to play with)
Compiler: mingw IDE: Code::Blocks Nightly WX: 2.8.0

Offline gd_on

  • Lives here!
  • ****
  • Posts: 581
Re: The 15 March 2007 build is out.
« Reply #9 on: March 16, 2007, 09:58:12 am »
Quote
Debuger still does not working on Win2k.    :( It can be hacked by replacement of current debugger.dll with one from svn3677.
It could be nice, but it does not work for me (don't know why). Debbugger toolbar is not displayed (though checked). Debugger menu is there, but if I start a debugging session, program goes to its end successfully, but I'm not able to have a line by line execution, I'm not able to set breakpoint,...
With a full 3677 version, it's OK!

gd_on
Windows 10 64 bits (20.04), svn C::B (last version or almost!), wxWidgets 3.1.4, Msys2 Compilers 10.2.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\msys64\mingw64) or 32 bits (sjlj, posix in C:\msys64\mingw32).

Offline indigo0086

  • Almost regular
  • **
  • Posts: 150
Re: The 15 March 2007 build is out.
« Reply #10 on: March 16, 2007, 10:53:48 am »
what was Feature Request #3165 and patch #1900 exactly?

Offline manmach

  • Multiple posting newcomer
  • *
  • Posts: 39
Re: The 15 March 2007 build is out.
« Reply #11 on: March 16, 2007, 11:37:19 am »
Hello,

I can no longer run executables using this nightly build on Windows XP using MinGW.

1. Build a Console project.
2. Hit Ctrl+F10 or chose Run from the menu.

This results in:

Execution of 'xterm -T '<Poject Name>' -e 'LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH "<Executable>" ' in '<Executable Directory>' failed.


Same here.

Offline julienlecomte

  • Multiple posting newcomer
  • *
  • Posts: 15
Re: The 15 March 2007 build is out.
« Reply #12 on: March 16, 2007, 11:50:59 am »
what was Feature Request #3165 and patch #1900 exactly?

Quoting myself (Feature Request #3165 implemented by patch 1900)
Quote
When we click on a (non-virtual) folder in the project
space, it would be nice if the browse dialog was
directly set to the directory instead of the root of
project.

e.g
filesystem :
/ (root)
/source
/misc/
/misc/project.cbp

project:
/source/foobar.cpp

If I click on /source in managment/project pane, and
then 'add files', I currently am directly set in /misc,
but would prefer to be set in /source.

Offline skirby

  • Almost regular
  • **
  • Posts: 137
Re: The 15 March 2007 build is out.
« Reply #13 on: March 16, 2007, 12:02:11 pm »
Hello,

Same problem here.
I am on Windows 2000 sp4.
I have simply created a Console Application (GNU GCC Compiler and C++) project on my Desktop and press F9 in order to compile and launch it.
I have the following message:
Quote
Checking for existence: C:\Documents and Settings\PC\Bureau\Test\bin\Debug\Test.exe
Executing: xterm -T 'Test' -e 'LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH "C:\Documents and Settings\PC\Bureau\Test\bin\Debug\Test.exe"  (in C:\Documents and Settings\PC\Bureau\Test\.)
Execution of 'xterm -T 'Test' -e 'LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH "C:\Documents and Settings\PC\Bureau\Test\bin\Debug\Test.exe" ' in 'C:\Documents and Settings\PC\Bureau\Test' failed.
Nothing to be done.

I have also tried from another location than windows desktop and I have the same problem.
Quote
Checking for existence: D:\Test\bin\Debug\Test.exe
Executing: xterm -T 'Test' -e 'LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH "D:\Test\bin\Debug\Test.exe"  (in D:\Test\.)
Execution of 'xterm -T 'Test' -e 'LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH "D:\Test\bin\Debug\Test.exe" ' in 'D:\Test' failed.
Nothing to be done.


I am waiting for the next build.
Thanks in advance for the correction and have a nice day.

Offline manmach

  • Multiple posting newcomer
  • *
  • Posts: 39
Re: The 15 March 2007 build is out.
« Reply #14 on: March 16, 2007, 12:51:06 pm »
I don't know exactly when or why this was changed, but I noticed that on many settings dialogs a listbox has been introduced to switch to a different set of settings. For instance, on the compiler and debuger settings dialogbox, there is one to select linker settings, or toolchain executables.

I find this a step backwards from the tabbed design. It now takes two clicks to navigate. One to make the listbox drop down and one to select the proper topic, instead of the one it used to take to select the right tab.

And not to mention, you can no longer tell at a glance if you've selected the right dialog, because you can't see all the topics until you select the listbox.

Offline ascxaxsvcbsxbbqvcxqsbcvxs

  • Multiple posting newcomer
  • *
  • Posts: 53
Re: The 15 March 2007 build is out.
« Reply #15 on: March 16, 2007, 01:32:36 pm »
@manmach: i agree with you.

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4305
    • Code::Blocks IDE
Re: The 15 March 2007 build is out.
« Reply #16 on: March 16, 2007, 01:56:47 pm »
Hello,

Same problem here.
I am on Windows 2000 sp4.
I have simply created a Console Application (GNU GCC Compiler and C++) project on my Desktop and press F9 in order to compile and launch it.
I have the following message:
Quote
Checking for existence: C:\Documents and Settings\PC\Bureau\Test\bin\Debug\Test.exe
Executing: xterm -T 'Test' -e 'LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH "C:\Documents and Settings\PC\Bureau\Test\bin\Debug\Test.exe"  (in C:\Documents and Settings\PC\Bureau\Test\.)
Execution of 'xterm -T 'Test' -e 'LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH "C:\Documents and Settings\PC\Bureau\Test\bin\Debug\Test.exe" ' in 'C:\Documents and Settings\PC\Bureau\Test' failed.
Nothing to be done.

I have also tried from another location than windows desktop and I have the same problem.
Quote
Checking for existence: D:\Test\bin\Debug\Test.exe
Executing: xterm -T 'Test' -e 'LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH "D:\Test\bin\Debug\Test.exe"  (in D:\Test\.)
Execution of 'xterm -T 'Test' -e 'LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH "D:\Test\bin\Debug\Test.exe" ' in 'D:\Test' failed.
Nothing to be done.


I am waiting for the next build.
Thanks in advance for the correction and have a nice day.

Yes, there is a problem in this build and the current platform is not recognized correctly in some places. You can easily tell by looking that it's trying to execute xterm (a unix program) in windows2000...
We are currently looking into this and will soon fix it.
Be patient!
This bug will be fixed soon...

Offline nenin

  • Multiple posting newcomer
  • *
  • Posts: 120
Re: The 15 March 2007 build is out.
« Reply #17 on: March 16, 2007, 02:08:17 pm »
Quote
Debuger still does not working on Win2k.    :( It can be hacked by replacement of current debugger.dll with one from svn3677.
It could be nice, but it does not work for me (don't know why). Debbugger toolbar is not displayed (though checked). Debugger menu is there, but if I start a debugging session, program goes to its end successfully, but I'm not able to have a line by line execution, I'm not able to set breakpoint,...
With a full 3677 version, it's OK!

gd_on

I had installed all newest mingw stuff (including gcc 4.1.2). You should not use gcc 4.1.2 but you can try to update your mingw installation like it proposed here: http://forums.codeblocks.org/index.php/topic,5282.msg41081.html#msg41081

Bug with  Execution of 'xterm... confirmed. Funny, it is not present in debug mode- only in plain "run"
« Last Edit: March 16, 2007, 02:12:10 pm by nenin »

Offline dr snuggles

  • Multiple posting newcomer
  • *
  • Posts: 27
Re: The 15 March 2007 build is out.
« Reply #18 on: March 16, 2007, 02:36:13 pm »
I don't know exactly when or why this was changed, but I noticed that on many settings dialogs a listbox has been introduced to switch to a different set of settings. For instance, on the compiler and debuger settings dialogbox, there is one to select linker settings, or toolchain executables.
There are lots of usability items to fix, but I think most of us prefer that the most important bugs get hunted :).

Offline klight

  • Multiple posting newcomer
  • *
  • Posts: 24
Re: The 15 March 2007 build is out.
« Reply #19 on: March 16, 2007, 02:53:18 pm »
RE: settings dialogs listbox

I find this a step backwards from the tabbed design. It now takes two clicks to navigate. One to make the listbox drop down and one to select the proper topic, instead of the one it used to take to select the right tab.

+1 for reverting this feature to tabs.  The tabs seem much easier to use.

Offline skirby

  • Almost regular
  • **
  • Posts: 137
Re: The 15 March 2007 build is out.
« Reply #20 on: March 16, 2007, 04:11:23 pm »
I find Tabs were easier to use too but if developers have done this they probably have their reason.

We will get used to this new interface.

Offline manmach

  • Multiple posting newcomer
  • *
  • Posts: 39
Re: The 15 March 2007 build is out.
« Reply #21 on: March 19, 2007, 09:35:55 am »
I find Tabs were easier to use too but if developers have done this they probably have their reason.

We will get used to this new interface.

One can get used to almost anything. That does not mean one should.

If the developers have made something harder on purpose, they must have a good explanation for it and no doubt they would be willing to share this.

Of course fixing more serious bugs should have their priority, but they appeared to find it a priority too to change this part of the interface, even if it did not appear to be broken. In fact, one might argue it is now.

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 15 March 2007 build is out.
« Reply #22 on: March 19, 2007, 10:02:06 am »
Of course fixing more serious bugs should have their priority, but they appeared to find it a priority too to change this part of the interface, even if it did not appear to be broken. In fact, one might argue it is now.

This is quite wrong. Please have a look at the last couple of weeks nightly. You'll find we're regularly fixing bugs.

The problem is a bug may be fixed by writing one line of code, but to find out where that one line fits is a tedious job. That's one of the reasons, you don't see huge number of fixes everyday.

Just to give you one small info, next nightly will come with at least 3 bug-fixes, so far and you may expect more. I think now you should stop complaining that we're not fixing bugs.

Regards,

Biplab
Be a part of the solution, not a part of the problem.

Offline manmach

  • Multiple posting newcomer
  • *
  • Posts: 39
Re: The 15 March 2007 build is out.
« Reply #23 on: March 19, 2007, 11:06:51 am »
Of course fixing more serious bugs should have their priority, but they appeared to find it a priority too to change this part of the interface, even if it did not appear to be broken. In fact, one might argue it is now.

This is quite wrong. Please have a look at the last couple of weeks nightly. You'll find we're regularly fixing bugs.

The problem is a bug may be fixed by writing one line of code, but to find out where that one line fits is a tedious job. That's one of the reasons, you don't see huge number of fixes everyday.

Just to give you one small info, next nightly will come with at least 3 bug-fixes, so far and you may expect more. I think now you should stop complaining that we're not fixing bugs.

Regards,

Biplab

What is quite wrong? Who said bugs are not being fixed?

Offline Biplab

  • Developer
  • Lives here!
  • *****
  • Posts: 1874
    • Biplab's Blog
Re: The 15 March 2007 build is out.
« Reply #24 on: March 19, 2007, 11:15:12 am »
What is quite wrong?

See your comment in following line.
Of course fixing more serious bugs should have their priority, ...

I wanted to point out that fixing bugs is still a top priority for us.
Be a part of the solution, not a part of the problem.

Offline manmach

  • Multiple posting newcomer
  • *
  • Posts: 39
Re: The 15 March 2007 build is out.
« Reply #25 on: March 19, 2007, 12:21:54 pm »
What is quite wrong?

See your comment in following line.
Of course fixing more serious bugs should have their priority, ...

I wanted to point out that fixing bugs is still a top priority for us.

And nobody is disagreeing or complaining. If you read that line again, and put it in the context of the preceding lines, you will see it does not say nobody is fixing bugs. It is a confirmation of the fact that fixing some bugs is more important than fixing others.

Don't accuse people of saying things they never said. That is rude. I am inclined to believe your mistake is an honest one if English is not your primary language (neither is mine by the way), and if that is the case, you should be even more careful of accusing people.

So just to make sure we understand each other:
1. I like Codeblocks.
2. I appreciate the work the developers are doing.
3. I especially like the way they are fixing bugs, adding improvements and making them available on an almost daily basis.
4. I think the change I mentioned was not an improvement, as apparently so do others.
5. The part that changed did not appear to be broken, but since someone gave it priority, that would suggest there might have been a reason to change it. I am curious why.
6. No one said bugs are not being fixed.
« Last Edit: March 19, 2007, 04:13:25 pm by manmach »