Author Topic: Problems debugging with CDB  (Read 3284 times)

Offline Matroc

  • Multiple posting newcomer
  • *
  • Posts: 12
Problems debugging with CDB
« on: July 05, 2006, 11:43:45 pm »

Im using C::B with VC toolkit 2k3 for a while now and always wanted to get debugging to work. So today i took the time, created some required libs from the dlls etc. but now i'm pretty stuck. I dont know much about using commandline debuggers and have no idea what to do.
As debugger i use the Debugging Tools for Windows (cdb.exe)
I wrote a pretty simple quicksort prog a while ago and thought i could use it to test debugging (other progs behave the same way if i try to debug them so it doesn't really matter).
Every time i start debugging it only gives me the following output:
Code: [Select]
Building to ensure sources are up-to-date
Build succeeded
Selecting target: default
Adding source dir: D:\reinstall\Eigene Dateien\cpp\Quicksort\
Adding source dir: D:\reinstall\Eigene Dateien\cpp\Quicksort\
Adding file: Quicksort.exe
Starting debugger: done
Setting breakpoints
 1  2  3  5  7  10  18  21
Microsoft (R) Windows Debugger  Version 6.4.0007.2
Copyright (c) Microsoft Corporation. All rights reserved.
CommandLine: Quicksort.exe
Symbol search path is: D:/REINST~1/EIGENE~1/cpp/QUICKS~1/
Executable search path is:
ModLoad: 00400000 00410000   Quicksort.exe
ModLoad: 7c910000 7c9c7000   ntdll.dll
ModLoad: 7c800000 7c906000   C:\WINDOWS\system32\kernel32.dll
(ff0.aa4): Break instruction exception - code 80000003 (first chance)
eax=00241eb4 ebx=7ffdf000 ecx=00000001 edx=00000002 esi=00241f48 edi=00241eb4
eip=7c911230 esp=0012fb20 ebp=0012fc94 iopl=0         nv up ei pl nz na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000202
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for ntdll.dll -
7c911230 cc               int     3
Debugger finished with status 1
No breaking on breakpoints or similar.
In the build options i enabled "Produce debugging symbols".
Btw. i use C::B rev 2687 nightly.
Did i miss something important? Any ideas?

ok seems like i just cant set breakpoints at some lines, others work. I can live with that though...
It basically works now for my small app. So ive tried to debug a bigger wxWidgets app, but i get no application window and the app seems just to be stuck at some point. If i try to step through it the little arrow marking the current line suddenly disappears on a function call and it doesn't seem to step into it. I'm pretty tired and will probably investigate further tomorrow...
« Last Edit: July 06, 2006, 12:05:57 am by Matroc »