Author Topic: wxWidgets integration  (Read 3159 times)

Daes

  • Guest
wxWidgets integration
« on: April 24, 2006, 03:09:29 pm »
Hi community :)
I would like to compile wxWidgets programs on codeBlocks

I have suceeded in installing codeblocks from source on a debian sarge following the wiki tutorial (Compiling Code::Blocks in Linux (applies to all distros)) except i use wx 2.6.3
So codeBlocks is working compiled with wxWidgets 2.6.3 monolithic unicode.

It seems that,  following the tutorial:
1) Install wxWidgets libs in /opt/wx/2.6/lib
2) Install wxWidgets includes in file:/opt/wx/2.6/include/wx-2.6/wx
3) Put the setup.h in file:/opt/wx/2.6/lib/wx/include/gtk2-unicode-release-2.6/wx

First i tried to use the wxWidgets Application wizard but when it ask for wxWidgets directory, whatever i put there, it seems not a correct wxWidget path.
I tried to compile myself by putting the above noted path in options, but however, i get a wxWidgets problems like:
No configuration defined , please use wx-config.

My wxWidgets seems well installed as codeBlocks compile sucessfully, but from codeBlocks, i don't understand what i have to do.
Could someone enlight my linux noobie mind ;) ?

Offline yop

  • Regular
  • ***
  • Posts: 387
Re: wxWidgets integration
« Reply #1 on: April 24, 2006, 05:33:19 pm »
I just answered the same thing 3 hours ago: http://forums.codeblocks.org/index.php?topic=2950.msg23258#msg23258
Tip: The search button has a reason for being there ;)
Life would be so much easier if we could just look at the source code.

Daes

  • Guest
Re: wxWidgets integration
« Reply #2 on: April 24, 2006, 06:17:59 pm »
ooops really sorry , i have done a search with wxWidget wizard but have not detect your post.
Tanks any way for answer ;)