Author Topic: wx-config not found  (Read 6929 times)

tavares

  • Guest
wx-config not found
« on: March 20, 2006, 01:33:47 am »
Hi:

I am just starting using code::Blocks - A linux (ubuntu) instalation.

I create a wxWidgets App, with the main.cpp and main.h template. 

After pressing "build" I got the following error:

g++: `wx-config: File or dir not found
cc1plus: error: unrecognized command line option "-fcflags`"

 wx-config is in /usr/local/bin , and this path is also in Directories/compiler settings.

   Can someone help me to solve this error?

       Tks
             Roberto Tavares

Offline balgior

  • Multiple posting newcomer
  • *
  • Posts: 24
Re: wx-config not found
« Reply #1 on: March 20, 2006, 01:50:37 am »
Hello,

I'm not a linux user but i think I had this problem :

Quote
cc1plus: error: unrecognized command line option "-fcflags`"

and many others, using an old version of gcc. (v 3.2.3 i think it was) and disappeared when upgraded to v3.4.5.

I don't know about:

Quote
g++: `wx-config: File or dir not found

However, in order to get some help by someone who knows what's going on maybe you should tell which version of gcc you're using. This was as much helpful as i could be...  :(

Good luck!

tavares

  • Guest
Re: wx-config not found
« Reply #2 on: March 20, 2006, 02:59:30 am »
I am using:
            gcc (GCC) 4.0.2 -
            Ubuntu  5.10.
            Code::Blocks 1.0rc2

   RTavares

Offline mandrav

  • Project Leader
  • Administrator
  • Lives here!
  • *****
  • Posts: 4305
    • Code::Blocks IDE
Re: wx-config not found
« Reply #3 on: March 20, 2006, 08:32:45 am »
I am using:
            gcc (GCC) 4.0.2 -
            Ubuntu  5.10.
            Code::Blocks 1.0rc2

   RTavares

Please switch to a nightly build (development snapshot). If you search the forums, you 'll find a .deb for ubuntu 5.10.
Be patient!
This bug will be fixed soon...

Offline takeshi miya

  • Lives here!
  • ****
  • Posts: 1487
Re: wx-config not found
« Reply #4 on: March 20, 2006, 08:35:33 am »
As a note to anyone using RC2, this can be solved as:

Quote
Go to Settings->Compiler->Other and set the build mode to "GNU make". Backticks work with it.