Author Topic: Build error, help  (Read 7786 times)

Offline 01Becker

  • Single posting newcomer
  • *
  • Posts: 8
Build error, help
« on: February 28, 2006, 01:20:19 pm »
.......
.......
Compiling: sdk\wxscintilla\src\wxscintilla.cpp
Linking dynamic library: devel\wxscintilla.dll
Creating library file: devel\libwxscintilla.a
.objs\2.6\sdk\wxscintilla\src\PlatWX.o: In function `Z10wxLogDebugPKcz':
D:/cb/src/sdk/wxscintilla/src/PlatWX.cpp:(.text$_ZN12wxStringBaseC2EPKc[wxStringBase::wxStringBase(char const*)]+0x27): undefined reference to `_imp___ZN12wxStringBase8InitWithEPKcjj'
D:/cb/src/sdk/wxscintilla/src/PlatWX.cpp:(.text$_ZN12wxStringBaseC2EPKcj[wxStringBase::wxStringBase(char const*, unsigned int)]+0x23): undefined reference to `_imp___ZN12wxStringBase8InitWithEPKcjj'
.objs\2.6\sdk\wxscintilla\src\ScintillaWX.o: In function `ZNK12wxSCICallTip12AcceptsFocusEv':
C:/wxWidgets/include/wx/window.h:(.text$_Z16wxGetTranslationPKc[wxGetTranslation(char const*)]+0x2c): undefined reference to `_imp___ZNK8wxLocale9GetStringEPKcS1_'
.objs\2.6\sdk\wxscintilla\src\wxscintilla.o: In function `ZN11wxScintilla12StyleSetSpecEiRK8wxString':
D:/cb/src/sdk/wxscintilla/src/wxscintilla.cpp:2551: undefined reference to `_imp___ZNK8wxString11BeforeFirstEc'
D:/cb/src/sdk/wxscintilla/src/wxscintilla.cpp:2552: undefined reference to `_imp___ZNK8wxString10AfterFirstEc'
.objs\2.6\sdk\wxscintilla\src\wxscintilla.o: In function `ZN11wxScintilla8SaveFileERK8wxString':
D:/cb/src/sdk/wxscintilla/src/wxscintilla.cpp:2724: undefined reference to `_imp___ZN6wxFileC1EPKcNS_8OpenModeE'
.objs\2.6\sdk\wxscintilla\src\wxscintilla.o: In function `ZN11wxScintilla8LoadFileERK8wxString':
D:/cb/src/sdk/wxscintilla/src/wxscintilla.cpp:2736: undefined reference to `_imp___ZN6wxFileC1EPKcNS_8OpenModeE'
.objs\2.6\sdk\wxscintilla\src\wxscintilla.o: In function `ZNK6wxRect9GetBottomEv':
D:/cb/src/sdk/wxscintilla/src/wxscintilla.cpp:(.text$_ZeqRK8wxStringPKc[operator==(wxString const&, char const*)]+0x14): undefined reference to `_imp___ZNK8wxString3CmpEPKc'
collect2: ld returned 1 exit status
Process terminated with status 1 (1 minutes, 16 seconds)
4 errors, 7 warnings
 

Offline killerbot

  • Administrator
  • Lives here!
  • *****
  • Posts: 5258
Re: Build error, help
« Reply #1 on: February 28, 2006, 01:27:24 pm »
unicode <--> ansi conflict ??

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Build error, help
« Reply #2 on: February 28, 2006, 01:34:29 pm »
Hello,

Could you say which version of C::B are you using to compile which version? And which compiler (GCC) version are you using?

Best wishes,
Michael

Offline 01Becker

  • Single posting newcomer
  • *
  • Posts: 8
Re: Build error, help
« Reply #3 on: February 28, 2006, 01:35:27 pm »
I'm not sure. When I change the version of the "wxmsw26.dll", the errors change.
PS: I directly use the "wxmsw26u_gcc_cb.dll" downloaded from here.

Offline 01Becker

  • Single posting newcomer
  • *
  • Posts: 8
Re: Build error, help
« Reply #4 on: February 28, 2006, 01:37:04 pm »
My C::B version is 1.0rc2
I am using gcc 3.4.5 <mingw special>

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Build error, help
« Reply #5 on: February 28, 2006, 01:39:25 pm »
My C::B version is 1.0rc2
I am using gcc 3.4.5 <mingw special>

The problem is that you cannot compile C::B SVN with RC2. You have to doewnload one of the nightly build. Then you can build C::B, but you have to use  a unicode build of wxWidgets, i.e., wxmsw26u_gcc_cb.dll.

Sorry, but what do you mean by mingw special?

Best wishes,
Michael

Offline 01Becker

  • Single posting newcomer
  • *
  • Posts: 8
Re: Build error, help
« Reply #6 on: February 28, 2006, 01:40:36 pm »
I'm so glad that you reply me very quickly :-)

Thanks for your help!

I'd like to compile C::B myself. I'm wondering about my own version of C::B!

Offline thomas

  • Administrator
  • Lives here!
  • *****
  • Posts: 3979
Re: Build error, help
« Reply #7 on: February 28, 2006, 01:42:51 pm »
You cannot build Code::Blocks using RC2 (not unless you rewrite the compiler and linker paths as well as the link libraries in the project file).

wxmsw26.dll is not good, either. It has to be wxmsw26u_gcc_cb.dll or wxmsw26_gcc_cb.dll, depending on whether you want to build Unicode or ANSI (note that you must also set the #defines accordingly, or it will not work).

Read the build instructions, they explain everything step by step:
http://forums.codeblocks.org/index.php?topic=1701.0
"We should forget about small efficiencies, say about 97% of the time: Premature quotation is the root of public humiliation."

Offline 01Becker

  • Single posting newcomer
  • *
  • Posts: 8
Re: Build error, help
« Reply #8 on: February 28, 2006, 01:43:16 pm »
My OS is winXP. I'm using MinGW. So, u c, the gcc is in the MinGW package.

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Build error, help
« Reply #9 on: February 28, 2006, 01:43:26 pm »
I'm so glad that you reply me very quickly :-)

Thanks for your help!

I'd like to compile C::B myself. I'm wondering about my own version of C::B!

To compile C::B you will also need zip.exe. Moreover to have the contr. plugins, you should compile them, by using a separate workspace. And do not forget to use update.bat :). You can search in this forum for useful information. If you have problems, you can post them.

Best wishes,
Michael

Offline 01Becker

  • Single posting newcomer
  • *
  • Posts: 8
Re: Build error, help
« Reply #10 on: February 28, 2006, 01:44:57 pm »
Thanks! I'm going to read <<Build Instructions>> now.

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Build error, help
« Reply #11 on: February 28, 2006, 01:45:31 pm »
My OS is winXP. I'm using MinGW. So, u c, the gcc is in the MinGW package.

Yes, I know :). I have asked, because I have recently re-installed MinGW (installer version 5.0.2) and I could only have GCC 3.4.4 (as candidate). I have had to download and install GCC 3.4.5 separately.

Best wishes,
Michael

Offline 01Becker

  • Single posting newcomer
  • *
  • Posts: 8
Re: Build error, help
« Reply #12 on: February 28, 2006, 01:49:42 pm »
Yeah, I downloaded and installed GCC 3.4.5 separately. I downloaded it from the MinGW project page on sourceforge.

Offline Michael

  • Lives here!
  • ****
  • Posts: 1608
Re: Build error, help
« Reply #13 on: February 28, 2006, 01:53:28 pm »
Yeah, I downloaded and installed GCC 3.4.5 separately. I downloaded it from the MinGW project page on sourceforge.

Ok, so you did as I did :). Thanks for your reply.

Best wishes,
Michael