Author Topic: Broken link on sourceforge  (Read 1780 times)

Offline gd_on

  • Lives here!
  • ****
  • Posts: 581
Broken link on sourceforge
« on: September 30, 2020, 10:59:14 am »
This link is broken since this week end on SF : https://sourceforge.net/p/codeblocks/code/log/
Windows 10 64 bits (20.04), svn C::B (last version or almost!), wxWidgets 3.1.4, Msys2 Compilers 10.2.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\msys64\mingw64) or 32 bits (sjlj, posix in C:\msys64\mingw32).

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7018
    • My Best Post
Re: Broken link on sourceforge
« Reply #1 on: September 30, 2020, 03:11:01 pm »
This link is broken since this week end on SF : https://sourceforge.net/p/codeblocks/code/log/

Should this link not show some folders and files https://sourceforge.net/p/codeblocks/code/

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline gd_on

  • Lives here!
  • ****
  • Posts: 581
[solved]Re: Broken link on sourceforge
« Reply #2 on: September 30, 2020, 06:52:19 pm »
Well, it works again. Repaired by Sourceforge.
Windows 10 64 bits (20.04), svn C::B (last version or almost!), wxWidgets 3.1.4, Msys2 Compilers 10.2.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\msys64\mingw64) or 32 bits (sjlj, posix in C:\msys64\mingw32).

Offline gd_on

  • Lives here!
  • ****
  • Posts: 581
Re: Broken link on sourceforge
« Reply #3 on: October 18, 2020, 10:28:57 am »
Link is broken again. I filled a "broken link request" on sourceforge.
Could it be a problem with some commits ?
gd_on
Windows 10 64 bits (20.04), svn C::B (last version or almost!), wxWidgets 3.1.4, Msys2 Compilers 10.2.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\msys64\mingw64) or 32 bits (sjlj, posix in C:\msys64\mingw32).

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12911
    • Travis build status
Re: Broken link on sourceforge
« Reply #4 on: October 18, 2020, 11:46:10 am »
Yes, this is bug in sourceforge when there are multiple commits done in quick succession. It happens very often when I do git svn dcommit for more than one commit.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12911
    • Travis build status
Re: Broken link on sourceforge
« Reply #5 on: October 18, 2020, 11:46:48 am »
Do you have the "repository refresh" link? I've clicked it and it seems to have fixed it (at least for me).
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline gd_on

  • Lives here!
  • ****
  • Posts: 581
Re: Broken link on sourceforge
« Reply #6 on: October 18, 2020, 06:47:51 pm »
It works again ...
Quote
Do you have the "repository refresh" link?
I don't see such a link. May be next time if this happen again.
« Last Edit: October 18, 2020, 07:00:48 pm by gd_on »
Windows 10 64 bits (20.04), svn C::B (last version or almost!), wxWidgets 3.1.4, Msys2 Compilers 10.2.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\msys64\mingw64) or 32 bits (sjlj, posix in C:\msys64\mingw32).

Offline gd_on

  • Lives here!
  • ****
  • Posts: 581
Re: Broken link on sourceforge
« Reply #7 on: October 31, 2020, 10:42:04 am »
Link still broken.
I don't have a repository refresh link. Sorry.

gd_on
Windows 10 64 bits (20.04), svn C::B (last version or almost!), wxWidgets 3.1.4, Msys2 Compilers 10.2.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\msys64\mingw64) or 32 bits (sjlj, posix in C:\msys64\mingw32).

Offline LETARTARE

  • Regular
  • ***
  • Posts: 435
  • L'ami de l'homme.The friend of man.
Re: Broken link on sourceforge
« Reply #8 on: October 31, 2020, 10:52:19 am »
No problem with 'TortoiseSvn' to recover r12231.
CB-rev12240, plugins : QtPregen-2.7.3-sdk240
1-Win7 Business Pack1 64bits : wx-3.1.4, gcc-8.1.0,
2-Vista Business Pack2 32bits : wx-3.1.4, gcc-8.1.0
3-OpenSuse-15.1-Leap 64bits : wx-3.03, gcc-7.5.
=> !! The messages are translated by Deepl !!

Offline gd_on

  • Lives here!
  • ****
  • Posts: 581
Re: Broken link on sourceforge
« Reply #9 on: October 31, 2020, 11:16:24 am »
True. That was always like that : no problem to recover the last commit through svn. The problem is just to look the content with the link : https://sourceforge.net/p/codeblocks/code/log/
Windows 10 64 bits (20.04), svn C::B (last version or almost!), wxWidgets 3.1.4, Msys2 Compilers 10.2.0, 64 bits (seh, posix : gcc, g++ and gfortran in C:\msys64\mingw64) or 32 bits (sjlj, posix in C:\msys64\mingw32).

Offline wimc

  • Multiple posting newcomer
  • *
  • Posts: 12
Re: Broken link on sourceforge
« Reply #10 on: October 31, 2020, 11:21:59 am »
I know nothing about SF.

Oh snap! We can't process this request.

Only see links for:
Report a Broken Page
Browse Projects

Perhaps nothing else shows not logged in, I have no account anyway. Well, this post is probably unhelpful.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7018
    • My Best Post
Re: Broken link on sourceforge
« Reply #11 on: October 31, 2020, 04:10:09 pm »
This link shows no commits; https://sourceforge.net/p/codeblocks/code/

This is [likely] a common symptom of SVN issues on sf.net

Edit: This link does work; https://sourceforge.net/p/codeblocks/code/commit_browser
And, a SVN update worked locally.

Tim S.
 
« Last Edit: October 31, 2020, 04:15:00 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12911
    • Travis build status
Re: Broken link on sourceforge
« Reply #12 on: October 31, 2020, 07:50:06 pm »
Pressing the "refresh" button fixed it again. If someone is bothered by this, you have to report it on sf.net. I don't have fate they want to fix it or care.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]