Author Topic: Trouble installing the wxsmith plugin to codeblocks in ubuntu [Solved]  (Read 402 times)

Offline MegAmaNeo

  • Single posting newcomer
  • *
  • Posts: 3
I want to create a GUI program using the codeblocks wxsmith GUI builder. Trying to run wxwidgets I get the error message

wxSmith plugin is not loaded, can not continue

After researching I found out that I have to download the wxsmith plugin by using the command:

sudo apt-get install codeblocks-contrib

However I get the error message shown in the attached picture.
I already searched some threads but was mostly unable to follow the recommendations given because I am quite new to ubuntu/codeblocks.
Can someone maybe help me? If you need further information about my system let me know. I am using the codeblocks version:

Release 17.12 rev 11263 (2018-01-06 10:13:06) gcc 6.3.0 Linux/unicode - 64 bit

Already tried:

sudo apt-get update
sudo apt-get clean
sudo apt-get autoremove
sudo apt-get install -f
sudo aptitude install codeblocks-contrib

Sadly, nothing helped.
« Last Edit: September 19, 2020, 08:35:24 pm by MegAmaNeo »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12910
    • Travis build status
Re: Trouble installing the wxsmith plugin to codeblocks in ubuntu
« Reply #1 on: September 19, 2020, 04:09:24 pm »
You're mixing packages from different providers and with different versions.
My guess is that you've installed codeblocks using a package from our site and now you're trying to use the package system.

It is not clear what is your Ubuntu version, but I guess it is not 20.04, so my advice is to remove everything you've installed related to codeblocks and then use our release PPA: https://launchpad.net/~codeblocks-devs/+archive/ubuntu/release
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline MegAmaNeo

  • Single posting newcomer
  • *
  • Posts: 3
Re: Trouble installing the wxsmith plugin to codeblocks in ubuntu
« Reply #2 on: September 19, 2020, 04:33:45 pm »
Thank you, it solved the problem!

If I create a program with a GUI on my ubuntu system using codeblocks, can a windows user run the .exe on windows automatically or do I need to do something to ensure compatibility on both linux and windows systems?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12910
    • Travis build status
Re: Trouble installing the wxsmith plugin to codeblocks in ubuntu
« Reply #3 on: September 19, 2020, 05:45:27 pm »
You have to do one of:
1. cross compile
2. do separate compile on windows
3. expect the user would use WSL and your app would just work

Option 2 is most reliable if you ask me.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]