Author Topic: This annoying messege appears every time  (Read 593 times)

Offline Alif

  • Single posting newcomer
  • *
  • Posts: 8
This annoying messege appears every time
« on: August 02, 2020, 04:33:04 pm »
a messege occures with errors every time i start codeblocks. even if I uncheck the "show this dialogue next time" radio button.
There is an option to copy the error:
Code: [Select]
ASSERT INFO:
./src/common/colourcmn.cpp(228): assert "isOpaque" failed in GetAsString(): alpha is lost in HTML syntax

BACKTRACE:
[1] wxColourBase::GetAsString(long) const
[2] wxEntry(int&, wchar_t**)
[3] __libc_start_main



Offline Miguel Gimenez

  • Lives here!
  • ****
  • Posts: 522
Re: This annoying messege appears every time
« Reply #1 on: August 02, 2020, 06:16:57 pm »
Did you change any C::B colour?

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12772
    • Travis build status
Re: This annoying messege appears every time
« Reply #2 on: August 03, 2020, 09:10:00 am »
Can you share your default config file?
What OS and C::B version are you using?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Alif

  • Single posting newcomer
  • *
  • Posts: 8
Re: This annoying messege appears every time
« Reply #3 on: August 03, 2020, 11:49:29 am »
https://sangams.com.np/installing-codeblocks-dark-themes/
i've installed these themes and now the problem is gone. i don't know how.
OS: Manjaro Gnome
codeblocks:
Code: [Select]
Name             : Code::Blocks
Version          : 20.03-r11997
SDK Version      : 2.0.0
Scintilla Version: 3.7.5
Author           : The Code::Blocks Team
E-mail           : [email protected]
Website          : http://www.codeblocks.org

wxWidgets Library (wxGTK port)
Version 3.0.5 (Unicode: wchar_t, debug level: 1),
compiled at May 10 2020 07:34:55

Runtime version of toolkit used is 3.24.
Compile-time GTK+ version is 3.24.20.

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12772
    • Travis build status
Re: This annoying messege appears every time
« Reply #4 on: August 03, 2020, 09:00:15 pm »
Can you restore your original theme?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline Alif

  • Single posting newcomer
  • *
  • Posts: 8
Re: This annoying messege appears every time
« Reply #5 on: August 04, 2020, 05:17:41 pm »
Can you restore your original theme?
Hello, the problem is here again.
looks like this. This problem occurs after installing this theme on manjaro gnome: https://www.gnome-look.org/p/1241688/
Theme name: MacOS Catalina Gnome Dark
Code: [Select]
ASSERT INFO:
./src/common/colourcmn.cpp(228): assert "isOpaque" failed in GetAsString(): alpha is lost in HTML syntax

BACKTRACE:
[1] wxColourBase::GetAsString(long) const
[2] wxEntry(int&, wchar_t**)
[3] __libc_start_main


« Last Edit: August 04, 2020, 05:59:57 pm by Alif »

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12772
    • Travis build status
Re: This annoying messege appears every time
« Reply #6 on: August 05, 2020, 08:11:29 am »
Can you log this on the issues tracker?
Does this problem depend only on the gtk theme and not the syntax highlight theme?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]