Author Topic: Compiler Toolchain Setting seems to be ignored in Version 20.03  (Read 1910 times)

Offline patraxbi

  • Multiple posting newcomer
  • *
  • Posts: 11
Re: Compiler Toolchain Setting seems to be ignored in Version 20.03
« Reply #15 on: April 30, 2020, 08:33:57 pm »
That "full comand" was already on. I pressed rebuild and that build log  is the same: ( I compiled the hello world program. Could it be from my computer?)
g++.exe  -o bin\Debug\test1.exe obj\Debug\main.o   
g++.exe: error: obj\Debug\main.o: No such file or directory
g++.exe: fatal error: no input files
compilation terminated.
Process terminated with status 1 (0 minute(s), 0 second(s))
2 error(s), 0 warning(s) (0 minute(s), 0 second(s))
 
The problem is that the compiler doesn't create the main.o file and I can't see why
« Last Edit: April 30, 2020, 08:41:42 pm by patraxbi »

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7017
    • My Best Post
Re: Compiler Toolchain Setting seems to be ignored in Version 20.03
« Reply #16 on: April 30, 2020, 08:44:59 pm »
That "full comand" was already on. I pressed rebuild and that build log  is the same: ( I compiled the hello world program. Could it be from my computer?)
g++.exe  -o bin\Debug\test1.exe obj\Debug\main.o   
g++.exe: error: obj\Debug\main.o: No such file or directory
g++.exe: fatal error: no input files
compilation terminated.
Process terminated with status 1 (0 minute(s), 0 second(s))
2 error(s), 0 warning(s) (0 minute(s), 0 second(s))
 
The problem is that the compiler doesn't create the main.o file and I can't see why

If that is the full rebuild log then your CB Project is bad!!!!

Is there a reason you told the project to not build the source file?

Edit: My guess is you did not rebuild the project and the Antivirus is causing the problem.
But, you could delete the "default.conf" file under "%APPDATA%\CodeBlocks" in case you realy did a full rebuild to delete a possibly bad configuration file. (Do this when Code::Blocks is not running) The next start of Code::Blocks will recreate the configuration file.

Tim S.
« Last Edit: April 30, 2020, 08:52:38 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline patraxbi

  • Multiple posting newcomer
  • *
  • Posts: 11
Re: Compiler Toolchain Setting seems to be ignored in Version 20.03
« Reply #17 on: April 30, 2020, 08:52:42 pm »
I didn't tell the project to not build the source file. that's the problem. it won't build it. I reinstalled code blocks 4 times already. I choosed the console project, I haven't made a modification and
hit build & run on the hello world program. So... how could I tell my project to build the source file ? I've never encountered such thing and I'm still learning programming. I barely know some OOP so I wouldn't have a reason to mess up with the settings

Offline patraxbi

  • Multiple posting newcomer
  • *
  • Posts: 11
Re: Compiler Toolchain Setting seems to be ignored in Version 20.03
« Reply #18 on: April 30, 2020, 09:02:31 pm »
I don't think is the antivirus. I have Bitdefender Total Security for almost one year and never did such thing. I'm gonna try find the ""%APPDATA%\CodeBlocks"" file

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7017
    • My Best Post
Re: Compiler Toolchain Setting seems to be ignored in Version 20.03
« Reply #19 on: April 30, 2020, 09:07:32 pm »
So, you never used rebuild or did a clean and then a build.
I go with the anti-virus being the cause.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline patraxbi

  • Multiple posting newcomer
  • *
  • Posts: 11
Re: Compiler Toolchain Setting seems to be ignored in Version 20.03
« Reply #20 on: April 30, 2020, 09:15:38 pm »
I deleted the default.conf , I entered codeblocks. went in the project. I cleared the project from "build" on that bar , then tried to build it. It won't work. I'm trying to see if it is Bitdefender's fault.

EDIT: OK, so I went through BITDEFENDER's notification and I couldn't find a thing. then I stopped the antivirus and tried do run codeblocks. it doesn't work either. Yeah.... could it be from something else other than the antivirus?  some other application which could interffere ?  I'm already sick of this
« Last Edit: April 30, 2020, 09:35:11 pm by patraxbi »

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7017
    • My Best Post
Re: Compiler Toolchain Setting seems to be ignored in Version 20.03
« Reply #21 on: April 30, 2020, 09:29:45 pm »
I deleted the default.conf , I entered codeblocks. went in the project. I cleared the project from "build" on that bar , then tried to build it. It won't work. I'm trying to see if it is Bitdefender's fault.

Do you not know what rebuild means!

Build -> Rebuild (CTRL + F11)

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline patraxbi

  • Multiple posting newcomer
  • *
  • Posts: 11
Re: Compiler Toolchain Setting seems to be ignored in Version 20.03
« Reply #22 on: April 30, 2020, 09:38:16 pm »
I deleted the default.conf , I entered codeblocks. went in the project. I cleared the project from "build" on that bar , then tried to build it. It won't work. I'm trying to see if it is Bitdefender's fault.

Do you not know what rebuild means!

Build -> Rebuild (CTRL + F11)

Tim S.


I know what rebuild means. I did that. I just suck at explaining things.
I've done build -> rebuild twice
and build -> clear and build -> build once

and in all of those cases it apeared the same build log.... I'm already sick of it.

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7017
    • My Best Post
Re: Compiler Toolchain Setting seems to be ignored in Version 20.03
« Reply #23 on: April 30, 2020, 09:50:01 pm »
This is what a real rebuild looks like.

Code: [Select]
-------------- Clean: Debug in testrebuild (compiler: GNU GCC Compiler)---------------

Cleaned "testrebuild - Debug"

-------------- Build: Debug in testrebuild (compiler: GNU GCC Compiler)---------------

x86_64-w64-mingw32-gcc.exe -Wall -g  -c C:\SourceCode\test\testrebuild\main.c -o obj\Debug\main.o
x86_64-w64-mingw32-gcc.exe  -o bin\Debug\testrebuild.exe obj\Debug\main.o   
Output file is bin\Debug\testrebuild.exe with size 295.02 KB
Process terminated with status 0 (0 minute(s), 5 second(s))
0 error(s), 0 warning(s) (0 minute(s), 5 second(s))

Edit add C++ rebuild
Code: [Select]
-------------- Clean: Debug in testcpprebuild (compiler: GNU GCC Compiler)---------------

Cleaned "testcpprebuild - Debug"

-------------- Build: Debug in testcpprebuild (compiler: GNU GCC Compiler)---------------

x86_64-w64-mingw32-g++.exe -Wall -fexceptions -g  -c C:\SourceCode\test\testcpprebuild\main.cpp -o obj\Debug\main.o
x86_64-w64-mingw32-g++.exe  -o bin\Debug\testcpprebuild.exe obj\Debug\main.o   
Output file is bin\Debug\testcpprebuild.exe with size 315.35 KB
Process terminated with status 0 (0 minute(s), 6 second(s))
0 error(s), 0 warning(s) (0 minute(s), 6 second(s))
« Last Edit: April 30, 2020, 09:55:47 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7017
    • My Best Post
Re: Compiler Toolchain Setting seems to be ignored in Version 20.03
« Reply #24 on: April 30, 2020, 09:53:40 pm »
You must understand!

You do not know how to use Code Tags.
You do not know how to start a new thread.
But, you are positive the anti-virus is not the cause.

You have failed to post a full rebuild log.
No idea why you have failed; till we get one the only guess we have is user error or the Anti-virus is causing the problem.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline patraxbi

  • Multiple posting newcomer
  • *
  • Posts: 11
Re: Compiler Toolchain Setting seems to be ignored in Version 20.03
« Reply #25 on: April 30, 2020, 10:06:33 pm »
yeah... if u mean "build > clean", "build > build" or "build > run" or " file > new" by code tags, I just forgot 'bout them. I know how to start a new thread but this seemed like my problem... but it defenetly isn't.

So, i just tried to compile the main.cpp in command prompt with
g++.exe main.cpp  because code blocks wouldn't give me a full rebuild log
and a error occured: "The code execution cannot proceed because libwinpthread-1.dll was not found. Reinstalling the program may fix this problem"


EDIT: misspelling

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7017
    • My Best Post
Re: Compiler Toolchain Setting seems to be ignored in Version 20.03
« Reply #26 on: April 30, 2020, 10:08:17 pm »
Please use only ASCII characters in the path without and spaces!!!!!!!!!!!!!!

C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7017
    • My Best Post
Re: Compiler Toolchain Setting seems to be ignored in Version 20.03
« Reply #27 on: April 30, 2020, 10:09:22 pm »
It is either path with spaces or other non-ascii characters or an antivirus software causing this. Which one is for your case?

Bye!!!!

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline patraxbi

  • Multiple posting newcomer
  • *
  • Posts: 11
Re: Compiler Toolchain Setting seems to be ignored in Version 20.03
« Reply #28 on: April 30, 2020, 10:10:48 pm »
i copy pasted the path from windows 10' explorer. I'm gonna rename it and try it again to see if that's the problem but usually it never affected if directory's name was "this is just some shit code"

Offline stahta01

  • Lives here!
  • ****
  • Posts: 7017
    • My Best Post
Re: Compiler Toolchain Setting seems to be ignored in Version 20.03
« Reply #29 on: April 30, 2020, 10:12:06 pm »
Quote
"The code execution cannot proceed because libwinpthread-1.dll was not found.

This likely means your Compiler installation is broken; but, till you STOP USING non-ASCII path you can not be sure of that.

Please ask questions when you say things that are lies I start to believe you are a troll or a help vampire!!!

Tim S.
 
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org