Author Topic: Having very little code completion  (Read 1552 times)

Offline carra

  • Multiple posting newcomer
  • *
  • Posts: 114
Having very little code completion
« on: August 31, 2015, 03:22:58 pm »
I haven't been coding in C++ much since some time ago, but I have noticed that, ever since the code completion system was upgraded, I have been getting little to no completion in C++ projects that, before this change, worked perfectly in Code::Blocks. Man, is it time consuming having to check the headers manually!

I run Windows 7 64bit in both of the machines where I run C::B, and I have been getting this behavior in nightly builds from at least 9884, and until some of the latest (around 10300). I have also tried to fix the problem by deleting default.conf and making a fully fresh install, and by tweaking the parser settings. The only difference I have seen is that the problem seems worse when I enable per-project C++ parsers instead of a single workspace parser.

I have attached a very simple C++ project to see if you can reproduce the problem (shown in the 3 zipped images), as well as my current configurations. The 4th image, outside the ZIP, shows a different case that I have noticed in a more complex project, in which a member objects seems to be mistaken by a function because of the initialization list used above.

Hope I have given you enough detail ;)
« Last Edit: August 31, 2015, 03:36:57 pm by carra »

Offline carra

  • Multiple posting newcomer
  • *
  • Posts: 114
Re: Having very little code completion
« Reply #1 on: August 31, 2015, 03:27:23 pm »
PD: Sorry to double post, but it seems the forum won't let me add both files in the same message. The ZIP file is attached here now.