Author Topic: Bug in nsis script for installer  (Read 3894 times)

Offline scarphin

  • Lives here!
  • ****
  • Posts: 644
Bug in nsis script for installer
« on: August 29, 2015, 01:39:36 am »
Current nsis script for installer lacks the line:
Code: [Select]
Delete /REBOOTOK $INSTDIR\wxmsw${WX_VER}u_gcc_cb.dllafter/around:
Code: [Select]
${If} ${WX_VER} == "28"
    Delete /REBOOTOK $INSTDIR\wxpropgrid.dll
${EndIf}

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12090
    • Travis build status
Re: Bug in nsis script for installer
« Reply #1 on: August 30, 2015, 10:19:01 pm »
Patch?
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]

Offline scarphin

  • Lives here!
  • ****
  • Posts: 644
Re: Bug in nsis script for installer
« Reply #2 on: August 31, 2015, 01:21:41 pm »
My local nsis script is modified, I can't isolate the changes to provide a patch. Sorry...

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9508
Re: Bug in nsis script for installer
« Reply #3 on: August 31, 2015, 05:50:21 pm »
My local nsis script is modified, I can't isolate the changes to provide a patch. Sorry...
Nevermind, fixed in SVN.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Online stahta01

  • Lives here!
  • ****
  • Posts: 6667
    • My Best Post
Re: Bug in nsis script for installer
« Reply #4 on: September 01, 2015, 12:43:49 pm »
My local nsis script is modified, I can't isolate the changes to provide a patch. Sorry...
Nevermind, fixed in SVN.

Can you tell me where to find AdvSplash NSIS Plugin?

Code: [Select]
ReserveFile: "C:\Program Files\NSIS\Plugins\x86-ansi\AdvSplash.dll" -> no files found.
« Last Edit: September 01, 2015, 01:02:38 pm by stahta01 »
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9508
Re: Bug in nsis script for installer
« Reply #5 on: September 01, 2015, 02:36:15 pm »
You'll need to use nsis 3.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ

Offline scarphin

  • Lives here!
  • ****
  • Posts: 644
Re: Bug in nsis script for installer
« Reply #6 on: September 26, 2015, 12:20:58 am »
I didn't want to create another topic but I think I found an inconsistency in the nsis script. The 'symsrv.yes' file is copied by the 'update.bat' from 'exchndl\win32\bin\' to the 'devel' folder but not to the 'output' folder. Yet the nsis script looks for that file in a path which probably refers to the 'output' folder. Maybe update the 'update.bat' to copy that file also to the 'output' folder so the nsis script works? Or am I missing something?

Offline MortenMacFly

  • Administrator
  • Lives here!
  • *****
  • Posts: 9508
Re: Bug in nsis script for installer
« Reply #7 on: October 01, 2015, 08:06:39 am »
I didn't want to create another topic but I think I found an inconsistency in the nsis script.
Should be fixed in trunk now.
Compiler logging: Settings->Compiler & Debugger->tab "Other"->Compiler logging="Full command line"
C::B Manual: http://www.codeblocks.org/docs/main_codeblocks_en.html
C::B FAQ: http://wiki.codeblocks.org/index.php?title=FAQ