Author Topic: Can't install Plugin  (Read 4161 times)

Offline threeS

  • Multiple posting newcomer
  • *
  • Posts: 36
Can't install Plugin
« on: October 17, 2014, 11:00:14 pm »
I installed my plugin but it gives me a warning like
Quote
One or more plugins were not loaded. This usually happens when a plugin is built for a different version of the Code::Blocks SDK.
Check the application log for more info.
and where i can find the application log?

Thank you for the help  :)

Online stahta01

  • Lives here!
  • ****
  • Posts: 6995
    • My Best Post
Re: Can't install Plugin
« Reply #1 on: October 17, 2014, 11:50:01 pm »
I believe that is the log window titled "Code::Blocks" on my PC it is the rightmost log window.

Tim S.
C Programmer working to learn more about C++ and Git.
On Windows 7 64 bit and Windows 10 32 bit.
On Debian Stretch, compiling CB Trunk against wxWidgets 3.0.
--
When in doubt, read the CB WiKi FAQ. http://wiki.codeblocks.org

Offline threeS

  • Multiple posting newcomer
  • *
  • Posts: 36
Re: Can't install Plugin
« Reply #2 on: October 17, 2014, 11:57:45 pm »
Quote
log window titled "Code::Blocks" on my PC it is the rightmost log window
Im using ubuntu OS and it shows it is in the leftmost log window, but anyways thanks!

the error says
Quote
plugin.so: not loaded (missing symbols?)

BTW, it happens when we put postgres query in the plugin code (#include <postgresql/libpq-fe.h>)

Offline oBFusCATed

  • Developer
  • Lives here!
  • *****
  • Posts: 12810
    • Travis build status
Re: Can't install Plugin
« Reply #3 on: October 18, 2014, 12:35:03 am »
Use -Wl,--no-undefined or -z defs in the linker options and you'll see what you're doing wrong.
(most of the time I ignore long posts)
[strangers don't send me private messages, I'll ignore them; post a topic in the forum, but first read the rules!]