Author Topic: [SOVLED]How to install CodeBlocks in CentOS-7 x64?  (Read 24428 times)

Offline yaoyansi

  • Multiple posting newcomer
  • *
  • Posts: 31
[SOVLED]How to install CodeBlocks in CentOS-7 x64?
« on: August 29, 2014, 05:38:14 pm »
Hi all,
I'm trying to install CodeBlocks in CentOS7 x64,
but it seems that CodeBlocks doesn't release the the binary package for CentOS7, right?

So, my question is:
Could I install codeblocks-13.12-1.el6.x86_64.tar.xz in CentOS7 x64?
If not, when the package for CentOS7 will be available?

Cheers
yaoyansi

P.S.
In fact, I've tried installing codeblocks-13.12-1.el6.x86_64.tar.xz in CentOS7 x64, but failed. It complains:
warning: ./codeblocks-13.12-1.el6.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 6eeb25c9: NOKEY
error: Failed dependencies:
   libwx_baseu-2.8.so.0()(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_baseu-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_baseu-2.8.so.0(WXU_2.8.2)(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_baseu_net-2.8.so.0()(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_baseu_net-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_baseu_xml-2.8.so.0()(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_gtk2u_adv-2.8.so.0()(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_gtk2u_aui-2.8.so.0()(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_gtk2u_core-2.8.so.0()(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_gtk2u_core-2.8.so.0(WXU_2.8.5)(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_gtk2u_core-2.8.so.0(WXU_2.8.8)(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_gtk2u_html-2.8.so.0()(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_gtk2u_qa-2.8.so.0()(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_gtk2u_richtext-2.8.so.0()(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_gtk2u_xrc-2.8.so.0()(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit) is needed by codeblocks-13.12-1.el6.x86_64
   wxGTK >= 2.8.0 is needed by codeblocks-13.12-1.el6.x86_64
« Last Edit: August 30, 2014, 11:13:30 am by yaoyansi »

Offline jens

  • Administrator
  • Lives here!
  • *****
  • Posts: 7253
    • Jens' unofficial debian-repository for the Code::Blocks - IDE
Re: How to install CodeBlocks in CentOS-7 x64?
« Reply #1 on: August 29, 2014, 06:57:26 pm »
Use my repo (see signature) and install a nightly.

I did not (yet?) build the 13.12-release for CentOS/RedHat 7 and I do not know whether I will do it.

Offline yaoyansi

  • Multiple posting newcomer
  • *
  • Posts: 31
Re: How to install CodeBlocks in CentOS-7 x64?
« Reply #2 on: August 29, 2014, 09:39:33 pm »
Hi, jens
Thanks for your reply.

But I encountered a problem when I install your package.

I update my system at first.
[[email protected] yum.repos.d]# yum update

Then I tried installing codeblocks.
[[email protected] yum.repos.d]# yum install codeblocks
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirrors.grandcloud.cn
 * extras: mirrors.pubyun.com
 * rpmforge: ftp.riken.jp
 * rpmforge-extras: ftp.riken.jp
 * updates: mirrors.pubyun.com
Resolving Dependencies
--> Running transaction check
---> Package codeblocks.x86_64 0:13.12.svn.9857-1.el7 will be installed
--> Processing Dependency: codeblocks-libs(x86-64) = 13.12.svn.9857 for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: wxGTK >= 2.8.0 for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8.2)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu_net-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_core-2.8.so.0(WXU_2.8.5)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu_net-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_xrc-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_html-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libcodeblocks.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_adv-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu_xml-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_richtext-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_aui-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_qa-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_core-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Running transaction check
---> Package codeblocks.x86_64 0:13.12.svn.9857-1.el7 will be installed
--> Processing Dependency: wxGTK >= 2.8.0 for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8.2)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu_net-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_core-2.8.so.0(WXU_2.8.5)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu_net-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_xrc-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_html-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_adv-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu_xml-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_richtext-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_aui-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_qa-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_core-2.8.so.0()(64bit) for package: codeblocks-13.12.svn.9857-1.el7.x86_64
---> Package codeblocks-libs.x86_64 0:13.12.svn.9857-1.el7 will be installed
--> Processing Dependency: libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8.2)(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu_net-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_core-2.8.so.0(WXU_2.8.5)(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu_net-2.8.so.0()(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_xrc-2.8.so.0()(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_html-2.8.so.0()(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_adv-2.8.so.0()(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu_xml-2.8.so.0()(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_baseu-2.8.so.0()(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_richtext-2.8.so.0()(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_aui-2.8.so.0()(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_qa-2.8.so.0()(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Processing Dependency: libwx_gtk2u_core-2.8.so.0()(64bit) for package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_html-2.8.so.0()(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_baseu_xml-2.8.so.0()(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_richtext-2.8.so.0()(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_core-2.8.so.0(WXU_2.8.5)(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_baseu_net-2.8.so.0()(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_baseu_xml-2.8.so.0()(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_baseu-2.8.so.0()(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_core-2.8.so.0()(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_xrc-2.8.so.0()(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_baseu-2.8.so.0(WXU_2.8.2)(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_baseu_net-2.8.so.0()(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_baseu-2.8.so.0()(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_qa-2.8.so.0()(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_baseu-2.8.so.0(WXU_2.8.2)(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_adv-2.8.so.0()(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_richtext-2.8.so.0()(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_aui-2.8.so.0()(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_xrc-2.8.so.0()(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_core-2.8.so.0(WXU_2.8.5)(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: wxGTK >= 2.8.0
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_aui-2.8.so.0()(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_baseu-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_qa-2.8.so.0()(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_adv-2.8.so.0()(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_baseu_net-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_html-2.8.so.0()(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_core-2.8.so.0()(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-libs-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_baseu-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_baseu_xml-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_baseu_net-2.8.so.0(WXU_2.8)(64bit)
Error: Package: codeblocks-13.12.svn.9857-1.el7.x86_64 (jenslody.de)
           Requires: libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


------------------------------------------------------------
It seems that EPEL and repoforge both have wxGTK, and I have already added EPEL and repoforge in my CentOS7.
[[email protected] yum.repos.d]# ls
adobe-linux-x86_64.repo  CentOS-Debuginfo.repo         centos-jenslody.de.repo  elrepo.repo              mirrors-rpmforge-testing
CentOS-Base.repo         CentOS-Debuginfo.repo.rpmnew  CentOS-Sources.repo      mirrors-rpmforge         rpmforge.repo
CentOS-Base.repo.rpmnew  CentOS-fasttrack.repo         CentOS-Vault.repo        mirrors-rpmforge-extras
[[email protected] yum.repos.d]#
-------------------------------------------------------
[[email protected] yum.repos.d]# cat elrepo.repo
### Name: ELRepo.org Community Enterprise Linux Repository for el7
### URL: http://elrepo.org/

[elrepo]
name=ELRepo.org Community Enterprise Linux Repository - el7
baseurl=http://elrepo.org/linux/elrepo/el7/$basearch/
   http://mirrors.coreix.net/elrepo/elrepo/el7/$basearch/
   http://jur-linux.org/download/elrepo/elrepo/el7/$basearch/
   http://repos.lax-noc.com/elrepo/elrepo/el7/$basearch/
   http://mirror.ventraip.net.au/elrepo/elrepo/el7/$basearch/
mirrorlist=http://mirrors.elrepo.org/mirrors-elrepo.el7
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-elrepo.org
protect=0
#priority = 10

[elrepo-testing]
name=ELRepo.org Community Enterprise Linux Testing Repository - el7
baseurl=http://elrepo.org/linux/testing/el7/$basearch/
   http://mirrors.coreix.net/elrepo/testing/el7/$basearch/
   http://jur-linux.org/download/elrepo/testing/el7/$basearch/
   http://repos.lax-noc.com/elrepo/testing/el7/$basearch/
   http://mirror.ventraip.net.au/elrepo/testing/el7/$basearch/
mirrorlist=http://mirrors.elrepo.org/mirrors-elrepo-testing.el7
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-elrepo.org
protect=0
#priority = 11

[elrepo-kernel]
name=ELRepo.org Community Enterprise Linux Kernel Repository - el7
baseurl=http://elrepo.org/linux/kernel/el7/$basearch/
   http://mirrors.coreix.net/elrepo/kernel/el7/$basearch/
   http://jur-linux.org/download/elrepo/kernel/el7/$basearch/
   http://repos.lax-noc.com/elrepo/kernel/el7/$basearch/
   http://mirror.ventraip.net.au/elrepo/kernel/el7/$basearch/
mirrorlist=http://mirrors.elrepo.org/mirrors-elrepo-kernel.el7
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-elrepo.org
protect=0
#priority = 10

[elrepo-extras]
name=ELRepo.org Community Enterprise Linux Extras Repository - el7
baseurl=http://elrepo.org/linux/extras/el7/$basearch/
   http://mirrors.coreix.net/elrepo/extras/el7/$basearch/
   http://jur-linux.org/download/elrepo/extras/el7/$basearch/
   http://repos.lax-noc.com/elrepo/extras/el7/$basearch/
   http://mirror.ventraip.net.au/elrepo/extras/el7/$basearch/
mirrorlist=http://mirrors.elrepo.org/mirrors-elrepo-extras.el7
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-elrepo.org
protect=0
#priority = 10
[[email protected] yum.repos.d]#


---------------------------------------------------------------------------------
[[email protected] yum.repos.d]# cat rpmforge.repo
### Name: RPMforge RPM Repository for RHEL 7 - dag
### URL: http://rpmforge.net/
[rpmforge]
name = RHEL $releasever - RPMforge.net - dag
baseurl = http://apt.sw.be/redhat/el7/en/$basearch/rpmforge
mirrorlist = http://mirrorlist.repoforge.org/el7/mirrors-rpmforge
#mirrorlist = file:///etc/yum.repos.d/mirrors-rpmforge
enabled = 1
protect = 0
gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag
gpgcheck = 1
#priority = 20

[rpmforge-extras]
name = RHEL $releasever - RPMforge.net - extras
baseurl = http://apt.sw.be/redhat/el7/en/$basearch/extras
mirrorlist = http://mirrorlist.repoforge.org/el7/mirrors-rpmforge-extras
#mirrorlist = file:///etc/yum.repos.d/mirrors-rpmforge-extras
enabled = 1
protect = 0
gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag
gpgcheck = 1
#priority = 20

[rpmforge-testing]
name = RHEL $releasever - RPMforge.net - testing
baseurl = http://apt.sw.be/redhat/el7/en/$basearch/testing
mirrorlist = http://mirrorlist.repoforge.org/el7/mirrors-rpmforge-testing
#mirrorlist = file:///etc/yum.repos.d/mirrors-rpmforge-testing
enabled = 0
protect = 0
gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag
gpgcheck = 1
#priority = 21
[[email protected] yum.repos.d]#


--------------------------------------------------------------------
But I can't install wxGTK with yum.
[[email protected] yum.repos.d]# yum install wxGTK
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirrors.grandcloud.cn
 * extras: mirrors.grandcloud.cn
 * rpmforge: mirrors.digipower.vn
 * rpmforge-extras: mirrors.digipower.vn
 * updates: mirrors.grandcloud.cn
No package wxGTK available.
Error: Nothing to do


What can I do now? how to install the libwx* files?

Cheers
yaoyansi

Offline yaoyansi

  • Multiple posting newcomer
  • *
  • Posts: 31
Re: How to install CodeBlocks in CentOS-7 x64?
« Reply #3 on: August 30, 2014, 10:22:12 am »
I'm sorry, I forgot to  enable elrepo.

now elrepo.repo  is:
[[email protected] yum.repos.d]# cat elrepo.repo
### Name: ELRepo.org Community Enterprise Linux Repository for el7
### URL: http://elrepo.org/

[elrepo]
name=ELRepo.org Community Enterprise Linux Repository - el7
baseurl=http://elrepo.org/linux/elrepo/el7/$basearch/
   http://mirrors.coreix.net/elrepo/elrepo/el7/$basearch/
   http://jur-linux.org/download/elrepo/elrepo/el7/$basearch/
   http://repos.lax-noc.com/elrepo/elrepo/el7/$basearch/
   http://mirror.ventraip.net.au/elrepo/elrepo/el7/$basearch/
mirrorlist=http://mirrors.elrepo.org/mirrors-elrepo.el7
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-elrepo.org
protect=0
#priority = 10

[elrepo-testing]
name=ELRepo.org Community Enterprise Linux Testing Repository - el7
baseurl=http://elrepo.org/linux/testing/el7/$basearch/
   http://mirrors.coreix.net/elrepo/testing/el7/$basearch/
   http://jur-linux.org/download/elrepo/testing/el7/$basearch/
   http://repos.lax-noc.com/elrepo/testing/el7/$basearch/
   http://mirror.ventraip.net.au/elrepo/testing/el7/$basearch/
mirrorlist=http://mirrors.elrepo.org/mirrors-elrepo-testing.el7
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-elrepo.org
protect=0
#priority = 11

[elrepo-kernel]
name=ELRepo.org Community Enterprise Linux Kernel Repository - el7
baseurl=http://elrepo.org/linux/kernel/el7/$basearch/
   http://mirrors.coreix.net/elrepo/kernel/el7/$basearch/
   http://jur-linux.org/download/elrepo/kernel/el7/$basearch/
   http://repos.lax-noc.com/elrepo/kernel/el7/$basearch/
   http://mirror.ventraip.net.au/elrepo/kernel/el7/$basearch/
mirrorlist=http://mirrors.elrepo.org/mirrors-elrepo-kernel.el7
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-elrepo.org
protect=0
#priority = 10

[elrepo-extras]
name=ELRepo.org Community Enterprise Linux Extras Repository - el7
baseurl=http://elrepo.org/linux/extras/el7/$basearch/
   http://mirrors.coreix.net/elrepo/extras/el7/$basearch/
   http://jur-linux.org/download/elrepo/extras/el7/$basearch/
   http://repos.lax-noc.com/elrepo/extras/el7/$basearch/
   http://mirror.ventraip.net.au/elrepo/extras/el7/$basearch/
mirrorlist=http://mirrors.elrepo.org/mirrors-elrepo-extras.el7
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-elrepo.org
protect=0
#priority = 10
[[email protected] yum.repos.d]#



But wxGTK is still can't be installed, here is the log.
[[email protected] yum.repos.d]# yum install wxGTK
Loaded plugins: fastestmirror, langpacks
elrepo                                                                         | 2.9 kB  00:00:00     
elrepo-extras                                                                  | 2.9 kB  00:00:00     
elrepo-kernel                                                                  | 2.9 kB  00:00:00     
elrepo-testing                                                                 | 2.9 kB  00:00:00     
Loading mirror speeds from cached hostfile
 * base: mirrors.hust.edu.cn
 * centosplus: mirrors.hust.edu.cn
 * elrepo: ftp.ne.jp
 * elrepo-extras: ftp.ne.jp
 * elrepo-kernel: ftp.ne.jp
 * elrepo-testing: ftp.ne.jp
 * extras: mirrors.hust.edu.cn
 * updates: ftp.tc.edu.tw
No package wxGTK available.
Error: Nothing to do

Offline yaoyansi

  • Multiple posting newcomer
  • *
  • Posts: 31
Re: How to install CodeBlocks in CentOS-7 x64?
« Reply #4 on: August 30, 2014, 11:13:09 am »
SOLVED:
I have to install epel repo.

- Download and install the latest epel-release rpm from
http://dl.fedoraproject.org/pub/epel/7/x86_64/epel-release-7-1.noarch.rpm

- Install wxGTK rpm package:
# yum install wxGTK

It works now.

Thank you.